Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Appliances, vmware and multipathing

Created: 17 Apr 2013 • Updated: 10 Jul 2013 | 4 comments
This issue has been solved. See solution.

Hi all

I'm seeing a lot of folk buying appliances and finding out that they can't use both of the HBAs with VMware vStorage API because multipathing is not supported on the appliance. Whilst "this may be supported in a future release", I'm wondering what you guys are doing in the meantime to be able to use san transfer method with vmware backups?

Does single processessor/port/HBA zoning present a single, usable path for example? Or are you still bound by multiple ports used on the storage processor side?

Thanks

Chris

Operating Systems:

Comments 4 CommentsJump to latest comment

Ed Carter's picture

We're on a Clarrion CX4 which isn't true ALUA so really need it to have access to both SP's. We get a lot of noise re conflicts etc on the 5220 messages though as yet haven't experienced any actual issues with the backups though makes you wonder what impact its having on potential throughput. Its a bit of a challange which we are trying to line up a call with Symantec on via our account manager. I'll post back if we get anywhere. Really interested to hear how others have configured, in particular on Clarrion or VNX arrays.

Ed

teiva-boy's picture

I'm really surprised since Storage Foundation is such a big part of these appliances, that it cannot be unlocked or available to be installed.

EIther Symantec hasn't a clue of the business requirement, doesn't care, or is trying to monetize it down the road as an add-on.

With PureDisk (not the 5000 series boxes) you could do multipathing.  I believe even normal NBU supports it.  But not the appliances.  

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) http://mysupport.symantec.com "We backup data to restore, we don't backup data just to back it up."

Andrew Madsen's picture

The issue is not on Symantec's side but on VMWare's side. Their API is chingered and does not handle the dual path from ANY Linux host used as a VMware backup server, be it an appliance or a build your own. Has nothing to do with DMP or multipath, or PowerPath or anything else. So they are waiting for VMware to fix the issue. 

The above comments are not to be construed as an official stance of the company I work for; hell half the time they are not even an official stance for me.

SOLUTION
Mark_Solutions's picture

In my experience user still have multiple paths to the appliance because they have to - vmotion etc!

It does cause a lot of logging to be generated but can also have other side effects

The process leaks memory semaphores which can cause an appliance to run out of memory, failed backups get the vmdk's left in /tmp etc.

Not all directly related as such but the side effects i have seen is memory and disk space related so if you can not multi-path it would be best not to until VMWare bring out a fix

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.