Video Screencast Help

Application connection failed for servername\. Please select a different SQL Server host and instance, or press 'cancel' to exit the NetbAckup for SQL Server Graphical User Interface.

Created: 28 Mar 2011 • Updated: 29 Mar 2013 | 15 comments

I have seen this topic before, but I am not resolving with the resolutions I have seen on-line. Running NetBackup 6.5.5 and trying to set up the SQL agent for MS SQL 2008 on a Windows 2008R2 server. I have checked UAC, using an account with sysadmin server role and making sure to "Run As Administrator". The weird thing is the SQL version, etc., it all says Unknown, like there is some permission or something that prevents the agent from even seeing the SQL instance. Also new to this.

Comments 15 CommentsJump to latest comment

Marianne's picture

Have you tried to specify 'sa' as user id and sa's password in the bottom of the GUI?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Tim Hansen's picture

Those fields you highlighted will propagate with the correct information after you have supplied proper credentials at the bottom of the window and hit Apply.

mmichael's picture

Well, there lies my issue, I cannot get anything but the error above when I hit apply. I was using sa at first, then went with SQL and Windows accounts, all of which have sysadmin role.

MommaMo's picture

Any resolution yet?  I am encountering the same exact scenario.  I am running on Windows 2008 Std.  32-bit.  This same error happens with both 6.55 and 7.1. 

mohanty's picture

My Master server is Window 2003 Std. + Netbackup 7.1 and I am trying to connect SQL 2005 std. instance installed in Window 2008 R2 server. Please help!!!

I tried to connect Netbackup SQL Extension from Client and it is successfully connected but when I am trying to Restore database which is in another server it failed saying " unable retrieve required images due to lack of permission"

I am still unable to take backup.

Oddy's picture

Hi,

1. Make sure that you are logged in as a member of the local administrator on the sql server, and that Builtin\Administrator has sysadmin rights in the SQL studio manager. Check under the properties for the builtin\administrator, Security, Login, Server Roles. Take a note of the server name when you are connect to sql server manager, make sure that you use the same sql server name when you try to connect in the Netbackup MSSQL Database gui.

2. Check if the UAC is enabled or not on the SQL server, login as local administrator and open the Control Panel, User Accounts, Turn User Accoutn Control on or off.

3. When you open the Netbackup MSSQL Databse gui, right click on the Icon and select Run as Administrator and type in the sql host name and see if it works.

If all this fail, create log directory <install dir>\netbackup\dbclient on the sql server, increase the verbose level, open the BAR gui and go to File, Netbackup Client Properties, Troubleshooting, change General to 2, Verbose to 5 and Database to 9.  Try to open the Netbackup MSSQL database gui again and recreate problem and checkout the log files created in the dbclient folder.

Problem might be with the sqlvdi.dll file, check that you have installed the latest hotfix from Microsoft.

I hope this helps.

/Oddy

mohanty's picture

Thanks Oddy for the description but I am still unable to connect...

Is this happening because of my master server in Window 2003 and Client is Window 2008 server?

Oddy's picture

 

No, I do not think that problem is the master server. Check the dbclient log on the client, and check if you have any sqlvdi errors in the application log in the event viewer.

Are you able to open and connect to the SQL Studio Manager ?

/Oddy

Marianne's picture

Hopefully this has been resolved by now?

I found an o-l-d TN that could possibly be relevant :

http://www.symantec.com/docs/TECH31849

and http://www.symantec.com/docs/TECH24811

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

florin.s's picture

hi,

i got this issue on a server 2008 R2 with SQL 2008 R2 on which i've waisted like half an hour until i found this post :)

the "run as administrator" solved it.

thanks Oddy