Video Screencast Help

Archive search not exporting results

Created: 07 Jan 2013 • Updated: 08 Jan 2013 | 6 comments
This issue has been solved. See solution.

Hello

 

I have an issue trying to perform a search for a client. I have to use the browser search as unfortunately the client does not have Discovery Accelerator in the environment.

The issue is that although I am able to get results based on the search criteria, I am unable to export the results either to PST file or back into the mailbox. There are no errors logged in the event viewer so I am unsure as to why it is not exporting the results.

The challenge is that the environment is an Exchange 2007 with EV 7.5, however the client are in the process of migrating to Exchange 2010 and EV.cloud.

I don't believe that the journal mailbox has been migrated as yet, although I need to confirm that with the Exchange team and I was wondering if anyone has any ideas on this?

 

Thanks in advance.

 

Comments 6 CommentsJump to latest comment

Rob.Wilcox's picture

Have you implemented:

 

http://thingsilearnedtoday.net/2009/12/09/restoring-to-pst/

 

Do you see the basket restore as shown in the screenshots?

AlanJ's picture

The option is there as I have done searches in the past without any issue.

I am able to kick off the restore and the basket status will change to "Restoring" but nothing gets created in the destination folder and basket remains in the restoring state.

When restoring to the mailbox, the items do not appear either in the original location or to the "Restored Items" folder.

 

 

Rob.Wilcox's picture

Okay so your issue is somewhat wider spread than not being able to export the items to a PST file via the web browser.  From what you said you can't restore an item to the mailbox either.

 

Have you tried export archive?  I mean if your goal is to get the data in to a PST that would fit the bill, right?

 

You might also want to try a basket restore when dtracing the following:

RetrievalTask

StorageRestore

ShoppingService

 

 

TonySterling's picture

It sounds to me like your EV Servers may be set to Read-Only mode.  Prior to EV 8 registry keys were set to prevent items from being archived.

Look for EnableRestore in the HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Storage

DWORD value:
0 — Component disabled
1 — Component enabled (Default)

Enables or disables the StorageRestore component of the Enterprise Vault Storage Service. By disabling the component, you can prevent any StorageRestore processes from starting when an Enterprise Vault Storage Service starts.

If that is set to 0 then change it to 1 and restart the Storage service.  That will allow restores to complete successfully. The others can remain set to 0.

 

SOLUTION
AlanJ's picture

I overlooked that one. The server had moved between data centres recently and was put in read-only mode before the move and not reverted after the move. Thought it was changed, but obviously was not, so never thought about it.

Upon the service restart, SQL errors began to be logged.

Long story short, there was an issue with the SQL instance which then wreaked havoc, however once the DBA rectified the situation, the searches started to export their respective results.

Not sure how long the SQL issue existed as it only started throwing errors after the service was restarted.