Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Archived emails outside LAN

Created: 13 Jan 2013 • Updated: 15 Jan 2013 | 2 comments
This issue has been solved. See solution.

Good afternoon,

I think I have tried everything but just cannot seem to get a break with this problem of getting Outlook and archived emails to work outside of my LAN. I have two problems that I think may just be the same issue. I have Outlook working internally with the add-in and OWA working perfect inside and externally on IE (not safari or chrome?) but have these two major hurdles

Issue 1:

Getting archived email on any non-standard email clients, ex: IOS devices. The archived emails are listed in the user mailbox with the custom shortcuts but the link is wrong, it is referencing the internal server name.

Ex:

"This message has been archived. Click here to view the original item >link< http://evserver.internaldomain.local.com/enterprisevault/etc......"

Since this references the internal server and LAN of course no external clients can link to it. So none of my iPad users can get old emails and any browser that relies on that link also fails.

OWA works fine inside and outside on IE browsers, it is https://mail.externaldomain.com/. All archived emails open no problem, however if you click the link in the reading preview pane instead of opening the email i.e.: “Click here to view the original item >link< http://evserver.internaldomain.local.com/enterprisevault/etc....” It fails, since it again tries to use the EV servers internal name outside the LAN.

What do I have to modify to get this shortcut link correct? If I can fix it going forward then I can always recreate the old shortcuts if I have to.

Issue 2:

Outlook with the Add-In works fine on my LAN, however outside using Outlook with HTTPS we cannot get any archived emails with the add-in and the internal link reference fails due to the internal server name reference again I assume.

Environment Info:

  • Enterprise Vault 10.01.1171 installed on Win2008r2
  • Exchange 2010 ver 14.02.0318.004 installed on Win2008r2
  • Outlook 2010
  • OWA example: https://mail.externaldoamin.com/
  • FQDN vault server name example: evserver.internaldomain.local.com

Thank you

Jim

 

Comments 2 CommentsJump to latest comment

JesusWept3's picture

Issue 1:
This is absolutely expected behavior, its just like any regular link that you would paste in an email and is hardcoded and not dymanic.

For users using OWA, you could use ISA/TMG Link Translation:
http://technet.microsoft.com/en-us/library/cc984424.aspx

e.g. http://evserver.internal.com/EnterpriseVault/viewMessage.asp gets converted to https://mail.myDomain.com/EnterpriseVault/ViewMessage.asp

For iOS and Blackberry and other mobile devices, you can either use EV Mobile which is just a search interface but is included in the install binaries. The install documentation and getting started can be found here:
http://www.symantec.com/business/support/resources/sites/BUSINESS/content/live/TECHNICAL_SOLUTION/72000/TECH72590/en_US/328452.pdf

For a richer mobile experience, you can check out CommonDesk's  paid for solution:
http://www.commondesk.com/products/mobile-access-products/arcviewer-for-iphone-and-ipad

But again, its not free....and in the future there are plans for any mail client that supports IMAP to be able to browse their archive through the imap interface (so that includes iphone, thunderbird, even outlook express) ......but theres no timeline set for when that will be available and not what the functionality will be.

Issue 2:
Simply publish the /EnterpriseVault/ from one of your EV Servers....
So you would have https://mail.myDomain.com/EnterpriseVault/ -> http://evServer.internal.dom/EnterpriseVault/

Then in your desktop policies set the RPC over HTTPS URL to be https://mail.myDomain.com/EnterpriseVault/ and ensure that Outlook Anywhere is enabled in the Outlook client in order for it to work.

If you use https on the backend EV Server, you will have to ensure that your SSL certificate caters for the name change of the server, because if the SSL is configured for evserver.internal.dom, but you're accessing it through mail.myDomain.com, then  name conflict will be thrown

SOLUTION
JesusWept3's picture

For publishing the /EnterpriseVault/ virtual directory, you can find the technote here:
http://www.symantec.com/business/support/index?page=content&id=HOWTO59068