Video Screencast Help

Archived items not being indexed

Created: 28 Aug 2012 • Updated: 08 Dec 2012 | 3 comments
This issue has been solved. See solution.

Within the last couple of weeks one of my vault store DBs started showing error 41021. Then the rest started showing the error.

 

I have ran a couple of SQL Queries that have been posted like:

 

 

use EnterpriseVaultDirectory
select VaultEntryId,ArchiveName,FolderName from IndexVolumeView IVV
where IVV.VaultEntryId in (select distinct AP.ArchivePointId from  EVVSUSHREVEMAVS01_1..ArchivePoint AP
inner join EVVSUSHREVEMAVS01_1..JournalArchive JA
on AP.ArchivePointIdentity = JA.ArchivePointIdentity
and JA.IndexCommited = 0)
 
and
 
USE EVVSUSHREVEMAVS03_5
SELECT *
FROM JournalArchive
WHERE IndexCommited = 0
 

Both of course return results. the first query shows that the archived items are not being committed.

We have done a lot of the basic troubleshooting, restarting servers...firewalls...nothing has helped to bring the numbers down.

I see a lot of stuff on finding the issues but not resolving it.

 

Any suggestions?

We are running EV 10.0.1

SQL = 2005

Discussion Filed Under:

Comments 3 CommentsJump to latest comment

JesusWept3's picture

What kind of archive is it? Mail? FSA?
Indexes are definitely not in backup mode right?
What happens if you try and search the archive through search.asp, does it work or tell you that the index has failed etc?

JamaliP's picture

Didnt think to give all the info.

 

its Mail archives.

None of the indexes are in backup mode. I ran a sql query to be sure.

Search does work. but searching for key words in recent items are not shown.

 

 

JesusWept3's picture

Is this a new install of EV or is it an old install from EV9 or below to EV10?
If its an older version, is it the old 32bit index or have you converted the index to 64bit indexing?

Really though i think you're going to have to get a dtrace to see whats going on.
Is there anything in the event viewer related to indexing?
And did anything happen in the environment when this started happening?
You should be able to find the first item that is awaiting indexing in the JournalArchive table, there should be a submitdate or something like that

so like

SELECT TOP 1 SubmitDate FROM JournalArchive WHERE IndexCommited = 0 ORDER BY SubmitDate ASC

SOLUTION