Video Screencast Help

Archive/Delete Files Older Than XX Days

Created: 06 Dec 2013 | 4 comments

Created a new backup job, goal to archive files older than 999 days(maximum amount I could select), job ran and backed up files in my test directory but the job archived all files then deleted all files. Below is the procedure I used to create the job.

Select New Backup Job.

Selected the data to be archived.

Click the Include/Exclude button and check the Files not accessed in X days and entered the number of days, 999.

Checked the Include radio button.

Click OK

Click General.

In the Backup method for files field, selected Full-Archive the files (delete files after successful copy)

Complete the backup job options

Question what file attribute does BE look at to determine what files to archive then delete?

Operating Systems:

Comments 4 CommentsJump to latest comment

w-d's picture

Archiving files / creating placeholders:

  • User mode Placeholder service archives the file
  • User mode Placeholder service opens the file handle and sends it to the mini-filter driver evmf.sys as part of the message to the mini-filter
  • Mini-filter driver uses this handle to get the file object and performs following operations:
  • Mini-filter sets the reparse point on the file
  • Mini-filter sets the offline attribute on the file
  • Mini-filter makes the file sparse
  • Mini-filter zeroes the data allocation of the file

Recalling the placeholder:

On file data access operation the mini-filter recalls files on read, write, set info, memory map operations

  • Mini-filter requests the data from the Placeholder service
  • Mini-filter sends non-cached paging i/o write requests to NTFS to recall the file
  • When it is done it deletes the reparse point and clears the offline attribute

More information is here:

Kunal.Mudliyar's picture

Hi TheB,

BE will look into the modified date to decide this.

If the file is not modified in x no of days it becomes a candidate to get deleted.

Technical Support


TheB's picture

Further testing have found the following. When I set "Files not accessed in XX" under Include\Exclude, the setting is not being applied. If I select the Apply button both the Apply and OK button gray out, only button left is Cancel. When I go back into the job and select Include/Exclude agian I cannot tell it was ever selected and based on the results of my test runs it would appear this is indeed true.