Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

ArchivePoints.exe via Powershell

Created: 16 Oct 2013 • Updated: 21 Oct 2013 | 7 comments
This issue has been solved. See solution.

Hi all,

I’m in the process of creating a powershell script to check OU users against users already configured for file share archiving but I’ve hit a stumbling block. I can query AD to get a list of users per OU and their home directories, dumping all of the details out to text files for logs and basing subsequent queries on.

When I try to query the Archive Points using archivepoints.exe I keep getting an error.

The simple form of the script would be :

$app="D:\Enterprise Vault\ArchivePoints.exe"

$EVArg = "find"

$VolLine = "\\fopserver045v\ouone_users_r$"

Invoke-Item "$app $EVArg $VolLine"

But it errors with the following.

Invoke-Item : Cannot find path 'D:\Enterprise Vault\ArchivePoints.exe find \fopserver045v\ouone_users_r$' because it does not exist.

It looks like it’s cutting the first backslash off the UNC path, not sure if that’s the problem or just a side effect but either way I haven’t been able to successfully run it.

Has anyone tried to use Powershell to find archive points successfully ?

I can upload the script (it ain’t pretty but it does the job so far) if it might help.

Thanks Kevin

Operating Systems:

Comments 7 CommentsJump to latest comment

EV_Ajay's picture

Hi Kevin,

Could you try to use $app= UNC Path of EV Server and then run the script.

Thanks,

Ajay

Kevin O'Connor's picture

Hi Ajay,

Sorry, I don't understand.

$app currently has $app="D:\Enterprise Vault\Archivepoints.exe" so are you saying it should be $app="\\evserver01\D$\Enterprise Vault\Archivepoints.exe"

Rgegards

Kevin

EV_Ajay's picture

Hi Kevin ,

That's right.

Thanks,

Ajay

Kevin O'Connor's picture

Hi Ajay,

Okay, it now references the UNC path with double backslashes but still fails with the following.

Invoke-Item : Cannot find path '\\evserver01\D$\Enterprise Vault\Archivepoints.exe find \\fopserver045v\ouone_users_r$' because it does not exist.
At D:\Scripts\testing\ev.ps1:5 char:12
+ Invoke-Item <<<<  "$app $EVArg $VolLine"
    + CategoryInfo          : ObjectNotFound: (\\evserver01\D...\ouone_users_r$:String) [Invoke-Item], ItemNotFoundException
    + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.InvokeItemCommand

Regards

Kevin

PJuster's picture

try this it worked in my lab

$cmd="E:\Program Files\Enterprise Vault\ArchivePoints.exe"
 
$cmdarg = @("find","\\evserv2\users")
& $cmd $cmdarg
 
saved as ap.ps1
 
it took a while to run but the output looked like
 
PS C:\Users\admin> .\ap.ps1
 
Listing Archive Points ...
        Archive Point : \\evserv2\users\Andrew.Moore
        Archive Point : \\evserv2\users\Bonnie.Walker
        Archive Point : \\evserv2\users\Mike.Smith
        Archive Point : \\evserv2\users\Samantha.Cho
        Archive Point : \\evserv2\users\Tamara.Kramer
        Archive Point : \\evserv2\users\Vivian.Vance
PS C:\Users\admin>
 
 

If you feel this is a solution please mark it as such. TIA Paul

SOLUTION
Kevin O&#039;Connor's picture

Hi Pjuster,

Thanks for that.

I've been able to get it working now and using out-file to dump the results out to a text file.

GabeV's picture

Hi,

I would use the '&' operator as PJuster suggested to call the program. According with MS, the Invoke-Item cmdlet is recommended to force the default action for a file type:

4. Invoke-Item (II)

Why: Forces the default action to be run on the item.

Details: Good when trying to open a file with an associated program. If for example you invoke-item with a PDF file, it opens it in whatever program is associated with PDF files. This can also be used to open multiple files at once. This is not good for executing a program.

https://social.technet.microsoft.com/wiki/contents...

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill