Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Archiving explorer page not found

Created: 28 Dec 2012 | 9 comments
donk2000cl's picture

Hi all,

I installed Enterprise vault 9.0.4 and added two servers Exchange 2010. All archiving works fine. The only option that not working is the link on Archiving explorer and sometimes Search Archiving on OWA.

There are two hub/cas role servers I installed the add-ons for OWA and I made the changes in web.config file. The icons of EV are present and you can archive or restore.

This started working fine, but the customer renamed the owa connection from owa2.domain.com to owa.domain.com. I made the changes over the advanced tab in the desktop policies. But the system continues sending an error of page not found when you click over this two icons in OWA. Sometimes is Page not found or The Page cannot be displayed.

I think that the problem is in the certificate, but I don't know about how the certificate must be configure. Do you know about documents over this issue?

Regards,

Carlos Espinoza

Comments 9 CommentsJump to latest comment

Rob.Wilcox's picture

Do the CAS servers work correctly internally?

What do the EV bits look like in the web.config file?

When you hover over the link ... what is the URL that is being given?

donk2000cl's picture

Do the CAS servers work correctly internally? as cas servers they work
correctly but if you conect as owa the system not work fine then iwa cannot pass the user credentials to evault so is necesary that the owa ask for credentials then the systems pass the user crdentials. with this the system works and you can archive or restore and view the archived items.

donk2000cl's picture

What do the EV bits look like in the web.config file?

There are only the path where is the version and the protocol used it is http.

When you hover over the link ... what is the URL that is being given?
This question is interesting. When you pass over the links it said legacy.domain.com/# not owa.domain.com

AndrewB's picture

here's an example of what you might see:

<add type="Symantec.EnterpriseVault.Owa.EVOwaModule, Symantec.EnterpriseVault.Owa" name="EVOwaModule"/>

<add key="EnterpriseVault_ResourceVersion" value="v10.0.1.1171"/>
<add key="EnterpriseVault_LogEnabled" value="false"/>
<add key="EnterpriseVault_LogFolder" value="C:\Temp\"/>
<add key="EnterpriseVault_ExchangeWebServicesUrl" value="http://localhost/ews/exchange.asmx"/>

<probing privatePath=";EnterpriseVault\bin"/>

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

Rob.Wilcox's picture

I don't have access to my virtual machines at the moment to compare and / or offer a fix.  Hopefully will be able to tomorrow, or the day after.

AndrewB's picture

have a look at this article http://www.symantec.com/docs/TECH154553

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

ITDAP_COM's picture

To access Archive Explorer or Search archive from outside or enside you should change one or more of the following keys on the CAS server to match with your environment. This setting will override the setting that you have on the policy about the external url.

Enterprise Vault Key (2007 SP4+) Value
EnterpriseVault_VaultServiceAccountUPN VSA@mydomain.local
EnterpriseVault_ExternalWebAppUrl /enterprisevault
EnterpriseVault_UseExternalWebAppUrl true
EnterpriseVault_ExternalHostNames owa.mydomain.local
EnterpriseVault_ExternalIPAddresses 192.168.0.5;192.168.0.103

Check this technote for more details:

http://www.symantec.com/docs/TECH141519

You can also verify the URL that you get when you press the AE button in OWA. 

If this response answers your concern, please mark it as a "solution"

donk2000cl's picture

Hi all,

Thank you to all for the posts, I made changes in the web.config file, now the keys are the following:

<add type="Symantec.EnterpriseVault.Owa.EVOwaModule, Symantec.EnterpriseVault.Owa" name="EVOwaModule" />

  <add key="EnterpriseVault_ResourceVersion" value="v9.0.4.1097" />
  <add key="EnterpriseVault_WebDAVRequestProtocol" value="http" />
  <add key="EnterpriseVault_UseExternalWebAppURL" value="true" />
  <add key="EnterpriseVault_LogEnabled" value="false" />
  <add key="EnterpriseVault_ExternalHostNames" value="owa.domain.cl" />
  <add key="EnterpriseVault_ExternalWebAppUrl" value="/enterprisevault"/>

Any other idea?

ITDAP_COM's picture

Are you testing internally or externally ? please send were owa.domain.cl is resolving for both.

Send the url that your browser show when you click the search archive.

Enable the EV trace on the CAS server and attach it.

The externalwebapp url will concatenate the same url that you use to open the Owa session, if that redirection does not is setup in your firewall it will be redirected to the cas instead of the EV. (owa.domain.cl/enterprisevault)

If you firewall does not support header redirection you can change the externalwebappurl to your EV server name. Example: evserver.domain.cl/enterprisevault

If this response answers your concern, please mark it as a "solution"