Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Archiving of Public Folders

Created: 17 Oct 2013 • Updated: 25 Sep 2014 | 4 comments

Greetings,

I've recently started using Enterprise Vault (new company), and have a query regarding the archiving of Public Folders; mailboxes are archiving just fine, with an archive age of 6 months.  Public folders don't seem to be archiving, and I have no idea why.  At first I believed that it was because the messages are showing up as unread, and we have "Maintain per-user read and unread information for this folder" selected on just about every public directory - but there is no option in the Public Folder policy to toggle whether or not one archives unread messages.

If anyone can point me in the right direction, I'd be much obliged.
 

Russell.

Operating Systems:

Comments 4 CommentsJump to latest comment

GabeV's picture

Hi NT,

Have you checked the event logs looking for any errors or warnings when you run the public folder  task? You can also collect a dtrace for the PublicFolderTask, run the Exchange Public Folder task and go through the log to see if there are any errors.

I hope this helps.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

NameTaken's picture

Hey Gabe,

Thank you for your reply; there are no error messages in the event log, so I'll have a look at running a trace. tomorrow morning!

Russell.

BigPhil's picture

Like GabeV said, Dtrace would be a good start. I would also double check your Exchange public folder targets to make sure what you think should be archived, is actually listed. Also, do you have the "Activate this auto-enabled" check box checked? You might also check your Public Folders Exchange policy and verify that the message classes of the items in your public folders are enabled for archiving. Thoroughly go through the policy and verify all of your settings are what you expect them to be. Make sure your Public Folder Task is not set to " run in report mode."

Philip Nunn EV 11 CH2 on Windows 2012, Exchange 2013 CU6 DAG on Windows 2012, ESXi 5.5, Mircosoft TMG, NetApp/EqualLogic storage

If this response answers your question, please mark it as solution

NameTaken's picture

Hi again, Gabe and Phil,

I moved a couple of partitions, and created a new partition - the last partition had been closed about a month ago.  I didn't believe the lack of partitions was related to the unarchived mail, because the mail had not been archiving for much longer than one month (at least six).  However, on arrival this morning, I see that all of the unarchived e-mail has been properly archived.

While I'll never know why it wasn't archiving the mail long before I arrived, it seems to be working just fine now.  Thank you both for your advice; I'll remember the dtrace feature, and I've double checked that the auto-enabled policies are selected.

Thanks again.

Russell.