Video Screencast Help

Assigned tape not in Catalog

Created: 02 Jul 2013 | 4 comments

Hi,

I added a new tape that probably was bad.
Netbackup tried but chooked immediatly writing to the tape. (it just re-started on another tape)

Now the tape is assigned but it's not in the Catalog!
I Can't delete it or label or erase it because it is assigned.

I got a new Tape in the library

root@ipndms:~# /usr/openv/netbackup/bin/admincmd/bpimmedia -L -mediaid DRT110
no entity was found
root@ipndms:~# /usr/openv/netbackup/bin/admincmd/bpmedialist -summary |grep DRT110
            DRT110 expires 07/26/2013 00:05 (SUSPENDED)
root@ipndms:~# /usr/openv/netbackup/bin/admincmd/bpexpdate -m DRT110 -d 0 -force
requested media id is not assigned to this host in the EMM database
root@ipndms:~#

What do I do?

 

- Roland Soderstrom
 

Operating Systems:

Comments 4 CommentsJump to latest comment

Marianne's picture

Please show us output of :

/usr/openv/netbackup/bin/admincmd/nbemmcmd -listmedia -mediaid DRT110

We need to see all fields to determine current status and how to fix it.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

rsm.gbg's picture

Sure.

root@ipndms:~# /usr/openv/netbackup/bin/admincmd/nbemmcmd -listmedia -mediaid DRT110
NBEMMCMD, Version:7.1
====================================================================
Media GUID:                     c71ef722-ddf2-11e2-8000-92a5b15f1c60
Media ID:                       DRT110
Partner:                        -
Media Type:                     HCART
Volume Group:                   000_00000_TLD
Application:                    Netbackup
Media Flags:                    1
Description:                    Daily Remote LTO4 Tape
Barcode:                        DRT110L4
Partner Barcode:                --------
Last Write Host:                pnms01
Created:                        06/25/2013 13:55
Time Assigned:                  06/28/2013 00:05
First Mount:                    06/28/2013 00:10
Last Mount:                     06/28/2013 00:10
Volume Expiration:              -
Data Expiration:                07/26/2013 00:05
Last Written:                   06/28/2013 00:05
Last Read:                      -
Robot Type:                     TLD
Robot Control Host:             pnms01
Robot Number:                   0
Slot:                           5
Side/Face:                      -
Cleanings Remaining:            -
Number of Mounts:               1
Maximum Mounts Allowed:         0
Media Status:                   SUSPENDED
Kilobytes:                      9536
Images:                         1
Valid Images:                   1
Retention Period:               10
Number of Restores:             0
Optical Header Size Bytes:      1024
Optical Sector Size Bytes:      0
Optical Partition Size Bytes:   0
Last Header Offset:             0
Adamm Guid:                     00000000-0000-0000-0000-000000000000
Rsm Guid:                       00000000-0000-0000-0000-000000000000
Origin Host:                    NONE
Master Host:                    ipndms
Server Group:                   NO_SHARING_GROUP
Upgrade Conflicts Flag:
Pool Number:                    5
Volume Pool:                    Daily_Offsite
Previous Pool Name:             -
Vault Flags:                    -
Vault Container:                -
Vault Name:                     -
Vault Slot:                     -
Session ID:                     -
Date Vaulted:                   -
Return Date:                    -
====================================================================
Command completed successfully.

 

rsm.gbg's picture

Hi,

Don't know what I did but know it works.

Could the nbemmcmd command seen some miss-configuration and automagically fixed it?
A catalog backup was done at 14:00 but that has been done for a week now.
 

07/03/2013 14:44:08 - begin Label
07/03/2013 14:44:08 - started process bplabel (pid=14156)
07/03/2013 14:44:09 - Info bptm (pid=14161) start
07/03/2013 14:44:09 - Info bptm (pid=14161) Waiting for mount of media id DRT110 (copy 1) on server pnms01.
07/03/2013 14:44:09 - mounting DRT110
07/03/2013 14:44:09 - Info bptm (pid=14161) INF - Waiting for mount of media id DRT110 on server pnms01 for reading.
07/03/2013 14:44:08 - requesting resource Daily_Offsite:DRT110
07/03/2013 14:44:09 - granted resource  DRT110
07/03/2013 14:44:09 - granted resource  HP.ULTRIUM4-SCSI.000
07/03/2013 14:45:10 - mounted DRT110; mount time: 0:01:01
07/03/2013 14:45:10 - Info bptm (pid=14161) EXITING with status 0 <----------
07/03/2013 14:45:10 - labeling DRT110
07/03/2013 14:45:21 - labeled DRT110; label time: 0:00:11
07/03/2013 14:45:21 - end Label; elapsed time 0:01:13
the requested operation was successfully completed  (0)

Marianne's picture

The only thing that I would change about your bpexpdate command was to add the name of the media server:

bpexpdate -m DRT110 -d 0 -host pnms01

I cannot see how nbemmcmd command would fix anything - it simply reports status in volume and media tables.

Glad you got it fixed.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links