Video Screencast Help

Attempting to capture Win7 image fails in WinPE

Created: 28 Oct 2013 | 4 comments

Good Morning...

I'm finally delving into the world of Win7 ( I know I know) and have completed my baseline image.  Prior to win7, I never really used sysprep, so I figure I'd give it a go this time.  I created a win7 sysprep configuration and set it to what I need. I went to capture the image and it fails in the winPE portion of the image. 

At first I thought it was the drivers that we had for the winPE image (Intel 82567LM-3 NIC) because I was getting the unknown PCI identifiers (32902:4318)  I updated my winPE image in Ghost Boot Wizard, but it seems that might not be the case.  

When I run the create new image task, I can get all the way up to "To Virtual Partition" as successful. However, it keeps failing at Run Sysprep "client timed out"...  On the actual machine, it looks like it stalls after the .bat kicks off... last thing I see is gdisk32 /revert    1>>X:\ghost\startlog.txt

If I kill the bat/ghost console, it has an IP address (originally 169.254...) If I stay in the WinPE mode and kick the console off again, it will hash some things, but get stuck again.

Oh, and I'm currently running 11.5.1.2266

Any ideas?

Thanks...

Milnesy

Operating Systems:

Comments 4 CommentsJump to latest comment

EdT's picture

What Sysprep parameters are you using?

One way to reduce the number of variables in this scenario is to run sysprep so that it prepares the image and then shuts down the machine. You can then boot to an external USB hard disk running WinPE and then run Ghost from the external USB hard disk and create the image "manually" without using the network.

That way you can take the image to another test machine, deploy it locally, and test whether it boots up and configures correctly. Once you know that the image is working as intended, you can go back and track doiwn the cause of the other issues.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Milnes's picture

Thanks for the response. 

I was working on my google-fu and found 2 other posts similiar to my issue.  One of them was regards to the dell drivers and instead of using the univeral driver 2.0 switch to the Intel Pro 1000 drivers. Another was in reference to ACHI and ATA and Legacy.  I changed the drive settings from ACHI to Legacy.  Figure I'd try to pull the image again... and it worked. Sort of. I still had to kill the task in the winPE and do an Ipconfig /renew to get a good ip address (rather than the 169.254)  So I'm not sure which solution was the answer.

I am going to try to push the image down on a 2nd machine and only make 1 of the two changes... hopefully I can isolate the issue.

As for the setting in Ghost for Sysprep -

Standard settings ...
option 3 for protect your pc
Network Location - Work
Join the Domain
Timezone - Eastern and all English
All but "skip re-arm" checked.

If the issue turns out to be ACHI / UEFI ... how do I get the latest revision of Ghost?  I do not have a maintenance agreement with them as there was never any movement regarding Ghost 3.0 ... etc...

 

Maneesh's picture

Its good that you have SKIP Rearm checked,which is handy especially when you have to attempt image creation multiple times.As for 169.254.x.x IP under WINPE,its either NIC drivers for WINPE or DHCP latency which is causing the issue.The solution is to add the ipconfig /renew command in the associated batch file.

On the Ghost server navigate to ,

C:\Documents&Settings\All Users\Application Data\Symantec\Ghost\Template\Common\"Winpe-You-Use"\Ghost\

I assume the server is either XP or 2003 since you are migrating to WIN 7 .Else the below path,

C:\Program Data\Symantec\Ghost\Template\Common\"Winpe-You-Use"\Ghost\

Right click Start.bat->Properties->Uncheck Read Only .Open the start.bat with Notepad and add the ipconfig /renew command after the line cd\ghost.Also include ping 127.0.0.1 after the ipconfig /renew line for delay.Save and Run the task again using the same WINPE template.

This is cleary a driver thing and AHCI mode is totally irrelevant.Check if the machine uses UEFI for BIOS which is the next important thing as the created image will be useless,if the machine uses UEFI.

Steps to check for UEFI->Disk management->Disk 0 ->Right click->Properties->Volumes Tab->Partition Style.

If MBR you should be good.If GPT UEFI is in place and contact support to obtain the latest 64 bit Ghost patches.

Note:Was in a hurry .Excuse typos.

EdT's picture

Basically, 11.5.1.2266 is the latest version available for Ghost. There are other patches and an update for Win 8 available but only to holders of current maintenance agreements.

Modern systems all use SATA drives, and this requires the correct SATA drivers to be present both in WinPE and in the operating system you will be booting. The legacy bios setting where AHCI is turned off and compatibility mode enabled, makes the driver resemble the older PATA technology (IDE) which is still natively supported by operating systems but has severe limitations when you are working with large drives due to the limitations of CHS addressing when compared to LBA addressing used today.

If turning off AHCI makes things work, then this confirms that you don't have the correct SATA driver present in WinPE (yes, it has to be a Vista 32 bit driver as WinPE V2 is based on the Vista kernel).

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.