Video Screencast Help

Auto protect is disabled

Created: 21 Mar 2013 • Updated: 21 Mar 2013 | 10 comments
vinu283's picture

Hi

 Recently I installed SAVFL(12.1.2) in Linux 5.4 test environment but by default autoprotect is disabled i gave enable command as follows 

sav autoprotect -e but still it is in disable positon only can any one help me to get out of this problem 

Operating Systems:
Discussion Filed Under:

Comments 10 CommentsJump to latest comment

_Brian's picture

Please check this article from Mick2009:

SAV for Linux Scanning Best Practices: A (Somewhat) Illustrated Guide

https://www-secure.symantec.com/connect/articles/s...

How to check if AutoProtect is enabled?

Here is the command line to run from /opt/Symantec/symantec_antivirus

sudo ./sav info -a 

to enable it:

sudo ./sav autoprotect -e

to disable it:

sudo ./sav autoprotect -d

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Mithun Sanghavi's picture

Hello,

To enable Auto-Protect:

◆ From the command line, type the following:
sav autoprotect --enable
To disable Auto-Protect
◆ From the command line, type the following:
sav autoprotect --disable

Secondly, check this Article:

Guide to building AutoProtect kernel modules for Symantec AntiVirus for Linux 1.0

http://www.symantec.com/docs/TECH132773

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Mick2009's picture

"Thumbs up" to the above- if those command lines do not enable AP in SAVFL, then your kernel is probably unsupported "out of the box."  Compiling your own AP module will have you protected in a few minutes.

With thanks and best regards,

Mick

vinu283's picture

Hi Mick 

 

My kernel version(2.6.18-164) is in supported version list MR 9 release and i am installing 1.0.14 soi think  it is a supported kernel version.

Mick2009's picture

Cheers for the update - have a look at the install logs that SAVFL generated, specifically savap-install.log.  Can you copy that and paste it here into the thread?

_____________________________________________________

 

Actually, what I am looking for is the messages that appear in the terminal window: see https://www-secure.symantec.com/connect/forums/sav-linux-errors-when-installing-it-ubuntu-1210

do you see something like:

 

Setting up savap (1.0.14-13) ...

symap: not currently loaded

symev: unable to load kernel support module (UNSUPPORTED-OS-ub-ST-12-3.5.0-21-generic-x86_64)

invoke-rc.d: initscript autoprotect, action "restart" failed.

 

With thanks and best regards,

Mick

pete_4u2002's picture

suggest to work with technical support team.

SameerU's picture

Hi

Please reinstall the SEP client and observe the same.

Regards

 

super1234in's picture

Sir,

I get the following message while starting up,

 

msln program not found skipping auto check

 

How to resolve

 

Regards,

 

 

super1234in's picture

 

Sir,

I get the following message while starting up,

 

msln program not found skipping auto check

 

How to resolve

The operating system is  wince pack 2dows vista home premium service pack 2.

64 bit operating sysstem

 

Regards,

 

SameerU's picture

Hi

Have you reinstall the SEP client

Regards