Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Auto start workflow web service

Created: 10 Sep 2010 • Updated: 22 Jan 2013 | 5 comments
This issue has been solved. See solution.

I'm trying to create a web service that will automatically kick off every hour.  The project is a Workflow type.  I've set the Workflow type to "Auto Start" and provided a schedule that runs everyday with a time of 01:00:00 (1 hour).  Having an auto start now requires an auto start component.  I am unsure of rather I need to use the "Auto Start from Exchange" component or the "Configurable Auto Start" component.  I tried using the Configurable Auto Start component and setting the embedded model inside to always map to true (since I want it to run every hour).  However, once I published the project, it ran continuosly and seemed to ignore the time schedule that I provided.  Any help or suggestions that anyone can provide would be greatly appreciated.

Thanks,
Brandon

Discussion Filed Under:

Comments 5 CommentsJump to latest comment

Aaron - WEVO Group's picture

It sound to me like you need to change an option.  On the Publishing tab, "Auto Start Setting" section, there is a setting for "Run Auto Start Until Does Not Start".  This is selected by default, and since you are using the configurable auto start with no decision, as far as workflow knows it is always starting.  If this box is checked, just uncheck it and your problems should be solved.

beamer7296's picture

Thanks for the quick reply.  I tried that, but now the service does not kick off ever.  I guess what I'm actually getting at is, is it possible to create a Windows Service from a Workflow project?  In the past we have done this by using the Monitoring project type, but we're curious if this is a possibility for Workflow project types as well.

Thanks,
Brandon

Aryanos's picture

It is possible to have autostarts for Workflow projects as we have projects that do this. You do need the Configurable Auto Start Configuration component and to set the end to true. Did you try restarting the Server Extensions on the server you deployed the project to? If successful the project will show up when you right-click the workflow icon on the task tray > Servers > Server Name.

I like my beats fast and my bass down low

Rob Moore's picture

you need to restart the Logicbase Server Extensions. I know it sounds dumb, but re-starting the server extenstions registers the URL neeed to run the auto start.

Rob

SOLUTION
stuper2's picture

There's a couple oft forgotten settings in Symantec Wofklow Server Windows Service.

If you rt click on the task tray man and pick 'Settings' you'll find a section called "Worfklow Server Configuration" 

On the next popup you'll find "Auto Trigger Info" and "Manual Setup Info" back to back.  

These two things participate in auto start workflows.  Under Auto Trigger Info you'll find the polling interval (default 1440) that the tool uses to actually look for new auto start workflows that haven't been previously found.  On restart (as Mr. Rob M) describes, this is run so restarting the Workflow Server service effectively resets this timer and voila, your auto start gets found and registered.

Alternatively you could shrink this auto poll interval OR, add your auto start project to the list of manually triggered projects at which point the auto registration is irrelevant.