Video Screencast Help

Autopurge for VDI not working?

Created: 21 Jan 2013 | 7 comments
diabolicus23's picture

SEP 12.1 RU2

I've set autopurge for disconnected VDI at 2 days but it does not work...

I see clients last time online 10 days ago (in the properties section I see them as VMware).
If I set the filter in order NOT to see offline non-persistent VDI, I still see them... it's like SEP does not recognize them as non persistent VDI.

I've already performed all the steps described in best practices (vietool, clientprep and so on).

Comments 7 CommentsJump to latest comment

Mithun Sanghavi's picture


SEPM will ‘remember’ all new images attaching, which can build up quickly in a VDI environment.  An admin can either reduce the interval required for clients to age out of SEPM or periodically run a cleanup script which purges the old client records. 


Also check this - 

Using Symantec Endpoint Protection in non-persistent virtual desktop infrastructures

Configuring a separate purge interval for offline non-persistent VDI clients

Hope that helps!!

Mithun Sanghavi
Associate Security Architect


Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

diabolicus23's picture

The link refers to clients that have not been prepared for cloning...

As I said, I've used cliensideprep tool so I don't think I'm in that situation.

diabolicus23's picture

Ehm... no... I see this for the first time surprise

I mean, I don't see this steps in the "official" instructions regarding virtual environments but probably I'm too old and I'm beconing blind smiley

Are you telling me that if I "tag" the original VDI template with that registry key, those machines will use the autopurge days set in VDI of the domain?


SMLatCST's picture

Yup, the SEP clients only count as Non-Persistent VDI machines if this reg key is present.  It must be present in the base image from which the Non-Persistent VDI's are spawned, otherwise they'll just use the "Normal" purge option

SMLatCST's picture

Bear in mind that this reg change is NOT included in the clientsidecloneprep tool and must be perfformed as a separate step.

I've already raised this at the WTS that this setting would be better implemented as a checkbox within a Client Install Settings package.  I'm happy to create an IDEA for it if need be

SMLatCST's picture

Just FYI, I have created this request for a simople checkbox as an IDEA.

Please take a look-see and vote on it if you think it useful.

@diabolicus23: I hope your issue is sorted (though I suspect you'll need to wait until tomorrow to confirm if you're sticking with your 2 day threshold).  It'd be appreciated if you could mark any posts you found useful with a "Thumbs Up" or as the Solutionwink