Video Screencast Help

avoid 196

Created: 23 Oct 2012 • Updated: 23 Oct 2012 | 5 comments
This issue has been solved. See solution.

How can i avoid 196 in my environment where there are around 2000 servers to backup.

 

Any specific settings?

Comments 5 CommentsJump to latest comment

Nicolai's picture

Status 196 is a capacity issue. You are loading more backup than the system can handle in the backup window defined. Review backup windows to see if they are acceptable for you're environment.

See Symantec recommendation: http://www.symantec.com/docs/HOWTO35070

 

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Arun K's picture

I mean i want to know whatall setting i can see for this.

For eg:max jobs per policy settings, etc etc

mph999's picture

 

Further to Nicolais answer, where the issue is caused by capactity of the system issues ...

Very very simple - design your systems properly in the first place, so it is correctly designed to handle the amount of backups it needs to do, taking into account future growth and new clients that will be added (capacity planning).

Trying to fix 196, once they start to happen, can be very difficult, if not impossible. - if the cause is 'capacity'.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Marianne's picture

You need to monitor backups during backup window to see why jobs are queued.

If you give us a reason for queued jobs (copy all text in Details tab and post here), we can provide better assistance.

While jobs are queued, you need to see how many jobs are active at that point in time, how many drives are in use (if using tape drives).
For jobs to Data Domain, see how many jobs are active for each media server. Check 'Maximum Concurrent Jobs' in STU config, confirm Multiplexing is enabled in ALL schedules, check 'Max Jobs per Client' in master server Host Properties. Ensure this value is not the default of 1. A value of 4 is a good average.

Check that your timeouts on all media servers are not too high - Excessive Client Read and Client Connect Timeouts will cause jobs to remain in Active state for way too long, holding on to resources while no data is backed up.
The default for both values is 5 minutes. The only time where this should be increased is for database backups. 30 minutes (1800) should be the limit.

Possible reasons for status 196 (excessive timeouts):
https://www-secure.symantec.com/connect/forums/client-read-timeout-and-client-connect-timeout-can-go-masters-or-medias-they-go-anything-will#comment-7120441

https://www-secure.symantec.com/connect/forums/details-media-server-and-clients

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Yogesh.Jadhav's picture

Enough resource and accurate configuration & correct Backup Window depending upon number of jobs are key to avoid 196.

A short work-around to stop the 196 error just before the backup window closes and where you do not have oter option ; particularly for file system job set the checkpoint for policy and suspend the queued jobs just 5 minutes before the backup window close. You can resume it later & they should complete, make sure you are not affecting your production environment by spilling jobs in production hours.

Thanks & Regards

Yogesh Jadhav