Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

B2V - unable to continue...

Created: 25 Aug 2014 • Updated: 06 Oct 2014 | 8 comments
sdo's picture
This issue has been solved. See solution.

Master - NB52x0 - v2.6.0.2 - and the MSDP storage contains a full backup of client named 'winclient7602'.

ESX - vSphere v5.5 (base - no patches)

Media - Win2008 R2 SP1 - NBU v7.6.0.2 Enterprise Server

Client - Win2008 R2 SP1 - NBU v7.6.0.2 Client

I understand that to B2V a Windows backup to create a Windows VM, one needs a Windows based VIC (Virtual Image/Instance Converter):

http://www.symantec.com/business/support/index?pag...

...so I created a Windows 2008 R2 SP1 media server running NBU 7.6.0.2.

The full BMR based backup image of winclient7602 is within the MSDP storage on the master server appliance.

I've added host 'media7602' as VMware Access Host on master server properties.

And added media7602 to teh Storage Server credentials of 'master2602a PureDisk'.

(I have been able to backup a separate VM from the ESX hosts, so I know that's working.)

Re-started NetBackup processes on master.

When I try a B2V, I get:

B2V - failed.png

...but the catalog definitely contains an original full image:

master2602a:/home/maintenance # bpimagelist -client winclient7602 -U -d 01/01/1970 00:00:00
Backed Up         Expires       Files       KB  C  Sched Type      On Hold Index Status Policy
----------------  ---------- -------- --------  -  --------------- ------- ------------ ------------
22/08/2014 11:53  05/09/2014     7731  4358832  N  Full Backup     0       0            POL-TEST01
22/08/2014 11:41  05/09/2014    15842 10597004  N  Full Backup     0       0            POL-TEST01

Does the VIC host (media7602) have to own the backup image, or have the image directly accessible within its own storage?

Any obvious tips before I start delving through logs?

Operating Systems:

Comments 8 CommentsJump to latest comment

sdo's picture
$ vxlogview -p 51216 -o 433 -t 00:10:00
25/08/2014 13:25:32.315 [bmrPreMain.cpp:BmrPreMain()] Locale changed to English_United Kingdom.1252 line=86
25/08/2014 13:25:32.315 [bmrb2v.cpp:bmrmain()] Entering, line=48
25/08/2014 13:25:32.315 [bmrb2v.cpp:bmrmain()] Command line: C:\Program Files\Veritas\NetBackup\bin\bmrb2v.exe -bmr -vmw -C winclient7602 -v
mproxy media7602 -vmserver esxi55.localdomain -veconfig ve.txt
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:initializeDefaults()] Entered, line=434
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:initializeDefaults()] Exiting, line=467, return BMR_SUCCESS
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:execute()] Entered, line=67
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:parseArguments()] Entered, line=261
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractHelp()] Entered, line=1177
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractHelp()] Exiting, line=1186
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractBmrb2v()] Entered, line=1156
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractBmrb2v()] bmrb2v CLI invoked by others.
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractBmrb2v()] Exiting, line=1165
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractGui()] Entered, line=1116
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractGui()] Exiting, line=1125
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractSystemOnlyRestore()] Entered, line=1136
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractSystemOnlyRestore()] Exiting, line=1145
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVersion()] Entered, line=493
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVersion()] Exiting, line=499
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVEtype()] Entered, line=552
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVEtype()] Virtual Environment Type = VMWARE_VE_TYPEline=559
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVEtype()] Exiting, line=560
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractProfile()] Entered, line=523
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractProfile()] Exiting, line=529
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractClientAndConfig()] Entered, line=985
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractClientAndConfig()] Exiting, line=1014
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractMasterServer()] Entered, line=630
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractMasterServer()] Master server Name is not specified
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractMasterServer()] Exiting, line=639
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVmproxy()] Entered, line=592
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVmproxy()] Exiting, line=613
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVMServerName()] Entered, line=945
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVMServerName()] Exiting, line=966
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVEconfigDetails()] Entered, line=681
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:parseVEconfig()] Entered, line=717
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:parseVEconfig()] Exiting, line=928
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVEconfigDetails()] Exiting, line=708rc= 0
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVmPowerOn()] Entered, line=1070
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractVmPowerOn()] Exiting, line=1079
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractStripNetwork()] Entered, line=1096
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractStripNetwork()] Exiting, line=1105
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractOverwriteVM()] Entered, line=1044
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:extractOverwriteVM()] Exiting, line=1053
25/08/2014 13:25:32.315 [CBmrb2vCommandLine.cpp:parseArguments()] Exiting, line=368, rc=0
25/08/2014 13:25:35.170 [Error] V-433-33 Cannot find TrueImage date. Please make sure a full backup of this client is available.
25/08/2014 13:25:35.185 [CBmrb2vCommandLine.cpp:execute()] Exiting, line=137, rc=1
25/08/2014 13:25:35.185 [bmrb2v.cpp:bmrmain()] Exiting, line=63, return rc=1

Wondering if this is because TIR is set to only one day:

C:\Users\Administrator>bpconfig -L
...
Keep TIR Info:          1 days
...
Riaan.Badenhorst's picture

Did you copy the configuration and make a new one? Had the same thing last week. If you choose current  and use that it should work (although you might not want to restore from that date..)

Regards,

Riaan Badenhorst

You need an OpenVision to see the truth about Backups. Restores are a plus. But that's just Semantics ;)

ITs easy :)

sdo's picture

Yes, tried using the 'current' conf, so also tried PiT which selected the only image(s) date(s) available - neither worked.

I've just taken another full backup after increasing TIR retention days.  Tried B2V again, but same failure message.

Riaan.Badenhorst's picture

Cool, that worked for me, but it just failed on the next steps (first got a status 7 then 1 status 1). Support suggested to upgrade to 7.6.0.3 (did the same for a colleague on another egagement).

Might be worth your while to just get the upgrade out of the way if possible wink
 

Regards,

Riaan Badenhorst

You need an OpenVision to see the truth about Backups. Restores are a plus. But that's just Semantics ;)

ITs easy :)

sdo's picture

FYI - it's only a test-lab, just trying to get used to the basic process, basic functionality, basic ability, and basic limitations - and not trying anything complicated, yet.

I've got one or two more source backup policy configurations to try, before upgrading the lab to 7.6.0.3.

Are you able to share 'why' an upgrade to v7.6.0.3/v2.6.0.3 might help?

sdo's picture

Tried B2V from:

- accelerator, client side de-dupe

- no accelerator, client side de-dupe

- no accelerator, no client side de-dupe

...no joy.

I must be missing something obvious.

Is it a requirement that the NetBackup VIC (Virtual Image/Instance Converter) (FYI - not to be confused with VMware Converter, which is unrelated) host also be the host/owner of the storage that has the backup image?

Riaan - are you able to suggest why upgrading to v2.6.0.3/v7.6.0.3 might be a solution?

Riaan.Badenhorst's picture

Hi,

No its not a requirement. In my case it was a W2K8 VIC host and the backups are on an appliance.

Support just told us to upgrade, it worked in my colleague's case, in my case I've not had the chance to upgrade the master. Having said that we got further than you. Since its test it won't hurt to do it :)

Regards,

Riaan Badenhorst

You need an OpenVision to see the truth about Backups. Restores are a plus. But that's just Semantics ;)

ITs easy :)

Jaime_Vazquez's picture

The status code 7 issue was resolved with a patch fix in the 7.6.0.3 release. 

There appears to be  tricky 'work-around' for this. Perform the same validation process with the VSphere Client open. When the vmdk is created, immediately edit the settings and increase the virtual disk size by a small amount and save the settings. I believe you have about 20-30 seconds to do this. Once done the process of allocating the partition will not fail.  This appears to happen in cases where the system disk is fully allocated (0 free space). The allocation request (because of the reported disk geometry) will ask for a little larger space due to Window's partitioning mechanism, which allocates such space on a cylinder boundary.It can cause the request to 'round up' to the next cylinder boundary, which puts it past the end of the disk.

SOLUTION