Video Screencast Help

Backing up Workgroup VMWare VMs

Created: 17 Feb 2013 • Updated: 19 Feb 2013 | 2 comments
This issue has been solved. See solution.

Still getting my head around BE, so please bare with me here. We are running BE 2010 R3.

We have got an ESXi 4 environment with about 30 virtual machines. Some of the virtuals are in a DMZ and are not part of the domain.

When I try to back these ones up using the System Account (which is a Domain Admin) I get an exception that I cannot perform GRT-Enabled restores becuase BE was unable to collect the necessary metadata. I came across the following link:

This made me think that I needed to use the local admin account for that server on the VM (System account on the host, and local admin on the VM). However when I did this and ran a backup I got the following:

Completed status: Failed
Final error: 0xe0001605 - Access is denied (VMware backup).
Final error category: Security Errors

For additional information regarding this error refer to link V-79-57344-5637

I came across this, but I am lost:

I am not sure how I can set a local admin account to have the required permissions on the host so it can get to the actual VM.

Or am I going the complete wrong way here?

Comments 2 CommentsJump to latest comment

Colin Weaver's picture

GRT for applications and databases MUST have access via RAWS into the Virtual Machine itself

In practice this means

1) There must be a routable network path from media server to the IP adress of the virtual machine

2) At least Port 10000 and a range of configureable dynamic ports must be open from media server into the VM

3) The VM itself may need to advertise back to the media server on Port 6101

4) Name resolution for both FQDN and Hostname MUST work from media server to VM

5) The user account configured against the VM itself in the Backup Job Properties must have enough permissions to access he data inside the VM. Note: leave vCenter or ESX host on correct account for them and just edit the details for the specific VM.

Point 3 may not always be needed

Most of the points above are not needed if only doing file system GRT (although you will need to edit the job properties and remove/disable the application GRT settings as otherwise you might still see the quoted error message.)

ttdgaz's picture

Thanks Colin, step 4 and step 5 fixed it up :)