Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Backup 2012 - slow clustered file share backups

Created: 04 Jun 2014 • Updated: 09 Jun 2014 | 10 comments
This issue has been solved. See solution.

Hi,

I have Backup Exec 2012 V-Ray Edition running on a physical Windows 2008 R2 server. It is connected using a gigabit connection to the LAN, where we also have a 3-node Hyper-V 2008 R2 cluster hosting 2 virtual machines that are running an SMB file share within a guest cluster (also 2008 R2). The virtual machines and file share cluster data is located on an iSCSI SAN.

The problem I have is that the clustered file share backups are very, very slow - usually around 4MB/second. Our 700GB file share takes over 2 days on a full backup.

The job is backing up to disk using a share on our Synology NAS. The NAS and media server are connected using gigabit on a seperate NIC and in a private subnet. I have run a large file copy to the NAS in Windows and get over 100MB/second.

I have also tried a large file copy to the Hyper-V hosts, the C drives on the virtual machines and to the clustered file share - I always get over 100MB/second doing this, so network bandwidth is not an issue. I just can't make Backup Exec do anything quickly. 

Backup Exec does seem to be very slow in general. The Hyper-V cluster backup of the VHDs only runs at 8MB/second. The fastest backup job we have is a full system backup of a physical Windows 2003 server over gigabit that runs at 21MB/second.

Any suggestions would be appreciated.

 

 

 

Operating Systems:

Comments 10 CommentsJump to latest comment

bestseany's picture

I've just noticed that Backup Exec 2014 is now available. I'll try upgrading to that and see if the problem persists....

bestseany's picture

I've now installed and set up Backup Exec 2014, but the jobs are running even slower!

A full clustered file share backup is currently running at only 2MB/second.

Any advice would be welcome.

VJware's picture

Is Backup Exec & the remote servers fully patched ?

Additionally, if using any AntiVirus, have you added exclusions for the BE processes ?
 

bestseany's picture

Yes, Windows and Backup Exec is fully patched on all servers.

The Backup Exec server doesn't have anti-virus on it yet. 

VJware's picture

Have you tried isolating backups to a local disk instead of using the Synology NAS to check if the backup performance is better or not ?

And if using archive bit as backup type for the file shares, try switching to modified time and check as well.

 

bestseany's picture

I've just run a backup of the file share cluster to a locally attached USB3 hard disk and the speed is even slower. Currently running at 0.8 MB/second!

I tested the disk and was getting over 100MB/second to it with a normal file copy.

Looking at the jobs from the weekend, they're all running quite slowly. Our Hyper-V cluster backed up at 16MB/second.

The file incremental backup is already set to modified time and date.

VJware's picture

Do ensure Checkpoint Restart option is disabled in the backup job. And edit the Disk Storage properties and ensure "Preallocate disk space..." option is disabled.

Consider running a Database mainentance and repair of Backup Exec also. Use this KB on running the DB maintenance - http://www.symantec.com/business/support/index?page=content&id=TECH67239

Lastly, do you notice any spikes in memory /CPU when the backups are running ? Any errors/warnings under the event viewer ?

 

 

 

bestseany's picture

Checkpoint Restart and Preallocate Disk Space are both disabled.

This is a brand new clean install of 2014. Our previous install of 2012 was also really slow.

There are no problems in the event logs for any of the servers involved and the CPU and memory usage remain low throughout.

VJware's picture

Would recommend to log a formal support case so that we can investigate this further.

bestseany's picture

I've had a play around with this and think I've found the solution. 

For the NAS storage settings in Backup Exec, I changed the block size to 64KB and the buffer size to 256KB. 

Although I had tried changing these settings earlier on, they didn't make any difference. However, this time I restarted the BE services after making the changes. This has so far caused the backup to be limited by the network bandwidth instead.

SOLUTION