Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup-to-disk files overwritten too soon

Created: 30 Oct 2012 | 5 comments

BE 11d on Windows 2003 SBS.

Backup-to-disk configured to 1 TB external USB drive, with these properties:

  • Maximum size for backup-to-disk files: 4 GB
  • Checked: Allocate the maximum size for backkup-to-disk files
  • Concurrent operations: 1
  • Disk space reserve: 10 GB
  • Device settings: auto

Media set properties:

  • Overwrite: 0 hours (no overwrite protection
  • Append: infinite - Allow Append

Job setup:

  • Append; overwrite if no apendable media is available

My Exchange backup is correctly creating an IMG000... folder each day (now at 25 since I started this 25 days ago). However, my file system backup created but 10 B2D... files and is overwriting them as required--even though I have used only 25% of the drive's capacity.

Shouldn't this configuration continue to create new IMG folders and B2D files until it hits the 10 GB free space limit, then begin overwriting the old ones?

Or maybe I should ask it this way: how can I accomplish that? I just want the backups to keep appending to the existing file as well as creating new ones, until I hit the 10 GB free space threshhold, then begin creating new backup files.

Comments 5 CommentsJump to latest comment

RahulG's picture

Under tools -Options-Media mangement - there is an option Thorough which you can set which media backup jo should overite first i.e overwrite scratch media  or recycleable media . IF u have selected the option to overwirte scratch media set , the backup job would create new bkf and img files untill your drive gets full.

you may use the option to allocate maximum size to the back to disk file in the b2d properties but I would not recommend you as it does not have any real benifit mostly when you run GRT backups. Perosonally , I feel when you run backup to disk its better not to use append media options and instead let the backup job create new set of backup to disk files for each job you run. Appending to media helps when you run backup to tape , as you dont want utilize the media completly

refer the following document

 http://www.symantec.com/docs/HOWTO22728

 

Beethoven's picture

It is already set to overwrite scratch media first.

RahulG's picture

You may also set Low disk space threshold

Beethoven's picture

Sorry...I read only the first half of your answer before...missed the information on append vs. overwrite, etc. I unchecked Allocate the maximum size for backkup-to-disk files and set backups to overwrite instead of append. I will check to see if that acts as expected.

I have the low disk space threshhold set at 10 GB (I think I referred to it as free space threshhold above).

Thank you!

Colin Weaver's picture

Well first of all GRT backups (those that create IMG folder such as your Exchange backup) always overwritre and they ignore any setting to append at Start  as the IMG process cannot append.

Then be aware that an overwrite with no overwriteable media = a file create

 

Next problem is your bkf files and you overwrite protection of none. think about this scenario

1) You start with a new bkf file and it does not reach 100% Capacity, however while this job is running a second job starts in parallel with the first and starts another bkf file that also does not reach 100% capacity

2) Then next day two more jobs run which append to the bkf  files and this time they do reach 100% capacity, but 1 job reached that capacity before the other.

3) The first job to reach capacity creates a 3rd bkf file.

4)The second job to reach capacity, switches to overwrite mode (as you cannot append to media when a job spans to more than one tape). It then looks for an overwriteable piece of media and finds the first bkf used by the first job and because you have 0 hours overwrite protection it overwrites it.

5) if you think about that scenario with maybe a couple more jobs in the mix then you should be able to see that eventually you will reach a semi-stable point where you seem to get no more bkf files. (Even with only 1 job you can have the snake of linked bkf files eating their own tail after a couple of days). You have also introduced a potential data loss scenario as you have 0 hours overwritre protection.

Basically never, ever set your overwrite protection to none/0 hours unless your really do want to have your data erased not long after the bkf is last written to (either filled up or last job)

Also do not do append jobs on disk unless you have a good reason to use the Allocate Max size for disk files setting. If you go to BE 2012 it won't let you do an append job on disk, however the allocate max size setting has an option to allocate in set chunks up to the max size and also will truncate the file if not full at the end of the job. (11D cannot do this)

Also don't use the disk space reserve as a deliberate thing to try and hit, it is a safety net to stop you filling the drive, if you let it hit the reserve your backups will fail. In fact we do not have a way to safely achieve what you have asked for in your "look at this another way" paragraph as we would not recommend anyone tries to use such a scenario due to the dangers.

 

What you should do is understand how long your need to keep your data for against each day's backup and ignore disk space unless you do not have enough space to keep that much data. Then you should set an appropriate overwrite protection setting and also set the jobs to start as Overwrite and then switch off the allocate max size option (or upgrade to 2012 if you must do that but read up on DLM before considering this option)