Video Screencast Help

Backup To Disk Jobs Stay Queued

Created: 16 Dec 2006 • Updated: 21 May 2010 | 4 comments

Server OS: WinServer 2003 Standard. Started out this whole ordeal having backup exec 9.1 installed.

We purchased a new disk array and transferred the backup-to-disk folders and files to it. After that when a job would run it stayed in the "Queued" status. I checked for .lck files, that the server wasn't paused, and tried replacing the .cfg file in the off chance they were corrupted some how. None of these suggestions worked. I then tried deleting and recreating the backup to disk files. Still didn't work. In then uninstalled 9.1 and installed a fresh copy of 11d (had planned to upgrade anyways). I setup all the devices and jobs again from scratch and still the same "Queued" problem.

I just tried making a backup to disk device that was stored on a different drive (then the new array) and it worked perfectly. Does backup exec not "play well in the sandbox" with disks/partitions that are larger then 4TB? The array I�m trying to write to is a 4.5TB SyneRAID6-16SSA attached to an LSI Ultra320 SCSI adapter. It�s a Basic Disk GPT, 1 4190.82 GB NTFS partition. I'm able to move, copy, delete and create files on the array just fine in explorer and other applications.

I think that is just about everything I can think of that may be relevant. Help/suggestions would be greatly appreciated.

Nathan

Comments 4 CommentsJump to latest comment

Deepali Badave's picture

Hello,

What errors you are getting in the event logs?

Regards,

Nathan Heck's picture

There are no Backup Exec alerts (other then the automatic cancellation alert after the job has stayed "Queued" for 24 hours).

The following errors were found in the application event log:

An error occurred while processing a B2D command.
Drive: ReadFMTable() SetFilePointer failed (E:\Backup-To-Disk\Daily17\B2D000011.bkf). Error=87

An error occurred while processing a B2D command.
Changer: Couldn't ReadFMTables/RecoverBKF (E:\Backup-To-Disk\Daily17\B2D000011.bkf). Error=87

I searched Symantec's knowledge base and found nothing for this error.

Nathan Heck's picture

I believe I found the answer to my original question (but in the process have arrived at new ones).

From Charlie Compton in thread: http://forums.veritas.com/discussions/thread.jspa?...

"Devices -> Backup2 Disk Folder -> Properties -> Advanced

Device Settings - uncheck auto detect, check buffered reads and buffered writes."

This appears to have fixed my problem, but raises another question I�d like answered by Symantec. Why would Backup Exec not be able to auto detect device settings on an external raid subsystem? And since it appears to be the case that "Auto Detect" doesn't work on external raid subsystems why hasn't there at least been a public knowledge base article posted (I spoke with a Symantec tech support rep and they told me that 2 internal knowledge base articles already exist but have not been published by their advanced group) and an informative line of text added below the auto detect checkbox stating that it should be unchecked for most external raid subsystems, or at least something eluding to the point that "if you are having problems uncheck this box"? Granted a solution would be great but my previously suggestions would be a good "band aid" until the solution can be found. If Symantec wants to keep their customers they need to start doing a better job supporting them and admitting to their and their product�s faults.

Thank you Charlie for answering my question (I�d like the points awarded to Charlie).

Anxiously awaiting an explanation�