Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup to disk (pool) keeps creating folders and .cfg files

Created: 01 Oct 2013 | 3 comments

Hi there,

We use 2 removable harddisk to rotate weekly. Some jobs run on seperate times. They have the same backup set but different device targets.

Harddisk 1: created a folder called disk1 and subfolder for each job.

Harddisk 2: folder called disk2 also subfolders with same name for device.

Created a pool per job, so 2 devices per pool.

This went fine the 1st week. After the change of disk on friday and restart of the backup exec services, I see strange behaviour.

Today disk 1 is in the server. The folder (device) existst. Somehow at the start of the job it tries to acces the device for disk 2 (previous week). It can't find it (thats OK) so it looks in the pool for another device, and finds it in disk1 folder. So it starts. But .... it did create the folder structure for disk 2.

So it did not find disk 2, uses disk 1, creates folder for disk 2. I am afraid that it will use the disk 2 folder created on disk 1 the next run allthough the physical disk 1 is in the server.

How can I prevent the creation of another folder?

I thought that using pools would prevent this. The job should look for an available device within the pool. When it finds one, use it.

Marcel

Operating Systems:

Comments 3 CommentsJump to latest comment

Jaydeep S's picture

Marcel if you are using removable disks for backups, you need to configure them as removable B2D folder.

http://www.symantec.com/docs/HOWTO55855

MarcelB's picture

I saw various setups for this. Since the disk are being access via UNC path and are not USB disks....

Also the article you mention says not to use Removable disk but the standard B2D device option. I have this.

BTW a noticed that every device listed in devices are being created (folders) when the Backup Exec Services are restarted. Also devices not being used at all. I have removed them.

Leaving me to the point why jobs do create thos folders and not use them the first time. Tests just performed pointed me to that I first lookes at the last device being used in the pool. If that one is unavailable it will search fotr another device and uses that one. Still it creates the folder for the not found device. After a week the disk will be replaced and the problems will start from that point.

-

Marcel

Colin Weaver's picture

Unplugging USB disks that are accessed over UNC paths and not directly connected to the media server is something we have not designed into the product and do not officially test/support. As such it is possible you might experience some strange problems with this configuration.

If you did have the USB disk directly connected to the media server then in BE 2010 R2 and R3, we did have a defect where a service restart might create the folders names for the wrong USB disks. The fix for this was to create files with no extension with the same names as the folders on the other USB disks so that the servcie restart cannot create the folders - it is possble this same workaround may help you although at the end of the day your scenario is likely to remain as reasonable efforts support only. and not something we can contribute further on.

BTW I hope the reason your USB disk being on shared is NOT because your media server is virtualized as if that is the case then you shodul move to a physical media server as per various recommendations for BE.