Video Screencast Help

Backup of DMZ server

Created: 03 May 2013 • Updated: 03 May 2013 | 5 comments
This issue has been solved. See solution.

I have a server in the DMZ. It is not on the domain. I get an error msg access denied when I try to backup this server. The client netbackup services are running under the system account. I created a netbackup local account, added the account to the administrators and backup operators group. I have the netbackup client service and the netbackup legacy client service run under the nbackup account. But the netbackup legacy network service does not start under the nbackup account. The backups are failing due to access denied.

Operating Systems:

Comments 5 CommentsJump to latest comment

Mark_Solutions's picture

The accounts should not matter and do not need to be set to use an anything other than the local system so please change them back and get them running

On the client add a hosts file entry for the Master and media servers (short and FQDN) and in the Master and Media Servers add a hosts file entry for the client (again short and FQDN)

Access denied means it cannot resolve the Master or Media servers name to one in its server list

The hosts file entroes should sort that out but if not then create the \netbackup\logs\bpcd folder and next time you run the job or try and conect to the clients host proerties see what the log says the issue is  - this will be quite clear

If however your firewall uses NAT you will have problems getting a backup from the client

If you are restricted on ports also make sure that you have set the client up appropriately in the Master Servers Host properties - Client Attributes section ... but as you get access denied i am guessing the hosts file entries willo resolve it for you

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
snawaz3's picture

After I posted the query, I set the logon for the netbackup client service and the netbackup legacy client service to run under the nbackup account. And I left the netbackup legacy network service to run under the system account. I was granted access and the bacup completed. Should I change these services back to run under system account and try adding the hosts entries on the client and master/media server? I am a believer of if it works dont touch it. But am not sure what the consequences would be. Thanks

Mark_Solutions's picture

If it works leave it be! - Just make sure that account is good to backup everything on that client

If the NetBackup Legacy Network Service does not run and you are using the vnetd option to do the backup through the firewall then that would be why it did not work - as that service is actually vnetd!

Glad you are sorted

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

snawaz3's picture

the nbackup account is a member of the administrators and backup operaters group

Mark_Solutions's picture

Good stuff - you should be fine then - thanks for the feed back

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.