Video Screencast Help

Backup on exchange failed

Created: 12 Sep 2013 • Updated: 16 Sep 2013 | 6 comments
Holloween's picture
This issue has been solved. See solution.

Dear community,

My backup on exchange failed 3 days straight recently.

I have logged a case with Symantec support.

The support provided the following solution:

- Uncheck the selections, and reselect the selections

- Uncheck snapshot technology (snapshot technology was used in the existing setting)

- Restart the exchange server

*Note: Exchange is running on DAG. I have not restarted the exchange as this will failover to another site.

 

The support mentioned that it is recommended not to uncheck "snapshot technology" when backing up exchange. Unfortunately, there is no article on this.

My question is as follows:

- Is snapshot technology not recommended when backing up exchange?

- After unchecking the "snapshot technology", do I really need to restart my exchange server?

 

Is anyone able to shed some knowledge on this please?

 

Thank you very much.

**Attached are the screenshots of the error messages. Screenshots are edited to masked certain information.

Operating Systems:

Comments 6 CommentsJump to latest comment

pkh's picture

As a general rule, you do not enable AOF (snapshot technology) )when you are backing Exchange or other databases.  You don't have to restart any servers.  You only need to disable AOF in your job.

From a commd prompt, run

vssadmin list writers.

If there are any writers that are not o.k., then you would need to restart your Exchange server,

Are you backing up the passive copy of your Exchange?  If so, I think you need to switch to backup your active copy.

 

Holloween's picture

Thanks pkh for the advice.

Yes, my writers are OK.

How do I check if I am backing up the passive or active copy of my exchange?

Holloween's picture

Alright, I have checked and I am backing up the active copy.

Will update again after I tried unchecking the snapshot technology option.

Holloween's picture

Hi pkh,

I have uncheck the snapshot technology option and it still fails after running for about 50 mins.

Getting the same error.

 

My last bet is to restart the exchange DAG server and then run the backup job again without the snapshot technology option, but we would really like to prevent that.

 

We have logged a case with Microsoft concurrently to check on this issue too.

Donald Eady's picture

Halloween when you ran the Vssadmin list writers command did you run this on all boxes in the dag? If not please verify that the writers on all boxes in the DAG are state 1 stable 

I hope this posting was helpful

  

Holloween's picture
Issue resolved.
 
Donald: I ran "vssadmin list writers" in 2 exchange servers in the DAG. They are showing with no errors.
 
A support engineer from Microsoft asked me to run the following in Exchange Shell:
 
Get-MailboxDatabase -Server <servername> -Status | fl Name, Identity, LastFullBackup, LastIncrementalBackup, LastDifferentialBackup, Backupinprogress
 
In my case, the "BackupInProgress" in one of the exchange server is set to True. (See attached)
However, no backup was running at that point of time. This prompts me to restart that individual exchange server.
 
Ran the same powershell again, this time the BackupInProgress is set to "False"
 
Backup run perfect.
 
Thanks all for the advice.
 
BackupInProgress.jpg
SOLUTION