Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

backup exchange v2010 dag with BE2012-SP2, strange behavior

Created: 15 Aug 2013 | 5 comments

hello all,

I've just installed the SP2 on my BE2012-SP1a installation. I had to do this, because I hade a call with symantec, they told me to install the SP2 patch to solve one of another problem (see https://www-secure.symantec.com/connect/forums/exchange-dag-duplicate-job-tape-timestamp-515-error

I have installed the SP2 and updated the database-agent on my exchange-servers.

Now I've tried to back one of my exchange-servers and now I see that the behavior from the full backup is quit different then in the SP1a version.
The backup does also backup the exchange-database files, which it didn't in the SP1a version. But let me explain my configuration:

I have 3 exchange v2010 servers in a DAG configuration.

In the BE-2012-SP1a installation I made weekly fullbackups of my exchange-servers, for system recovery.

see picture_1 for the backup properties, (there is no exchange information store available, I think because this server is in a DAG???). I've selected all drives and systemstate and nothing excluded.

see picture_2 for the backup options (there is no microsoft exchange option)

This backup job  created a full-backup (for system recovery). When I check the content of this backup, I see that from the directory d:\exchange ,
no xxx.edb files have been backed up. That was correct in my opinion. In my believe the agent excluded automatically all exchange databases and log files.

see picture_3, just different files but no xxx.edb files in the backup

-------------------------- 
The MBXDAG backup runs every day. This makes just exchange database and log-file backups. The configuration shows the the exchange properties,
see picture_4 and picture_5

After SP2 installation:
================
After the SP2 installation, I upgraded the agents on my exchange servers adn did a fullbackup. I didn't change anything on the job definition nor on the
job-properties etc.
The fullbackup did finish without error. But, when I check the content of the backup, I see that there is suddenly a xxx.edb file in the backup.
This, I did not expect, whats wrong??

see picture_6, there is an xxx.edb file show in the content

Question: What did I wrong? Do I have to exclude all the xxx.edb and xxx.log files in this job definition. As far as I know, in my fullbackup job
I do a "filebackup". But the agent should exclude the edb-files automatically ( at least it did in SP1a). Has this behaviour changed with SP2??

regards goro1503

Operating Systems:

Comments 5 CommentsJump to latest comment

pkh's picture

The .edb files should be automatically excluded by AFE.  Try this

1) push out the remote agent again to the Exchange servers.

2) reboot both the media server and the Exchange servers.

3) Use a new job to backup the files on the Exchange server.

If you still find .ebd files in your backups, then you should log a support case with Symantec and report this.

goro1503's picture

Hi pkh

thanks for your answer. I had to reboot the media server after the installation of the SP2. I couldn't push
out the new agent since the GUI didn't let me. So I installed the new agent locally on the exchange servers.

I'll try to find a timeslice to reboot the exchange servers and I will recreate the backup jobs.

But a the end, it's realy frustrating with this software. Every time a new patch comes out, you have to reboot
the hole mess. After the installation of a new SP you have to check all pices of the software, because
the programmers from symantec are not able to fix something without destroing another thing which worked
well in the old version.
 

regard from a verry frusted longtime BE-User

goro1503

MusSeth's picture

Hello goro,

Please check the following registry HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Engine\Misc\exclude active files
If registry set 0 that means active file exclusion is set to disable and thus backup exec will backup active files set the registry 1...reboot the server and than rerun the backup....
Hope this resolves the issue.

goro1503's picture

Hi Mus Seth

thanks for your anwser. I've just checke the registry on one of my exchange servers. There is no entry
in the registry for:

HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Engine\Misc\exclude active files

What I don't understand in your mail is: why should I change this registry key (if it would exist)? Bevor I
upgraded with the SP2 then the backup behavied as explained in the former Post. It excluded the
database and log files automatically.
Since this registry key is now not present, then I think ist wasn't there also bevor I upgraded. Otherwise if
SP2 removed this key, then I would expect to read somethinh about this in the readme notes, since this
would change the way the agent works.

regards goro1503

goro1503's picture

Hi all
 

Just to inform you. I' had to exclude the log and database file in the fullbackups of my exchange
servers, otherwise the logs and edb will be backed up. It seems that AFE doesn't work,
at least in my case within BackupExec 2012 with SP2, it doesn't.

 I'm really fed up with this software. In my believe, a backup-software should be reliable.

regards goro1503