Video Screencast Help

Backup Exec 12 - cannot start the device and media service

Created: 13 May 2012 | 5 comments

We have some maintenance this weekend on the backup exec server and it seems that the device and media service won't start anymore. 

Attached the dbrecover.log, I can see the MDF and LDF file fine and browse the database using the MSSQL admin interface. 

Any ideas what would be causing such errors? 

Comments 5 CommentsJump to latest comment

Backup_Exec's picture

Hi

 

Please check the link below

 http://www.symantec.com/docs/TECH129178

 http://www.symantec.com/docs/TECH163556

 

Thanks

 

 

Sameer

Don't forget to give a "Thumbs Up" or Mark as "Solution" if someones advice has helped you.

Olivier L's picture

Thanks for the links. 

  • the server name didn't change, I can see the files using the path written in the log file
  • the MSSQL instance is not in single user mode

Any other hints? 

Backup_Exec's picture

Hi

Check then if this works stop sql service for backupexec & then rename the exisiting data folder to data_old & then make new folder called as Data

Once done please copy bedb_dat.bak & bedb_log.bak and bedb.bak file from data_old to new data folder

Now please change the bedb_dat.bak & bedb_log.bak to bedb_dat.mdf & bedb_log.ldf

Now try to start the sql service for backupexec & then try starting device & media and see if that helps(to see if it works with blank database atleast)

If the services working fine then browse to backupexec directory & open beutility & right click on your server name & click on recover database & then click reload from backup so that you will get all your lost data again (to get your configuration back from backup file)

 

Thanks

Sameer

Don't forget to give a "Thumbs Up" or Mark as "Solution" if someones advice has helped you.

pkh's picture

If the user needs to start with a fresh database, he can use BEUtility to do so.  He does not have to go through all the trouble.  Being able to start the service with a fresh database does not prove a thing.  It is only when he is able to start the service after reloading from the database backup then he would have solved his problem.  He might as well reload the BEDB, instead of mucking around with a fresh database.

Olivier L's picture

I managed to get the media service running by modifying the security of MSSQL. 

 

Now, I have a different error, the job engine service won't start. I have this error in the event log:

 

Bengine.exe application error occurs, version 12.0.1364.158, faulting module ntdll.dll,version 5.2.3790.4937, error address 0x0001a1c1

For more information, please refer to the http://go.microsoft.com/fwlink/events.asp [Help and Support Center.