Video Screencast Help

Backup Exec 12.0 and SQL 2008 problem

Created: 30 Oct 2013 • Updated: 04 Nov 2013 | 9 comments
ashton_har's picture
This issue has been solved. See solution.

We have a server (Windows 2008 Standard 32bit) which was running Symantec Backup Exec 12.0 (12.1364) with SQL Express 2005 .

The customer had to uninstall SQL 2005, in order to install SQL 2008 for a new version of their logistics software (Had to be done with a clean SQL installation - after that we could and did reinstalled SQL 2005 express).

The problem is that Backup Exec is not running any more . The Backup Exec services are not starting due to dependencies . When we try to repair the installation we get errors due to dependencies..

When we run BE Utility we get errors when checking the consistency of the db,

When we try to enable communications with the managed media server we get

Server:SERVERNAME, Service:BackupExecDeviceMediaService failed to start

Error:(1068) - The dependency service or group failed to start

Is there a solution ?

(we have a backup of the database)

Operating Systems:

Comments 9 CommentsJump to latest comment

Jaydeep S's picture

1. When you uninstalled the SQL Express inorder to perfrom a clean install of SQL 2008, did you backup the Backup Exec database?

2. Is the new SQL Express instance installed with the same name or a different name? Also, is it the same version / patch.

3. In either case, you would need the Backup Exec database (BEDB) which needs to be attached to this new instance. If this is an instance with a different name, BE configuration needs to be changed. You could try this using beutility (move database instance). This may fail as the original instance does not exist. If this fails, open a support case and have this changed manually.

ashton_har's picture

1/ Yes we did backup the BE database before .

2/ We don't know that . We didn't made the installation . How can we check this ?

3/ We tried to attach the db, but it failed. Can we open a support ticket while the customer doesn't have an active support contract ?

If we completely uninstall the product, and reinstall it can we import to the new installation the backup database ?

Jaydeep S's picture

You can see the instance name from SQL Management Studio Express or in Windows Services. But you might not know what the old instance name was. What is the error that you get while attaching the database. Uninstall / reinstall might help, but you still need to get the old database imported to the new one and have the catalogs migrated manually.

As for the support ticket, I am not sure about the process involving the partners. I suggested to open a case as the technicians online might be able to fix this faster.

ashton_har's picture

Well we see a BEDB database attached in the SQL 2008 Management Studio.. I guess this is not right..

If we upgrade to a newer version (that supports SQL2008) can we solve the issue ?

ashton_har's picture

Well..

we detached the BEDB from SQL 2008 instance.

but ..

Whenever we try to install an SQL 2005 Express instance named BKUPEXEC, we get always the same eerror

backupexec-3.jpg

 

We can install a new SQL 2005 Express instance if we give it a new name -i.e. BACKUPEXEC.

But when we try to change the backup Exec Database Location via Backup Exec Utility

backupexec-4.jpg

we have an error

backupexec-5.jpg

because it  failed to start the SQL service (which is running..) failed to detach database BEDB from server servername\BACKUPEXEC (where it's not attached...) and failed to attach BEDB to server...

We even tried upgrading to Backup Exec 12.5 but..

backupexec-1.jpg

we got this.. which is strange, as the bundled with BE 12.0 SQL is SP2 ..

backupexec-2.jpg

Any suggestions ?

p.s. Opened a support case, talked with a TSE and still waiting after 48hrs for the Symantec SQL engineer to contact us ..

CraigV's picture

Hi Ashton,

 

I assume you have followed the TN below to manually install the BEDB:

http://www.symantec.com/business/support/index?page=content&id=TECH87111

Have you tried a simple repair of Backup Exec through Add/Remove Programs?

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

ashton_har's picture

Yes we followed the instructions for manually installing the BEDB.

And yes we have tried a repair of BE 12 with Add/Remove Programs, but it fails (as i stated in the first post ..)

CraigV's picture

Apologies for not picking that up.
Have you tried bemig.exe to see if it migrates the database? Not sure if this would work if the database is not mounted. Otherwise, grab copies of the Data and Catalogs folders, and consider a reinstallation carefully.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

ashton_har's picture

We finally managed to have a running installation following those steps

Uninstalled Backup Exec 12 via add remove programs, and selected to remove ALL components

Uninstall finished ok, BUT while Live Update folder was deleted, Program Files\Symantec\Backup Exec remained in place.

Symantec BE 12, still remained in the add/remove program list - but when we tried to uninstall it again we got an error that this could be done only with installed programs.

We manually deleted every 'BKUPEXEC' value from the registry (one couldn't be deleted).

Then we reinstalled Backup Exec 12. the installation program asked us for the database instance, and we pointed it to the 'BACKUPEXEC' instance that we had created in the previous attempts.

The installation finished without errors, BUT when we started the BE 12 console it still didn't work as all the backup exec services couldn't be started (except the Remote Agent).

We copied the database via backup exec utility from a previous backup, but still the be services couldn't be started .

So, we finaly tried and upgraed to Backup Exec 12.5, re entered administrator credentials during setup, the setup finished smoothly, and after that the services started normaly and backup exec is up & running.

 

SOLUTION