Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Backup Exec 12.5 for Oracle RAC database

Created: 26 Jul 2013 • Updated: 19 Aug 2013 | 22 comments
This issue has been solved. See solution.

Hi All,

Does anyone have or know a good doc/link on how to setup Backup Exec 12.5 remote agent for Oracle RAC?

Here is my setup:

Backup Server:

- Windows 2003 Standard 32-bit

- Backup Exec 12.5

Oracle Servers:

- Windows 2008 R2 Ent

- Oracle 11g with RAC config.

 

Thanks in advance.

Operating Systems:

Comments 22 CommentsJump to latest comment

MusSeth's picture
Configuring Oracle Agent on Windows

 

Database Access Tab

  • You will need to configure the Database Access Tab first. Make sure the name used in "Use full computer..." is the same name as "Published names for this agent" on the Publishing tab.

dbtab.PNG

Oracle Tab

  • You will then need to configure the Oracle Tab

oracletab_0.PNGoracletab2_0.PNG

 

Modify List on Media Server
  • On the Media Server you will need to add the oracle server to the modify list. (Tools | Options | Oracle)
  • This should match what is specified in the database access tab

modifylist.png

Oracle1: is oracle server

brownbag: oracle instance name

following needs to be done on all the nodes of RAC with the repected instance and server name

 

 

Kunal.Mudliyar's picture

After you are done with above. On the BE server go to tools->Options->oracle->modify list

  • For each physical node, you will need to add a new entry

 

  •   Basically, you enter the name of the RAC node ( FQDN) and you relate that to an existing logon account. 

  • Add the virtual node name and the corresponding Windows account that will be used to authenticate the connection.  RAC-DatabaseName-DatabaseID eg "RAC-PHAROS-3514636826"

After the Remote agent and Backup exec is set with oracle configuration

Restart the services and select the oracle database from the "Real application cluster" Node from the selection list

Remember if you see the oracle database under the oracle node in the selection list something is wrong in configuring oracle cluster or backup exec

RAC database should always show up under real application cluster in the oracle node

one tip is too add the host entries for oracle nodes in the backup exec host file and

backup exec servers host entry to all the nodes associated in the RAC

 

http://www.symantec.com/docs/HOWTO73891 sums it up

 

Technical Support

Symantec

MusSeth's picture

Kunal steps mentioned in your post are for linux yogi has windows servers

Oracle Servers:

- Windows 2008 R2 Ent

- Oracle 11g with RAC config.

yoogi68's picture

First of all, I want to Thank You all for your valuable comments and suggestion! Especially MusSeth's pictures!

After following MusSeth and Kunal configuration steps, I got the error below when I try to run a test backup.

Final error: 0xe0001405 - Unknown CORBA exception. Unable to contact the media server. Confirm that the Backup Exec Job Engine service is running on the media server.
Final error category: Resource Errors
 

BES01.jpg

I did look at the link, but did not seem to help much.

- All Firewall and Anti-virus is off, even took Kunal advice and added all hosts entry to all of the servers.

Anyone have other suggestions or tricks I can try? 

Thanks in advance!

Kunal.Mudliyar's picture

Look like port 5633 is blocked on the oracle server or in use

change the oracle port to a custom port lets say 5635 on remote agent and backup exec

Follow this

http://www.symantec.com/docs/TECH58180

 

Edit

Match the same port on all the nodes by editing the remote agent utility

Technical Support

Symantec

yoogi68's picture

Hi Kunal,

Change the custom port to 56388 on the agent, restart the agent service

Change the custom Oracle/DB2 port to 56388 on the Backup Exec Server, restarted all of the services.

Same error message:

Completed status: Failed
Final error: 0xe0001405 - Unknown CORBA exception. Unable to contact the media server. Confirm that the Backup Exec Job Engine service is running on the media server.
Final error category: Resource Errors
 

Thanks. :(

Kunal.Mudliyar's picture

Are you sure this port is not blocked 56388?

BE is on 2003 and Oracle on is on 2008

I think IPV6 can cause this issue as well

Try disabling IPV6 on 2008 or

 Make sure that the "::1    localhost" line is present in %Systemroot%\system32\Drivers\etc\hosts file (even on Windows 2003)

 http://www.symantec.com/docs/TECH64837

Technical Support

Symantec

yoogi68's picture

Hi Kunal,

I did check the kb: http://www.symantec.com/business/support/index?pag...

Disabled the IPv6 in the registry and added the localhost entries in the hosts file on all the the servers.

I'm not sure about the port block, I can't see how it would be block since there is not firewall or anything.  The backup job does run for about 30 seconds and I do see the "backup job is running" message on the Backup agent.

So mind bottling.... :(

Thanks!

Kunal.Mudliyar's picture

I am wondering if a 5 digit port number caused this?

Can you try 5634 5635 or 5636

Even if the windows firewall is disabled, if there is a hardware firewall in picture u need to get the network guy in to forward the ports

Now I am assuming you have dont this port change on all the nodes and BE

One resolution could be uninstalling and reinstalling the remote agents and reconfiguring them with a custom port

Try to disable the firewall on the BE server if not already

form the command prompt of the media server try

"telnet <ipadd of oracle node> 5633 (or custom port)"

If yout unable to connect to host or host not responding it surely means the port is blocked on the oracle server

 

Technical Support

Symantec

yoogi68's picture

Hi Kunal,

So we changed to 5636 on all of the Oracle RAC agents, and the media server, still no luck.

All of the servers are on the same switch, so there should NOT be any hardware firewall or filter.

We did try telnet "server ip" 5636, connect failed, but we also tried the telnet command on another working site with only single Oracle DB server and Backup Exec agent installed and still could not connect using the default port of 5633, so I'm not sure if the port is open all the time.

Thanks!

pkh's picture

I hope that your Oracle version is not 11g R2 because this is not supported by BE 12.5.  BE 12.5 only support  11g.  See the SCL below

BE 12.5 Software (SCL)

Also, is your Oracle a 64 bit version?  A 32 bit Oracle on a 64 bit OS (Server 2008 R2) is not supported.  See Note 5 on page 22 of the SCL.

SOLUTION
yoogi68's picture

Hi pkh,

It is release 11.2.0.3, does this means 11g R2?

It is a 64bit Oracle Ent. on 64-bit Windows Ent.

Thanks!

pkh's picture

It is release 11.2.0.3, does this means 11g R2?

Yes.  It is 11g R2, hence it is not supported by BE 12.5

You would need to upgrade to either BE 2010 R3 or BE 2012 to get that configuration supported.  The upgrade is free if you are on a current maintenance contract.

Kunal.Mudliyar's picture

Agree with pkh

If everything else is okay it could be due to a non compatible agent

BE 12.5 SCL lists 11g as supported version

BE 2010 SCL lists 11g R2 exclusively

You might want to upgrade the software

 

Technical Support

Symantec

pkh's picture

If you agree with an answer, just give it a thumbs up.  There is no need to repeat it.

Kunal.Mudliyar's picture

There is a differnce between repeating and clarifying.

Technical Support

Symantec

yoogi68's picture

Thank you all!

I will install the latest Backup Exec trial and report back.  I assume the configuration process should be similar?

Thanks.

Kunal.Mudliyar's picture

Yes it's the same but before configuring make sure you also update all rac nodes with the 2010 remote agent...

Technical Support

Symantec

pkh's picture

Download and install the latest SP

Backup Exec 2010 R3 revision 5204 Service Pack 3
 
Backup Exec 2012 revision 1798 Service Pack 2
 
Make sure that you push out the remote agent after installing the SP.
yoogi68's picture

Thank you all for your help!! using the latest version of Backup Exec seems to resolve the issue.