Video Screencast Help

Backup Exec 12.5 problem

Created: 04 Nov 2010 • Updated: 15 Feb 2013 | 9 comments
This issue has been solved. See solution.
we have a big problem with BackupExec, that we've been unable to fix. Probably we have to uninstall and re-install it. To save a lot of work I would try to use the settings of the backup jobs, tape configuration, weekdays, sample list etc. for later time.
Does anybody know where these files are located?
We're unable to do because we cannot start the Backup Exec Server Service.

Comments 9 CommentsJump to latest comment

CraigV's picture

Hi Brav,

2 things to try before completely reinstalling:

1. Use Beutility to run a repair on your DB. This is non-destructive.

2. Run a repair of BE through Add/Remove Programs which will repair any issues with your installation.

What errors are you getting in Event Viewer too?


Alternative ways to access Backup Exec Technical Support:

brav's picture

Hi Craig,

Thanks for the reply. I've tried to repair the install, it didn't work. We get a Visual C++ runtime error when trying to restart the services . A microsoft KB advises to re-install the .NetFramework , i've tried this but again no success.

There aren't any errors in the event viewer I'm afraid.

I'll try the Beutility & see how that goes . Thanks


brav's picture

Starting database repair.
Stopping Services
Stopping services for server:INPARDC01.
Server:INPARDC01, Service:BackupExecAgentBrowser stopped successfully or was not running.
Server:INPARDC01, Service:BackupExecJobEngine stopped successfully or was not running.
Server:INPARDC01, Service:BackupExecRPCService stopped successfully or was not running.
Server:INPARDC01, Service:BackupExecDeviceMediaService stopped successfully or was not running.
Stopping services for server INPARDC01 completed.
Performing repair for BEDB database.
Starting Services
Starting services for server:INPARDC01.
Server:INPARDC01, Service:BackupExecDeviceMediaService started successfully.
Server:INPARDC01, Service:BackupExecRPCService failed to start.

Error: (1068) - The dependency service or group failed to start

Any other Ideas ?


CraigV's picture don't run a CASO environment do you?
What happens if you open services.msc and reinput the username/password for Backup Exec (which I assume is a domain account with proper priviledges?)? Can you start the services up then?

Alternative ways to access Backup Exec Technical Support:

brav's picture

We don't run it in a CASO environment & I've readded the username/password for the server & yes it is a domain admin account .


Hywel Mallett's picture

I'd be inclined to reinstall - when things go that wrong, if you manage to get it fixed enough to start the services, you never know whether there's anything else still wrong.

You should find a file called BEDB.bak in your Backup Exec folder, which is a backup of the Backup Exec database, taken last time your database maintenance ran (4am by default). This will contain your job definitions and stuff, but not the catalogs. You'll probably want to transfer those too. There will be a catalogs folder in the Backup Exec folder, full of files. You want them all.

Once you've reinstalled, you can use BEUtility to restore the BEDB.bak file.

Kalm's picture

Try to follow the following steps:

1) Re-install the backup exec 12.5 server on alternate machine (just to test first)

2) Stop the backup exec services on the original machine (if any of them is running)

3) Take the backup of following folders from the original machine:

     i) C:\Program Files\Symantec\Backup Exec\Data

    ii) C:\Program Files\Symantec\Backup Exec\Catalogs

4) Stop the backup exec services on the new installed backup exec server.

5) Paste and overwrite the "Data" and "Catalogs" folders whose backup has been taken to the new backup exec server installation at the installed location.

6) Start the services on the new installed backup exec server.

 I hope that it will save your previous configurations and policies.

CraigV's picture

...its always best to know what your suggestion is going to do. Rather that, than have a seriously hacked off forum member who has lost all his data because of a "possible" way of doing things.

Setting up a new server is probably a long-winded way of doing things...try the reinstall, and grab a copy of your Data/Catalogs folders BEFORE doing it. You will need to stop your services to do this...

Alternative ways to access Backup Exec Technical Support:

brav's picture

Hi thanks for the responses.

It was a corrupt bedb file . Using the BeUtility to repair or restore failed to work , so we used the recover database from base option ( this lost all of our job setup settings ) but allowed us to start backup exec. We couldn't use the bedb.bak file because this was corrupt also :/

Unfortunately, the backup exec folder wasn't in the backup jobs , so I've had to re-create the jobs (slightly amended) from the catalogs.

Thanks again for all your help