Video Screencast Help

Backup Exec 12.5 on Server 2008 R2 RTM x64 errors

Created: 14 Aug 2009 • Updated: 21 Aug 2010 | 23 comments


I installed BE 12.5 on Windows Server 2008 R2 Standard RTM x64 today, and am running into some problems.  This is a single-server environment so this server has Active Directory and the media server with an internal tape drive.  I am aware that R2 is not on the compatibility list (yet), but I was hoping I could get some more information.

Here are the issues so far:

1). Installation:  Installs okay, but when it installs service pack or hotfixes I get "Backup Exec Performance Counter Setup has stopped working".  I understand that BEPerfSetup.exe installs the BE performance counters and it is crashing for some reason.


- Is there a workaround/fix for this?

- Will this cause any problems except for BE performance counters not working?

2). Backup:  When I attempt to run a full backup of the server it fails in less than a minute with the following error: "A failure occurred accessing the Writer metadata".  I read through some old articles regarding this error, used vssadmin list writers to check status--okay, VSS startup is set to manual.


- Is there a workaround/fix for this?

- What is the approximate ETA for an update/hotfix that will allow me to run BE 12.x with R2?  If not 12.x then 2010 would be okay, I have support.

- Is there a Beta version available that works with R2?

I need to bring a new server online ASAP and I would like it to run 2008 R2.  I will reluctantly go with 2008 SP2 if necessary so that BE will work since I have tested and it works fine.

Thanks for any help/suggestions.


Comments 23 CommentsJump to latest comment

Hemant Jain's picture

Currently, there are no plans to support Backup Exec 12.5 on WIndows 2008 R2. In future, they might release a hotfix for supporting remote backups of Windows 2008 R2.


JohnFrost's picture

Thanks for responding.

I have resolved the "A failure occurred accessing the Writer metadata" error.  BE was having a problem with the 100MB System Reserved Windows Recovery Environment (WinRE) partition that 2008 R2 creates at the front of the disk.  I used diskpart during install to create a single partition like the default for 2008.

Do you have any technical information regarding expected problems/incompatibilities between 12.5 and R2?

I understand that R2 is not officially supported with 12.5, but through the course of working on BE 2010 you must have a list of at least some of the issues discovered.  What I am looking for is a summary of known issues/limitations.  For example, I discovered that BE will not create a IDR bootable image for R2.

I remember when Vista first came out many software manufacturers said that their product was not designed to work with Vista, however, they said that if you did run it you would have the following issues and provided a list.  Many of the issues were a nuisance or only affected features that you may never use.  This allowed end users to make a choice.

Is there a Beta version of 2010 available?

What is the release timeframe for 2010?

Marcel Moerings's picture

Backup-Exec 12.5 is still running on Wndows Server 2003 R2 and everything seems fine, but when we are trying to back-up a Windows 2008 R2 Enterprise server we run into the same 'A failure occurred accessing the Writer metadata' error. I have taken a look at the partitions on the 2008 disk. The disk is divided into three parts.

1. -   78 MB                       OEM  Partition ()
2. -     2 GB        FAT32   System, Active, Primary Partition (OS)
3. - 134 GB       NTFS     Boot, Page File, Crash Dump, Primary Partition (C:)

I don't seem to have a 100MB System Reserved Windows Recovery Environment (WinRE) partition present, but do have another partition in front of the Windows 2008 R2 partition. These were probably installed by Dell as factory default. I obviously cannot delete the OEM partition and I wonder what the other partition is. It contains two files called bootsect.bak and bootmgr and a subdirectory called boot. I guess it is a boot partition, but I have no clue if it is something Dell but there or if it was installed by Windows 2008 R2. My R2 installation is on one partition as you can see.

My back-up is probably failing because there are two other partitions present in front of the 2008 R2 partition. OEM cannot be removed. OS neither I guess so I am kind of lost. We want to back-up this server using BE 12.5. Why is Windows 2008 R2 not supported yet? It's been RC for a very long time now. Please help!

W P's picture

Your OEM partition issue may have the same size problem as the WinRE one that I ran into.   I had the 100MB WinRE partition but I found an article online which pointed me to assiging the partition a drive letter and then setting up ShadowStorage for it on another larger partition.  Something about VSS not liking partitions that are too small to snapshot.

I've also noticed that my in-place upgrades haven't had this problem but they didn't have the OEM or WinRE partitions to start with.

pamulli's picture

I think it is inexcusable that Symantec would leave their customers completely unsupported with the latest major release of the Windows Server OS. They have known for a long time that this OS was coming out and had access to the software to develop a patch for their customers yet they aren't planning on having a version that will support 2008 R2 until DECEMBER! I'm also hearing that they may not release a patch to make 12.5 compatible which is also unacceptable. I upgraded to 12.5 because I need to support 2008 and now I'm faced with having to upgrade again to support 2008 R2!

I now have a file server with over 3tb of data on it that I can't backup because I keep getting the error "A failure occurred accessing the Writer metadata" from the remote server agent. I for one am an EXTREMELY unhappy Symantec customer and will be looking into other alternatives given how they are leaving their customers totally unsupported for several months. There is just no excuse for this type of lapse and bad planning.


Frank Lesniak's picture


I stumbled across this support article, which leads me to believe that a hotfix to support Server 2008 R2 and WIndows 7 should be released any day now:

From that page:

Product Version
Backup Exec for Windows Servers 12.5

Windows 7 <Support>
Supported with Hotfix xxxxx (AWS Only) (Soft Block)

Windows 2008 R2 <Support>
Supported with Hotfix xxxxx (AWS Only) (Soft Block)

Colin Weaver's picture

 Not sure why it was not mentioned in this thread previously - Limited Remote Agent Support for R2 should be available mid to late October more or less inline with Microsoft's stated general availability date for 2008 R2 (which is 22nd) This has already been mentioned in other posts.

Note i know RTM has been available for a while - but from the point of view of software companies RTM is kind of a marker that lets them know a final build - they still have to test their own products with the RTM build.

Ben L.'s picture

Do you have any technical information regarding expected problems/incompatibilities between 12.5 and R2?  We are still testing with R2 so information is very limited at this time.

Is there a Beta version of 2010 available? There is a beta program going on at the moment that you can sign up for. Please message me for more information on this.

What is the release timeframe for 2010? Generally new releases are set in the 3rd or 4th quarter of the year, but there is no offical release date has been set.

If this response answers your concern, please mark it as a "solution"

robinwilson16's picture

I installed Symantec Backup Exec 12.5 on Windows Server Enterprise 2008 R2 to see if it would work but most of the services won't start.
Backup Exec Device & Media Service just sticks on starting and Backup Exec DLO Administration Service, Backup Exec Job Engine and Backup Exec Server all do the same as well.

I can't even open the admin console due to the services not running.

I too would be happy to beta-test BackupExec 2010.
I will send you a message as well - hope this is ok!


Ben L.'s picture


That is perfectly fine.

If this response answers your concern, please mark it as a "solution"

Steve Alsop's picture

I have been running 12.5 on a 2008 SP2 server for many months without issues.  This is a stand alone server that backs up all my other servers.

I did an in-place upgrade of the 2008 SP2 OS to 2008 R2. 

The only problem I have with BE now is that the management GUI will not launch in the backup server.  I had to install the Backup Exec manager on another server with an older OS.  I then connect to my BE server that way and everything is still working as it should.  My jobs work fine.

There is a GUI glitch that pops up on my older server running the managment tool about "ordinal 450 could not be located in the dynamic link library urlmon.dll".  This does not seem to affect the operation of the backup server however.

All things considered, I am pretty happy.  I have about 50 jobs that run in the scheduler that back up to both DLT and disk and all work.

pamulli's picture

I was able to assign the 100mb system partition a drive letter through Disk Manager and I'm now able to backup data without getting an error.  If it truly is that simple then there really is no excuse for Symantec to not be able to release a patch.  It seems like they need some more pressure from the competitors to be more customer focused.

Rasmus Deleuran's picture

That simple solution helped me out as well. Had the same issue on several W2K8 R2 Servers.

Looking forward to the BuE 2010 release though.

Frank Lesniak's picture

Does anyone know if the GUID-mapped recovery partition issue in 2008 R2 is in fact the very same issue that causes Hyper-V virtual machine snapshots to fail if VMs are stored on a GUID-mapped volume (i.e. a volume without a drive letter)? Reference:

I have a customer that has about 30 VMs on a two-node Hyper-V cluster, so we are obviously out of drive letters. I cannot implement the workaround on the above link, because there are no more drive letters to assign. Also, because of the clustering architecture in Hyper-V R1, we're pretty much stuck with one VM per disk.

I've heard that it's possible to workaround the issues with Server 2008 R2 backups if you assign a drive letter to the recovery partition ( Whether this is true or not, I cannot say.

But this leads me to believe that the incompatibility with Server 2008 R2 and the incompatibility with Hyper-V VMs on GUID drives is really the same issue. If so, should I expect that the Hyper-V issue will be fixed once Server 2008 R2 support exists?

MTD Admin's picture

Hello, has anyone seen if that hotfix is available for BE 12.5 on Server 2008 R2 yet?  I too sent Ben a message asking if I could beta test BE 2010.  Thank you.

teiva-boy's picture

 Once R2 goes GA which is October 22nd, only then after that date will a patch be released.  That has been the official word from Symantec for a while now, and across many of their mainstream products.  

Symantec doesn't follow the First Availability (FA) program or RTM it seems, only the GA or General Availability date.  This way, the product is avail to the entire world, not just folks with an MSDN or EA agreement which represent only a portion of the market.

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) "We backup data to restore, we don't backup data just to back it up."

jaspain's picture

Looks like Hotfix 331998, which updates the BEWS 12.5 Windows remote agents to support Windows Server 2008 R2, has been released. See This is the hotfix referred to in "Product Compatibility Information for Windows 7 and Windows 2008 R2" ( I installed this hotfix on my media server and was then able to do a successful full backup of a Windows 2008 R2 domain controller, including the C drive, Shadow Copy Components, and System State. Upgrading the media server itself to R2 will have to wait for the release of BEWS 2010, but I should be able to move forward with other R2 upgrades meanwhile. What experiences have others had with this hotfix so far?


I'm not even able to install the agent, let alone apply the hotfix. Any things you need to take into account when trying to install the agent on R2?

pehap's picture

ho can i install remote agents, i have applied the hotfix but still can not pushh agents, when i try to install it locally i got incompaibility warning - should i proceed anyway?

C'mon SYMANTEC it's a shame...

pehap's picture

how do i backup my virtual machines then if i can not install the agent on my R2 :(((((((((((((((

Alexxx's picture

I can install it on a win2008 r2 server and it works fine however backing a windows 2008 r2 server up is another thing, it just fails with VSS and i cannot figure out what it is. Even when i dont install the VSS open file component as part of the agent it still fails. All hotfixes have been installed and service is set to manual

ollyparkhouse's picture

Hey guys, just an update as i have been struggling with Symantec support for the last 2 days.
They wont support Server 2008 R2 for 12.5

To make matters worse i have it all installed on a Domain Controller (2008 R2) so they rteally didnt want to touch it, but told me instead to upgrade to Backup Exec 2010 which was compatible with 2008 R2.

Well i have news for you. It dint work.
Tried an upgrade but SQL Express failed to install regardless of how many times i tried. Got Symantec involved, and was told this is a 5 minute job. 2 hours later SQL still wont install. Something to do with it not being able to install the local sqlserver2005$servername accounts. (those accounts existed on the domain from the 12.5 install, so why didnt it try and use them???)
So they advised me to install it it using an external SQL server.
So i did. SQL 2005 instance created on another server, all ready.
I ran the install, and this time it failed creating the services on the BE server, and rolled back. Sadly no log is created despite the View log button, i assume it gets deleted when the roll back kicks in. All i can see ion the event viewer is something to do with SNMP service:
The SNMP Service encountered an error while accessing the registry key SYSTEM\CurrentControlSet\Services\SNMP\Parameters\TrapConfiguration. 
and one other about SNMP trap extension

So far my experience with 2010 isnt that good.

SysAllMighty's picture

Hi guys,

I wanted to add share my experience regarding this issue

Last week we migrated our virtual environment from Hyper-V to Hyper-V R2, of course we couldn't backup our virtual machines anymore after the migration with the error V-79-57344-65233

We opened a case with Symantec and after spending around 5 hours on the phone they gave up so they gave us access to download Backup Exec 2010.  Yesterday we upgraded to 2010 and all jobs, setting, etc were migrated successfully but trying to backup the virtual machines turned out to be a nightmare!!!

I pushed the new agent to the Hyper-V hosts and it was installed successfully.  A restart was required but I tried a backup job before restarting.  I received the following error message: 0xe000fed1 - A failure occurred querying the Writer status

So I restarted the host but then Backup Exec agent fails to start!!!

I'm still fighting...I will keep you posted