Video Screencast Help

Backup exec 2010 B2D problems

Created: 03 Jul 2012 • Updated: 09 Jul 2012 | 5 comments
Nico Swanepoel's picture
This issue has been solved. See solution.

Hi all.  One of our clients have been upgraded to backup exec 2012.  The scheduled daily jobs runs to a Western digital sharespace NAS device, which are failing because the B2D folder goes into an offline state.  The bexec error reads: 

The disk is offline.

This is typically caused by the folder becoming inaccessible due to it being deleted, renamed, or unshared. It may also be caused by a disk full condition. The folder state has been set to offline. Please attend to this condition. Additional detail may be found in the Event Viewer - Application Log.

In the windows app log the following error appears: 

An error occurred while processing a D2B command.  Drive:  OpenPostMTF() (Createfile failed (\\ip address of nas\foldername\backupfile.bkf).  Error=64,

This NAS has more than enough space for the backups, 3 TB, so its not a space issue.  When I run bring the B2D folder back online, and run each job manually then it runs fine.

Any suggestions would be greatly appreciated.

Comments 5 CommentsJump to latest comment

CraigV's picture


Was this a legacy B2D from before the upgrade, or a new B2D?

If it existed prior to the upgrade, check the 2 TNs below for further information:


Alternative ways to access Backup Exec Technical Support:

Nico Swanepoel's picture

Hi Craig

No this is not a legacy folder.  I have tried to run the import legacy wizard but when I give it the existing drive location it tells me it already exist.  Only thing I notice is that under the details of the disk, its pointing to the disk in the following format:  \\ipaddress\folder.  Must I try to map a drive then recreate the b2d folder?

Thanks for your quick reply. 

CraigV's picture

That would work, yes. Pity it doesn't do iSCSI as this would resolve your issue, but as pkh said, you need to run that b2dtest.exe to make sure it is supported.

The only other thing I can think of, and it's absolutely no guarantee it will work, is to integrate the NAS with Active Directory. This way you'd access the NAS which would be integrated into DNS etc. But this is still no guarantee it will work...

Alternative ways to access Backup Exec Technical Support:

pkh's picture

Your WD device is not in the HCL and hence it is not supported.  See the HCL below

BE 2012 HCL

You should test its functionality with


Nico Swanepoel's picture

Will do the 2dtest later this afternoon, the backups which I have started manually is running to the Western Digital device.  Thanks