Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2010 does not see my linux Client

Created: 20 Mar 2013 • Updated: 21 Mar 2013 | 8 comments
This issue has been solved. See solution.

Backup Exec 2010 does not see my linux Client

Hello

Backup Exec 2010 does not see my linux Client under the Favorite Resources tab.

Here is what i've done so far:

1. install BE on a physical windows server 2012 box
2. installed the VRTSralus locally on a virtual Linux EON box (vmware workstation), kernel 2.6 x86
The Agent boots at startup and is currently running fine

3. the netstat -ln -A inet command indicates that tcp port 10000 is actually listening

4. The beremote --log-console displays :

Successfully resolved the ndmp service to port : 10000
BETCPListener : could not bind to port 10000 on ipv4
could not start ndmp listener on port 10000 ... address already in use

Therefore, the problem is there is no trust relationship between the Media Server and the linux box.
I already created the associated service account.

Any advice welcome.
Thank you.

ABackup Exec 2010 does not see my linux Client

Operating Systems:

Comments 8 CommentsJump to latest comment

CraigV's picture

...have you made sure that your version of Linux is supported on the BE 2010 SCL? Check below:

http://www.symantec.com/business/support/index?pag...

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

VJware's picture

Error indicates "address already in use"

Try changing the ndmp port to any available port...once done, add the linux server via user defined selections, then right-click & choose establish trust.

Anthony_D's picture

Hello

Thanks for you replies :-)

@ CraigV : Thanks for this list, I was unaware of it. I just cant believe BE2010 does not support any Debian-based Linux Distro ! That's WEIRD ... however, I want to point out that even not supported, that does not mean it won't work. The Ralus Agent is running on my linux box ! And firewalls have been disabled on both parties ... something is missing in some configuration file according to me. I just cant figure it out at the moment.

@ VJware : ok, I edited the /etc/VRTASralus/ralus.cfg file and changed the Advertisement port number from 10000 to 6101. Then I rebooted both machines (Media Server & linux box) yet they still dont see each others. I can ping them in both ways though, they are both responding well. Is there another config file I should look at by any chance ?

And also : is there any setting I should alter accordingly on the Media Server itself ?

Cheers!!

A

Anthony_D's picture

Ho guys, by the way, I omitted to specify that I currently use the TRIAL BE 2010, which I installed only yesterday. So I hope I get no functional limitations at this point !

CraigV's picture

Anthony: The trial version is fully functional! =)

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

VJware's picture

10000 to 6101

6101 is used by agent browser... change to 11000 or 12000 instead.

Change the port using this KB - http://www.symantec.com/docs/TECH37415 & not by editing the ralus.cfg file

Anthony_D's picture

VJWare : you're making my day, it IS working now  :-)

Here is the whole workaround :

1. you have to set NDMP to 120000 in the /etc/services file (udp / tcp) on the linux box

2. you also have to set it to 12000 on the Media Server (in c:\Windows\system32\drivers\etc\services)

3. The Ralus.cfg file must use 6101 as the Advertisment port number

4. On the Media server : Regedit > HKLM | SOFTWARE | Symantec | Backup Exec for Windows | Backup Exec | Agent Browser | Tcplp : create a DWORD Key nammed "AdvertisementPort" and set to 6101 (Decimal)

Reboot both boxes and launch BE 2010 : The linux box is there ! (providing you set up the service account)

Guys, thank you so much for you help !!!

Anthony

SOLUTION