Video Screencast Help

Backup Exec 2010 R2 cannot work with Tape Drives

Created: 30 Aug 2010 • Updated: 06 Jan 2013 | 16 comments
This issue has been solved. See solution.

We have Quantum Scalar i500 Tape Library with two IBM Ultrium LTO4 Tape Drive. With Backup Exed 2010 everything was working well. but when upgraded to Backup Exec 2010 R2, It seems cannot works with Tape Drives. In Devices view the IBM Tape Drive flashes sometimes and show its busy for a little while repeatedly, but in fact it's not busy. In Home view, Device Summary shows some unbelevable number of Library Drive In Use such as 24 and it changes repeatedly!
When I want to Inventory the Library or run a Backup Job, the job started to run and status stay in running forever and Tape drive flashes for a while as busy repeatedly.
For testing purpose, I've Installed a fresh copy of Backup Exec 2010 R2 and the result was the same.
I have another Backup Exec 12.5 installation which is working with that Tape Library and Drives as well.
The Guest OS is Windows 2008 R2 Enterprise x64. I installed Symentec Drivers for Tape Drives with Quantum Driver for Tape Library.
Is it about the driver problem? If so, how can i solve that?
Please help.

Comments 16 CommentsJump to latest comment

CraigV's picture

Hi there,

If you check the BE 2010 R2 Hardware Compatibility List, it states the following:

4. Required driver support can be found in "DDI 2010 20100215". Use latest DDI available: < >

That link mentions a specific driver revision to use.
The link below is for the latest drivers for BE 2010/2010 R2. Try them, see if they work, and if they do, you can close this off...


Alternative ways to access Backup Exec Technical Support:

h.tavakkoli's picture

Thanks CraigV
It's look like I should install that hotfix before upgrade to 2010 R2.

Hardware Compatibility List document for Backup Exec 2010 R2 says:

A new BE 2010 Device Driver Installer (DDI), version 20100515, has been published: <> Your device may require
that you download and install this DDI, but it is RECOMMENDED that the latest DDI is always used. If the new DDI is utilized, it is required that Intelligent Disaster
Recovery users regenerate the IDR boot media. If you have upgraded to BE 2010 R2, you have the latest device drivers.

But as I mentioned, fresh installation of Backup Exec 2010 R2 does not resolved this too. And now I upgraded to Backup Exec 2010 R2 and that hotfix cannot run on R2 release. What should i do?

Larry Fine's picture

Is this a virtual machine?  You mentioned Guest OS....

With a fresh install of R2, you should have all the right drivers.  Is this SAS or FC?

Can you post your adamm.log file?

If you find this is a solution for the thread, please mark it as such.

CraigV's picture

Maybe try using the manufacturer's drivers then. Restart the services and see what happens.
Failing that, see if there are any new updates for R2 and apply them.
Finally, try running the Device Configuration Wizard within BE 2010 R2, and reinstall the drivers...

Post the results/

Alternative ways to access Backup Exec Technical Support:

h.tavakkoli's picture

To Larry Fine:
Yes it is a Virtual Machine and Tape Drives are FC. The Virtualization is based on VMware vSphere 4.1 with ESXi hosts. The ESXi Servers recognized Tape Library and Tape Drives through FC-HBA and Virtual Machine is connected to Tape Library and Tape Drives through SCSI device which can be selected for VM.
And I attached adamm.log file as a zip archive.

To CraigV:
I've Uninstalled Symantec Drivers and restarted services, but the result was the same. Backup Exec 2010 R2 cannot Inventory Tape Drives yet. (On Windows Server 2008 R2 Enterprise x64, Tape Drives is recognized by Microsoft driver, i cannot find and download any driver from IBM)
Live Update says that Backup Exec 2010 R2 does not have any update.
After that using Device Configuration Wizard, I've installed Symantec drivers again, restarted server and nothing happend.

I've tested Backup Exec 2010 R2 with either Windows 2003 Enterprise x32 & x64, but the result was the same.
One other test was Installing Backup Exec 2010 on Windows 2008 R2 x64 and Updates it with Live Update to SP1. After applying service pack, the same problem happend to Backup Exec 2010 !!!

Be notice that the other installation of Backup Exec 2010 (without updating it) is working well with Tape Library and Tape Drives.

I realy confused and don't know what to do. Any help will be appreciated.

AttachmentSize 23.37 KB
pkh's picture

Are all the servers that you have problems with, virtual or physical?

h.tavakkoli's picture

To pkh:
I did not try Backup Exec 2010 R2 on physical server. All I've tried was on virtual. And remember that Backup Exec 2010 (without service pack) is working on virtual now!

CraigV's picture

Oh NPIV working correctly? I know that needs to be invoked on an FC switch and in ESX for it to detect SAN-attached devices.

Alternative ways to access Backup Exec Technical Support:

CraigV's picture

Any news on this issue?

Alternative ways to access Backup Exec Technical Support:

vijaygvk's picture

can anybody help me how to configure Tape Library to VMware VM.



CraigV's picture

...please open a new forum query, although this should be directed at a VM forum, not a Symantec forum...

Alternative ways to access Backup Exec Technical Support:

Colin Weaver's picture

For info at this current time Symantec are not aware that Fiber Channel attachments to libraries from inside a VM are supported by VMware themselves. The only connection types we are aware of are SCSI Passtrhough using Adaptec SCSI cards. As such we do not support Fiber Channel connections to libraries inside a VM.

Note we wish it worked too as a lot of our test systems are VMware based and we ran into all sorts of different unpredictable symptoms when we tried it (over 2 years ago) - which is when we found out that VMware did not support it.

SCSI Passththrough diocument (from us)  is available here

There is another possibility - if you can find an iSCSI library that is supported by Backup Exec it should be possible to attach this to a VM.

CraigV's picture

...would be a LOT simpler if you worked with VMware to enable FC support from a VM! Maybe in future releases!

Alternative ways to access Backup Exec Technical Support:

Roberto Cardin - QualiSystem Networking SA's picture

Dear All

Right now I have solved the problem using VMWARE Redirection :

One of the two Qlogic 8GB it is all redirected to my virtual Machine in this way I am able to see All the Drive and All the Library.

Backup Excec 2010 R2 Work fine !

The problem it is to search into multi-target configuration : With my VMWARE I am not able to configure Multitarget and I can see only the first redirected device.

I any one as some suggest

Very Thanks