Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2010 R2 + Hyper-V GRT Problem

Created: 10 Feb 2011 • Updated: 10 Feb 2011 | 6 comments

I am running Symantec Backup Exec 2010 R2 on a physical Server 2003 SP2 server. I have a Hyper-V host in a workgroup running Server 2008 R2 with 4 VMs at present.

Backup Exec is licensed for Backup Exec, Agent for Exchange, DC, SQL, and Hyper-V.

The guests are running Server 2003 SP 2 and have the guest integration tools installed. Backup Exec agents are installed on the Host and guests.

I have also installed the VHDMount app on the backup server.

I get the following warning when trying to backup the guests to tape using the Hyper-V agent and GRT. The backup completes 100% with this warning:

 

 

Backup- VRTSRV::\\HOST01\Hyper-V?Virtual?Machine\GuestVM01
V-79-57344-38732 - Virtual machine 'GuestVM01' does not meet the requirements necessary for Backup Exec to restore individual application items. You cannot perform GRT-enabled restores of application data from this backup.
V-79-57344-38721 - Failed to mount one or more virtual disk images:

 

Backup- VRTSRV::\\HOST01\Hyper-V?Virtual?Machine\GuestVM02
V-79-57344-38727 - Backup Exec failed to snap virtual machine 'GuestVM02' and was unable to collect the necessary metadata to restore individual application items. You cannot perform GRT-enabled restores of application data from this backup.
V-79-57344-38721 - Failed to mount one or more virtual disk images:

Comments 6 CommentsJump to latest comment

davmar's picture

I'm currently having the same issue, but we do have a bit diffrent environment.

Backup Exec 2010r2 (latests patches) on a Windows 2008r2 Ent. 

Hyper-V  (not r2) on Windows 2008r2 Datacenter

Guests running Windows server 2008r2

 

Not using GRT, and still getting the same exception. I do have a case open with Symantec regarding Hyper-V Backup, so ill try to get a answer on this aswell!.

TPEMIS's picture

 

Anyone get an answer on these? 
 
We are running Backup Exec 2010 r2 (recent patches) on a Windows 2008 r2 STD with SP1.  
 
Cant seem to get past these?  Followed http://support.microsoft.com/kb/2013544 and still nothing? 
 
Here are the errors:
 
 
V-79-57344-38732 - Virtual machine 'GuestVM' does not meet the requirements necessary for Backup Exec to restore individual application items. You cannot perform GRT-enabled restores of application data from this backup.
 
V-79-57344-38721 - Failed to mount one or more virtual disk images:
 
 
V-79-57344-38726 - Backup Exec failed to connect to virtual machine 'GuestVM' and was unable to collect the necessary metadata to restore individual application items.  You cannot perform GRT-enabled restores of application data from this backup. 
 
V-79-57344-38721 - Failed to mount one or more virtual disk images:
CJA333's picture

I am starting to test the GRT function now that I have a Hyper-V 2008R2 environment running 03, 08 servers on VM's.  I did see this error before, but now my test backups aren't showing this error, but I am searching for the process to actually get a GRT backup and GRT restore on some individual files. So far it is straight VM folder restore with just the VHD's etc.

Thanks.