Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2010 R3 backing up Exchange Server to Buffalo NAS and backup sets keep getting delete by new one

Created: 04 Oct 2012 | 9 comments

We bought a new Buffalo NAS and I am setting up Backup to Disk Folder option in order to backup Exchange Server with GRT. But every night the backup job keep deleting previous day's backup sets. I want to keep the data at least two months. The Buffalo has 6TB on it, I also set "Overwrite recycle media contain in the target media set before overwriting scratch media set" in the media management. That still doesn't work. 

If I using my local server disk to backup it will hold as long as the disk has space left. 

What else I can do to prevent data keep getting deleted? please help.

Comments 9 CommentsJump to latest comment

AmolB's picture

Check overwrite protection period of the media set which is used by the Exchange backup job.

Since you want to protect data for 2 months set the overwrite protection period as 2 months.

In BE console, click on Tools -> Options -> Media Management -> Make sure overwrite protection 

level is set as "Partial"

panpanbebe's picture

It is on "Partial - protected only allocated media"

prompt before overwriting import media is also checked.

panpanbebe's picture

On the media set I have "Keep data indefinitily do not overwrite"

On the job properties:

I have When job begins: Append to media, overwrite if no appended media is available.

pkh's picture

I think you are just appending to the media and not overwriting it.  Create a restore job and see whether you can see the previous day's backup.

Your current OPP will retain data forever.  This means that your disk will eventually fill up and you would have a out of space problem.  If you want to retain data for 2 months, the longest period you should set your OPP is 2 months.  However you also need to calculate the size of each of your backup and how many backups you would create in 2 months.  Your disk is 6TB.  If your daily backup is 1TB, you would run out of disk space in 6 days, so you have to think about getting another disk, etc.  It is no point just setting the OPP to 2 months, you would just get a out-of-disk space situation.  If you want to use just 1 disk, then you would have to shorten the OPP so that the media get overwriten before your disk gets full.

Also, you should not use append when you are writing to disk media.   There is no advantage to appending to a media.  For tape, you append data to them to maximise the use of the tape capacity.  For disk, you can use as much or as little disk space as you require, provided you have not set the B2D folder property to allocate the maximum size for the .bkf files.  By appending to a disk media, you would extend the overwrite protection period of that media and thus preventing it from being recycled earlier.  For example, your first job creates a .bkf file and the overwrite protection period is 3 days.  On the 4th day, this .bkf can be overwritten and the disk space occupied by it is re-used.  However, if there is a second job the next day which appends to this file, then the .bkf will only be overwriteable on the 5th day.  Thus the space occupied by the data from the first job is locked up for another day before it can be overwritten.

This is why you should always set your jobs to Overwrite if you are writing to disk media.

lmosla's picture

Hello,

Have you installed service pack 2 from live updates? Backup Exec 2010R3 sp2 resoves many media issues.

Also, since it is a best practice to overwrite B2D jobs do you have a tape drive that you can run a duplicate to tape job to retain your data?

panpanbebe's picture

I did set the media to "overwrite" still removed the previous day's backup. Also my Backup Exec 2010 R3 is the latest build. Still no solutions and my backup job keep getting deleted by the new one.

KRedd's picture

Hi Panpanbebe

I would suggest you to follow certain steps and check out whether its working or not

** Update the backup exec with all the latest hotfixes and patches

** Create a media set name {EXCHANGE} with allow infinite append and Overwrite protection as 2 months

** Associate the Exchange job with this media set {EXCHANGE}

** select this setting in the job properties Append to media, overwrite if no appended media is available

** Go to TOOLS>>OPTIONS>>MEDIA MANAGEMENT >> Over scratch media before over writing the recyclable in the target media set

** in TOOLS>>OPTIONS>>MEDIA MANAGEMENT >>Partial - protected only allocated media"