Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2010 R3 SBE. Remote agent will not start after applying SP3

Created: 21 Oct 2013 • Updated: 25 Oct 2013 | 20 comments
This issue has been solved. See solution.

Windows server 2008 with BackupExec 2010 R3. I ran Liveupdate and downloaded and installed SP3. After doing so tried to start BackupExec services but Remote Agent will not start. I get an error 1053 and then a windows popup that says "Agent for Windows systems has stopped working". I have rebooted but still cannot start the service. In the event viewer I see an error 1000 and the following:

"Faulting application beremote.exe, version 13.0.5204.1225, time stamp 0x51e07830, faulting module bedscomn.dll!?DLE_GetNext@@YAJPEAPEAUGENERIC, version 6.0.6002.18541, time stamp 0x4ec3e855, exception code 0xc0000139, fault offset 0x00000000000b6fc8, process id 0x788, application start time 0x01ceced320aaac11."

I downloaded the 2010R# SP3 file from Syamntec site and ran it, rebooted and still cannot start service. From Program Files\Symantec\Bckupexec\agents\raws64 created a mst file and ran the installation of Remtoe agent but still unable to start the service.

This is the only server on the network. The only other Symantec product is Endpoint. Coincidently I ran the same liveupdate on three servers for another client and everything was just fine.

Any help or suggestions would be greatly appreciated.

Thanks.

Joel

Operating Systems:

Comments 20 CommentsJump to latest comment

VJware's picture

Via a cmd, browse to \Program Files\Symantec\Backup Exec directory & run the following command:-

beremote -console

Pls post/pm me the output along with remote agent dump which is saved under \Program Files\Symantec\Backup Exec\BEDBG

Alternatively, you may log a formal support case for us to review further.

Dashman's picture

thanks for the quick reply.

When I run the command from the cmd prompt I get the same windows message that "Agent for Windows systems has stopped working".

AttachmentSize
beserver.exe_6696_0.zip 1.27 MB
Dashman's picture

Sorry but just figured out how to attach. I can see that the dump file is dated 2012. Perhaps that is when it was first created and it just keeps adding to it. But that is what I have.

Thanks in advance for your imput and help.

VJware's picture

This dump is for beserver.exe... Would you clear all the files from the BEDBG folder and retry. (As this folder can contain only limited entries)

Dashman's picture

I removed all files from BEDBG folder and ran the command from the prompt. I got the same windows message and when I looked in the BEDBG folder it was empty. I ran the command several times and that folder remains empty.

What do you suggest that I try now?

VJware's picture

Pls ensure the Backup Exec Error Recording service is in a 'running' state.

Open a cmd & browse to the Backup Exec directory. Run the following command ~

bedbg --pid (pid)

Substitute the pid of beremote.exe over here. For egs:

bedbg --pid 123

Now run beremote.exe -console   (Do use beremote.exe and not beremote this time)

See if an output is generated along with the dump or not.

VJware's picture

Using the Task Manager - View - Select Columns, enable the display of the PID column.

Then under Process tab, you could see what's the associated PID ( Process Identifier) with the beremote process.

Dashman's picture

Sorry to take so long to get back to you but I had to work today and just got home. I found the pid (7808) and ran the command. Actually it was bedbg --p 7808 that worked. I could see that it created the file in the BEDBG folder. Howerver when I ran the beremote.exe -console I immediately go the same Microsoft Windows Windows popup that says "Agent for Windows Systems has stopped working."

Attached is the dmp file created by the first command.

I really so appreciate you helping me resolve this problem as I am getting concerned that my client has not had a backup in several days.

AttachmentSize
bedbg.exe_7808_0.zip 38.24 KB
VJware's picture

I would recommend to log a formal support case as this new dump is for the bedbg process & not for beremote.

Steve_'s picture

Rather than just a reboot have you performed a cycle? (Shut down the server, then shut down the tape library, boot up the tape library, boot up the server)

Also, when you look in services (Task manager on the server) Which services under backup exec are currently running? Try running the majority of these

*Please mark as solution if this has resolved your query*

Dashman's picture

VJware,

Thanks for your suggestions. Sorry that none of them were successful. My client does not have support with Symantec and is a non profit who cannot afford to pay for a support case. I will have to persue this further on my own.

Steve_E,

I have not performed a cycle as I have been trying to resoolve this remotely. However I plan on going to the site tomorrow evening for some other work that needs to be done so I can try it then. I can turn off the server but the backup media is a Dell RD1000 so I am not sure how I would turn off the tape library and follow the sequence you have suggested.

When I look at Task Manager or just services most of the backupexec services are running. There is one that is dependent on Remote Manager and of course it will not start up either. What do you mean by "try runnig the majority of these" as they are already running?

Dashman's picture

Do either of you thing that if I do a backup of the content and data folders and then uninstall and reinstall the application that this will resolve the problem? It will take some time but I need to get this fixed and am willing to do it if there is a chance it will help.

Thanks for a reply

Steve_'s picture

Hi Dashman,

I understand, we are a non-for-profit too, and I've been in the job for 7 months so I've had to figure out how to resolve most of these issues by playing around with the software.

So your tape library is a single tape device? I've had a look and not sure how to turn them off. but If you find out how I got the steps wrong, turn off the media server, then the RD1000, then turn the media server back on, then the RD1000 back on. This step has the most chance of fixing the issue.

You can also try going into programs and features and select change on the symantec backup exec program and select repair.

Lastly, try running liveupdate again and see if there are any post-updates for sp3 since you installed.

I would not recommend an uninstall unless all of these steps have been tried. You could run into more problems otherwise.

*Please mark as solution if this has resolved your query*

Dashman's picture

I am going there tomorrow to do some other IT stuff and will try your suggestions. The only thing about RD1000 is that it is an internal device so there is no way to turn it on or off. I could open the box and  disconnect the device and see if that will make a difference but other than that I can see no way to turn it on or off.

While I see Liveupdate listed in control panel, programs and features I do not find an option for it in programs from the start menu. I looked in windows explorer and could only find the file "lsetup.exe" and when I ran that it says the latest version is already installed (obviously the installation setup not the run command). I would always run Live Update from within backup exec but obviously cannot do that. When I run End Point and run Live Update it says looking for Symantec products but does not list Backup Exec. Can you tell me how to run Live Update specifically for Backup Exec in this situation? I did say that I had manually downloaded  SP3 and ran it again.

When I go to do a repair on Backup Exec it quickly asks for the install media which is not in the DVD. I will have to try this tomorrow also when I am there.

I will let you know what I find after trying these.

Thanks for hanging in there.

Dashman's picture

I was able to do a repair on Backup Exec but that did not resolve it. I was not able to figure out how to run liveupdate to see if that helped although I doubt it would after I did download the SP3 and rerun it.

Any other suggestions out there?

Steve_'s picture

If you got program files (most likely x86) and select symantec>Live Update> and run LUALL then it will scan for updates.

Sorry, all out of ideas. Similar issue but I guess with a tape library that's only singular and can't be turned off it makes it a little more difficult as you can't exactly power cycle (Only way to unplug)

Last resort, uninstall, if there is a way to backup your configurations I suggest you go for it....If not, then you could just try starting from scratch with setting it up, noting down your configuration.

Hope you can find the solution!

*Please mark as solution if this has resolved your query*

Dashman's picture

When I run the LUALL attached is an image of what it finds. It does not recognize that backup exec is installed or is an app that needs updating. I think the next step is an uninstall and reinstall. I know that I have to make a backup of the data and catalog folders and once I reinstall just over write those folders and it will have all the settings. I just hope that doing that resolves the issue. Interestingly in addition to the three servers I updated before this one I have updated 3 others and they all worked perfectly afterwards.

Live Update Image.jpg
Dashman's picture

Just stopped all services,copied the catalogs and data folder then did a complete uninstall, rebooted and maually removed the remaining folders in windows explorer. Reinstalled the app, stopped all services, copied back the catalogs and data folder and now app running with all settings and jobs and history. Running current backups and once have those (has been several days so need them) I will run live update and hope the same thing does not happen.

Thanks to those that tried to help. I was hoping there was a fix but time wise I could have done this and been much better but one does not always learn anything from taking that route.

SOLUTION