Video Screencast Help

Backup Exec 2010 (Trial) - Microsoft SQL Server instance is not visible/available in selection list

Created: 14 May 2010 | 12 comments

I have a MS SQL Server 2008 instance running on a remote server with remote agent installed. The server is perfectly accessible from the network as I have other network services using it and working. My problem started with this message after performing a full backup of the server:

V-79-40960-37914 - Database DATABASENAME is configured to maintain transaction logs. Transaction log backups are not being performed. This will result in the log growing to fill all available disk space. Regular log backups should be scheduled or the database should be changed to the simple recovery mode.

Resolution:
Configure a log backup of the database(s) in question

Fine by me, I can create a log backup job in Backup Exec. Problem is, however the SQL Server instance is not visible in the backup selection list. The server is protected by a full server backup so my only interest for this job is to select the SQL Server instance and perform a "Backup log" job.

BE connects to the Remote Agent as local administrator and has no problem backing up other files on the server.

The SQL Server instance on the backup server is selectable and OK.

And this is the problem: On the remote server the SQL Instance isn't found, so I cannot create a pure "Backup log" job.

Comments 12 CommentsJump to latest comment

pkh's picture

In your screenshot of your remote server, there is a Microsoft SQL Server between ftproot and System Volume Information.  Click on that and you should be able to see your databases and you should be able to create your log backup job.  This SQL instance is not named, so there is no suffix.

sazz.'s picture

Do you have the sql license installed on the Backup Exec server please check by going to tools - license and option.
If you have it installed and still not able to view it then uninstall and install the license again and restart the remote agent on the sql server

RahulG's picture

Make sure you have the correct version of remote agent installed on the server
Refer the following document http://support.veritas.com/docs/345321

oskaremil's picture

pkh: The instance is named, it has the default instance name MSSQLSERVER from what I can see. If this turns out to be incorrect, how can I set an instance name so it it listed as a single node ?

sazz: I am currently running 2010 Trial license. From my understanding the SQL Agent option is included in the license.

RahulG: I have a clean installation from the installation media, and used the same installation media to install the Remote Agent. Also, if the version is incorrect I would get an error/exception message on this when performing a full backup so I am pretty sure I have the correct Remote Agent version.

The backup server is behind a firewall. Currently I have opened:
10000 (remote agent)
3527, 6106 (be server)
6101 (backup agent agent browser, not sure if this is needed on the server, though)
10001 - 100010 (configured for remote agent TCP dynamic port range in Tools > Options > Network and Security)

Might there be additional ports that need to be opened ?

pkh's picture

When I said named, I meant having a name other than the default.  I am not sure, but I think you can only name a SQL instance during the time of its install.  I may be wrong here.

Colin Weaver's picture

I am a tad puzzled about that showing up under A: (which historically would be a floppy disk) which some software would ignore or have problems with.

Is this a cluster of some kind?

sazz.'s picture

If you are using it in Trial then sql is available if you have it checked. If you have it checked then please try to repair the BE and then restart the remote agent on SQL.
Make sure you are using the correct credentials from the Backup Exec to connect to SQL.
Also make sure the sql browser service is running on BE server

oskaremil's picture

Colin Weaver: A: is another harddrive, so A:\Microsoft SQL Server is the path to the MS SQL data and log files. I don't think this should cause any problems. I have other servers with harddisks on A: and B: and Backup Exec has no problem recognizing those as harddrives.

sazz: I have uninstalled and reinstalled the MS SQL Agent on the media server. SQL Browser Service is running on BE server. I noticed that SQL Browser service wasn't running on the SQL Server computer (the service was set to manual start), but I started the service, restarted the remote agent service and restarted all BE services on the BE server. Still no change in results.

I am pretty sure I am using the correct credentials. Since the computer is outside the domain network BE connects as COMPUTERNAME\Administrator. The local Administrator account has the public and sysadmin role granted on the SQL server.

As a notice: I have another server, this server is on the same domain, the server had BE installed previously and thus has a SQL Express instance running. BE sees this as a node just like the one I presented in the screenshot so I believe that the problem is not installed features or configuration on the BE server but one of the following:
1) The SQL Server is not on the same domain and network as the BE server. It resides in a separate Workgroup on a different subnet.
1.1) However, I can perform a full backup of the server so the initial network settings should be properly configured.
2) There are firewall issues between the BE server and the SQL Server.
2.1) SQL server Firewall should not be an issue. It is configured to allow all connections from the domain network (including BE server). This works well with other applications.
2.2) As stated above, and from what I could read of the documentation, the following ports are opened on the domain firewall and forwarded to the BE server:
10000 (remote agent)
3527, 6106 (be server)
6101 (backup agent agent browser, not sure if this is needed on the server, though)
10001 - 100010 (configured for remote agent TCP dynamic port range in Tools > Options > Network and Security)
2.2.1) Does SQL Server browsing require extra ports on the BE server side ?
3) Some bug exists or workaround is required to perform SQL Server 2008 backups from remote servers with the above situation.

Dev T's picture

Hello,

http://support.veritas.com/docs/345465

This is related to SharePoint, but I think this might help you....

Its a best practice to have a "Support Contract" with Symantec...
 

sazz.'s picture

ok so you try to connect with the computername/administrator as it is not in the domain, that is correct,
Can you please do the udl connectivity that will isolate if it is the connection issue from the BE to sql server. The server is able to connect to the other server but not able to connect to the sql instance on the other server.

http://support.veritas.com/docs/256661

oskaremil's picture

The MS SQL Server is set up as the Default Instance, so this has no instance name, I connect to the SQL server using only the computer name. Might that be why Backup Exec is failing ?

I did the udl connectivity test. it returned success using public address (ftp.XXX.xx) as servername.

Using ftp.XXX.xx\MSSQLSERVER does not work as it is the default instance. I even thought maybe Backup Exec is trying to connect to the COMPUTERNAME as that is the one reported from the Remote Agent (haven't found out how to get the remote agent to report a custom address) so I made a DNS Alias for COMPUTERNAME -> ftp.XXX.xx. Still does not work.

oskaremil's picture

God know what I did right.... maybe it was adding a COMPUTERNAME alias in DNS ?

After adding the COMPUTERNAME in DNS i removed the server from my "Favorite Resources" list and readded it. Voila, the SQL Server instance is visible :)