Video Screencast Help

Backup Exec 2012 active job

Created: 25 Sep 2012 • Updated: 16 Oct 2012 | 9 comments
sgosden's picture
This issue has been solved. See solution.

Hi,

I have upgraded two dseperate sites to BE 2012 SP1a and i am getting the same problem on both sites.

Both sites are CASO environments with SP1a, one with fast LAN links and one with slow WAN links.

Every few days or so, one of the managed backup servers will show a job as active with a status of queued with 0 bytes backed up. The job will just stay queued and nothing will run. If i cancel the job it will either, cancel but leave the storage showing as active (even though there are no jobs shown as running by GUI or powershell) or the job just never cancels.

Only fix is a restart of the managed server and even this doesn't work sometimes and requires several reboots as the storage will show as active.

Keep getting this and it happens to different servers with different storage. Generally when it happens the managed backup server cannot use any of its storage, e.g. if a disk backup is stuck in the queued state, and a  tape backup tries to run it will also say queued.

when the jobs do run everything is ok for a few days and then one of the servers will do the same.

Anyone else getting this or have any idea how to clear the errors without multiple boots. 2012 is proving to be very unreliable

Comments 9 CommentsJump to latest comment

CraigV's picture

Hi,

Have you centralised your data and catalogs information on the CASO? If so, try localising it on the MMS again and see if this sorts out the issue.

Furthermore, a CASO environment allows you to set a type of QoS in terms of how often the data/catalogs are replicated to the CASO server from the MMS. Open the MMS on the CASO section and set this to low (I think this is the setting)...in this case data won't be replicated as often as a higher setting, and change the link to a slow link.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

sgosden's picture

I have centralised the catalogs on one site but not on the site with the low bandwidth (These are completely seperate installations and have no connections between them)

For the low bandwidth site the CASO setting is set to slow connection and the CASO is just used to centrally view the servers and job history etc.

I am looking at the low bandwith site at the moment and one of the MMS has 3 storage devices (disk, NAS and tape) and set to slow connection. from the MMS it shows a job on the disk storage as active and i can view the job which just says status queued, current operation none. The NAS storage says active but there are no running jobs showed either in GUI, CLI (get-BEActivejobdetail)  or on CASO. The tape storage has an inventory job which shows a status of 'to be scheduled' even though the start time has passed.

I rebooted this server this morning because a job was stuck and would not cancel. this job failed because of the reboot and the next one in the queue took its place and the same thing has happened. 

I have removed one of the servers from the CASO environment and will wait to see if the same thing happens but sometimes it can work fine for several days before it fails.

The CASO setup should work and i can see all the communication between the servers as the CASO reflects what is happening. 

Is there anyway to tell what backup exec is waiting for, rather than just showing queued?

thanks

CraigV's picture

You'd have to open that job to see. However, remove the server with the problem from the CASO for now and give it a couple of days to see if this problem replicates itself. If it does, then it isn't a CASO/MMS issue, and rather lies with BE on the local site itself.

I take it that all your servers are on the same patch level?

THanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

SOLUTION
sgosden's picture

I can open the job and see the status but it just says queued and operation none.

I have seen this same issue on 3 different MMS servers in this site. All have BE 2012 SP1, 1 is 32 bit 2003 R2 and the other two are 64 bit 2008 R2.

as mentioned seen the same error on another site with CASO/MMS but that is a fast LAN setup. Will wait to see if it reoccurs on the server i have removed from the CASO. 

so many bugs in the 2012 it is proving to be a nightmare

sgosden's picture

also, forgot to mention if i pause or disable the storage (either from CASO or MMS) it relflects the new status but still says active. e.g. disabled;active 

sgosden's picture

is there an easy way to remove the managed server option? last time i did it i just uninstalled everything as only a few jobs had been created. This time there are lots of jobs and configurations so don't want to uninstall.

If i go to the install option the managed backup exec option is greyed out.

Thanks

CraigV's picture

You can use BEutility.exe to do so. Just choose the option to remove from the CASO.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

sgosden's picture

great will give that a go. 

Thanks for your help, hopefully it will help fix the stuck jobs

cheers

sgosden's picture

Removing the server from the CASO environment fixed it. Seems to be a definate issue with the CASO environment. It's a shame as having the central site reporting on the state of the backups from multiple servers is very usefaul.

I still get the issue on the sites with are LAN connected but it is easier to deal with there. 

I think i will end up just removing the caso opyions from the sites at the moment and set up one site as a MMS then  log a call with Symantec as it happens on every MMS in both my CASO environments (which is about 20 MMS in total)

will update if i get a fix