Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2012 AVVI possible Glitch?

Created: 23 Jul 2013 • Updated: 24 Jul 2013 | 3 comments
Marco Tafur's picture
This issue has been solved. See solution.

Hi all,

I just wanted to share this event that happened to me today.

I installed BE 2012, connected to vCenter and everything's fine. Everything backups fine (even with GRT) and the whole install was done using best practices from the Technotes.

I created two jobs for the tests:

  • Backup without GRT activated (for Linux VMs and some Windows VMs where GRT is not required). This runs fine.
  • Backup with GRT (both files and applications). This one we had an issue.

The issue we had was with this particular VM (PELIMWEB02). It has installed the following:

  • Windows Server 2008 R2
  • IIS 7

(This VM had an initial issue which didn't allow to push-install RAWS. After many hours of troubleshooting, I finally managed to do a push install and start a backup job to test integration.) 

The first time I ran the "Backup with GRT" job, it showed warnings (Backup exec is not able to communicate with the VM and all that. In short, it said I wouldn't be able to do GRT restores). However, when I checked the catalogs (say, tried a restore), I could see AND restore files from that particular VM.

So, I suspected it had something to do with IIS (because it is the only "application" running there). I created another job with the same config as the one above...but this time just with PELIMWEB02. The glich was that on the job list it says "Correct"...but in the history says "Correct with exceptions".  Again, I checked the catalogs and was able to do a GRT based restore.

Finally, I changed the job settings to just do a File System GRT backup. This time, both were "Correct". No exceptions.

So, I ended creating a third job, "Backup with Filesystem GRT but no APP GRT".  Customer was satisfied in the end.

So, the following questions arise:

  • Does IIS has an effect on AVVI application Backup? I understand that VMs which do not support GRT (e.g. Linux based) needs to have separated jobs, else it will fail, but why do I have to have two different GRT based jobs?
  • Why does the job says "correct" while the job history (for the same job) says "Correct with exceptions". Kinda misleading.

I hope you understood me, english is not my mother tongue.

Regards,

Marco

Operating Systems:

Comments 3 CommentsJump to latest comment

Colin Weaver's picture

Just by having Application GRT enabled  we will attempt to talk to the remote agent near the start of the job and you can therefore then get an error either if we cannot talk to that remote agent, or possibly if we can talk to the remote agent, but there are no database technologies on the system to backup. If we cannot talk to the remote agent then either there is no access to Port 10,000 (firewall etc) or the trust relationship has not been correctly configured.

If you do not need App GRT then for the backup itself (even for file system GRT) we do not need to talk to the remote agent. Hence even though you had an error you could still recover individual files.

As an aside if this 2008 R2 system contains one of the following then it might be corectly try to use App GRT and then failing with some other problem

a) A domain controller

b) running any kind of SQL instance (even SQL express)

c) running any component of Sharepoint (is the IIS server involved withj a Sharepoint farm?)

d) running Exchange

SOLUTION
Kunal.Mudliyar's picture

1> I am guessing its not due to IIS, may be because you have enabled Application GRT and there were no applications like SQL Exchange and AD

2> Linux needs seperation as the Backup application will try to use its GRT api on Linux and it will not be able to complete a GRT as its not windows since only windows is supported for GRT

3> It may be due the point no 1...as it cannot find applications howerver all the required information is backed up and good for the restore so it reports the job as successful

Technical Support

Symantec

Marco Tafur's picture

Thanks for the replies. I thought the same as Colin. As there's no BD, AD, SP, or EXCH it will fail.

Well, this one is going directly to my knowledgebase.

Thanks!