Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2012 can't backup Exchange 2007 to Disk

Created: 17 Nov 2013 | 7 comments

I have set up Backup Exec 2012 to backup our Exchange 2007 environent

It is set to Backup to Disk weekly, then duplicate to tape.

The backup to disk starts, but then never seems to stop.

I have set it to stop if the job is still running after a certain amount of time (Can't get in to check the number of hours as it is still going)

I stumbled across it by accident today when I went in to set u pa backup for a new server.

It has been running for 9 days, and has only done 78GB (Out of 200GB)

As it seemd to have stopped working, I selected the option to Cancel job.

It is now sitting there with "Cancel Pending" status, and has been for over an hour now.

 

This had happened previously, and I followed a Symantec article which screwed it up even more. It told me to Restart services then kill some processes.

It froze when trying to stop some processes, then would not start them again afterwards.

I then had to restart both the Exchange server and backup server as the Writer had crashed on the Exchange server.

I have installed the Service Pack 2 for Backup Exec, but now Backup Exec has done the same thing.

I don't want to have to restart the servers again unless I have to.

 

In this case, restarting is not a solution, as I have already tried it and the problem has recurred, so please do not suggest that as a solution.

 

Where can I find more information about what has happened, and how to stop it happening in the future?

We need our Exchange system backed up, and currently this is not being done.

 

The job is set to backup from the Active copy. It was initially set to do the Passive, but that didn't work either. (That caused other issues, and I was told to do the active copy instead)

 

Operating Systems:

Comments 7 CommentsJump to latest comment

Jaydeep S's picture

"9 days, and has only done 78GB" This certainly is some issue. Have you tried to change the backup target? Try to backup directly to a tape device and see if it works well.

Also, try to backup some other data from the Exchange Server and some other server like flat files to the B2D folder and see if that works.

Run the B2D test tool and see if it gives out any errors.

http://www.symantec.com/docs/TECH69107

CraigV's picture

...you don't mention the OS BE is installed on, but stop all the BE services, and try a backup of Exchange to disk using the built-in Windows backup utility and see if you're getting the same speeds.

Also, if there is an AV installed, either stop the AV during the backup as a test, or put in exclusions for the BE services on the media server, and the B2D folder itself to see if this works.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

RCPAQAP's picture

Sorry, usually I add that in. OS is Server 2008 R2 Enterprise

I've left it running overnight, but the backup status is still set to "Cancel Pending"

It's been in that status for about 17 hours now.

 

Last time it went like this, I tried restarting services, but they went into the Stopping status, then nothing.

I have to kill the processes.

When I did that, they then refused to restart again, so I had to restart the server.

I really do not wish to do that, as the server is located interstate, and if it does not come back online, it is very difficult for us to get it back again.

 

How do I resolve this "Cancel Pending" status?

Once I can do that, I will try the suggestions above.

If I have to restart I will, but this server is also a Hyper-V host, with 4 VMs running on it, so it can be a pain to arrange down-time for all those servers.

 

Thanks again! :)

Jaydeep S's picture

Try to stop Remote Agent service on both Media Server and Remote host. If they don;t stop end process beremote.exe This should cancel the job.

RCPAQAP's picture

I have stopped the services and restarted them (Had to kill beremote process as the services didn't want to stop on the media server)

I believe this is what screwed the servers last time, but they seemed to have restarted ok this time.

 

Running the D2DTest.exe gives this result:

Final Analysis:
---------------
Path Validation - PASSED
Create Directory - PASSED
Disk Space - PASSED
Volume Information - PASSED
Query DOS Devices - PASSED
Traverse Volume Info - PASSED
Memory Mapped Files - PASSED
Reparse Points - PASSED
Sparse Files - PASSED
B2D Pre-allocation - PASSED
Random IO - PASSED
Default B2D Configuration - PASSED
Read buffer B2D Configuration - PASSED
No write buffering B2D Configuration - PASSED
File Handles - PASSED
Cleanup Directory - PASSED

 

 

I have rerun the backup again, and it has completed successfuly (3 hours for 215GB)

Is there a way I can find out what went wrong? I don't really want this to happen every time.

Backup to disk definitely works, as I have 3-4 other backups that go to disk.

It is just something with the Exchange backup that is having problems.

Jaydeep S's picture

Noit sure what could have went wrong. However, if you feel this happens too frequently it is better to contact tech support and have the logs analyzed.

Vishal Shinde's picture

to find what could hav been wrong, you can have a look at the event viewer, on the exchange server.

probably you can identify the events from event source
1. ESE
2. ESE Backup
3. ExchangeIS
4. VSS

and any thing that potentially be a show stopper.

Regards,
S

Vishal Shinde

Sr.Learning Consultant

Symantec Education Services