Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2012 compression issues

Created: 02 Aug 2012 • Updated: 20 Feb 2014 | 6 comments
This issue has been solved. See solution.

Hi all, I have a issue with compression. I have a IBM x3650 m3 server with an adaptec ultra 320scsi running an IBM LTO4 tape drive

I set the backup job to run and it gets to the native storage capacity (800GB for LTO4) and ejects the tape asking for the next one

It appears to make no effort to compress the data

SP1 is installed as well as both hotfixes 

I used the tracer.exe program and on the mode_select 6 I had both 0F and C0 but on the mode_sense6 I had 48 and 00 (on all mode_sense6 had the same numbers)

Hardware compression is enabled in the storage tab drive properties

Job was submitted with the 'hardware compression otherwise none' selected

Believing it to possibly be the drive itself having issues I replaced it with a spare LTO3 drive and the same issue happened it ejected the tape when it got to 410GB

No issue on backup exec 2010r3 on the other 3 servers and backup exec 12.5 on the others

Any ideas?

 

firmware on drives is up to date

Comments 6 CommentsJump to latest comment

CraigV's picture

Hi Joe,

 

Change to Hardware Compression, Otherwise Software and see if you get any improvement?

I also assume that the Symantec drivers are in use for your device?

Thanks!

EDIT: You can also check the tuning guide below for further information:

http://www.symantec.com/business/support/index?page=content&id=DOC5481

I take it that your SP is SP1a with hotfixes installed? I see that 1 of the HFs fixed the compression issue. Another post dated that at 3rd July...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

pkh's picture

Make sure that you have the HF described in this discussion

https://www-secure.symantec.com/connect/forums/end...

Also, as a precaution, change the compression setting to "Hardware, otherwise none".  Don't user "Hardware, otherwise software"

Joe Howarth's picture

I've installed both hotfixes (the hardware if not software problem and the 1:1 problem) it is sp1a craig

I'm running a test backup with it set to Hardware if not then Software to see if that will work.

Though i'm monitoring system use and the CPU is ticking at around 10% max on only one core the others are relatively idle, surely if software compression was working this would be larger?

 

Joe Howarth's picture

'hardware if not software', attempt failed and ejected LTO3 tape at 413GB

 

now running a job with compression 'software' setting to see if I can get around 800GB onto an LTO3 tape

pkh's picture

'hardware if not software', attempt failed and ejected LTO3 tape at 413GB

It is probably not a failure, but the tape is full.  Did you check whether there is any alerts asking you to insert an overwritable tape?

Check your joblog.  If it says hardware compression and you managed to get 413GB onto a LTO3 tape, it means that your hardware compression is working.

To confirm that your hardware compression is working, change your setting to "hardware, otherwise none".  If you managed to get more than the native capacity onto the tape, then the hardware compresssion on your tape drive is working.

now running a job with compression 'software' setting to see if I can get around 800GB onto an LTO3 tape

This would mean that you have achieved a 2:1 compression ratio.  This is hardly achievable in real life.  The hardware and software compression ratios are about the same.  All compression ratios depend on the type of data that is being compressed.

Joe Howarth's picture

sorry pkh i realised that 'failed' is the wrong word, the job was still running just asking for another tape

This server i'm backing up has an exact copy of the files on another server (where transfering all of its function over to this new one and it manages to back itself up onto a LTO4 tape compressed there's about 1.4TB of data. I was expecting to fit a similar amount onto one LTO4 tape connected to the new server but with with hardware if not software and harware if not none I could only fit 795GB onto the tape.

I asked a symantec engineer whilst he was fixing one of our other problems about it and he said that there still having problems with hardware compression and the hotfix doesn't work on all systems.

Good news though pure software compression has worked and i can fit an entire backup on an LTO4 tape but this is only a temporary fix (due to time constraints hardware compression would be faster)

 

Looks like symantec may have to put some work into this problem (at least we could test the software on a server without any roles as apposed to the others which handle security, quaratine etc...)

 

Thanks for the advice so far!

 

 

SOLUTION