Video Screencast Help

Backup Exec 2012 encrypting tapes with a Quantum LTO5 Drive

Created: 04 Aug 2012 | 6 comments

Howdy, I have a fresh install of Backup Exec 2012 with all the patches installed. When I create a Disk to Tape job, it will not allow me to get the encryption. When I select either hardware or software encryption I do not get the fly out to select which encryption key to use. But I do get the fly out when I do a Disk to Disk backup. There is no compression selected. When I look at the tape drive in Backup Exec it says the tape drive supports hardware encryption. I just want to be able to encrypt the Tapes using software or hardware. Also I have done restores using the tapes & drive that where encrypted in the previous version. Is there a check box somewhere I’m missing to allow me to use the tape drive in encrypted mode in this new version  Thanks

Comments 6 CommentsJump to latest comment

pkh's picture

Go to the BE installation directory and use BEUtility to repair the BEDB.  If this does not solve the problem, try re-creating your encryption keys.  Delete all of them and then create them again.

biltona's picture

No luck, with the BEUtility and deleting the Encryption Keys. I still can can not select encryption


Larry Fine's picture

Are you saying that you do NOT get the "encryption key" dropdown (ie the part in red boxes)?

It works here.

Can you post a screen shot of your drive properties and your job options?


If you find this is a solution for the thread, please mark it as such.

biltona's picture

That is correct I do not get the "encryption key" dropdown


backup.docx 459.05 KB
Larry Fine's picture

What is below the "encryption type"?  Your screenshot is clipped there, so you need to scroll.

If you find this is a solution for the thread, please mark it as such.

TTT's picture

I had a similar problem- fresh install of BE 2012 SP1a.  I think it's a UI bug, because I found a workaround.

After the installation, I wanted to test a direct-tape backup before adding a disk stage.  As part of initial config, I set up the tape library, used the "BE start button" to enable FIPS compliance (and rebooted the server), then used the "BE start button" again to add my 256-bit encryption keys.  Finally I added my vCenter server.  I then rt-clicked my vCenter server and I created a Backup-to-Disk (single-stage) job- three VMs, straight to tape, and I chose Software Encryption- and my dropdown for "Encryption Key" looked exactly like the one in the picture that Larry Fine put up.

The bug:  When I clicked the down arrow next to "Encryption Key: None", it did not show me a dropdown with my encryption keys.  Nothing appeared when I clicked the down arrow.  When I clicked "Manage Keys", I saw my keys.  I clicked OK, was returned to the same screenshot- but the dropdown didn't work, and of course it wouldn't let me save the stage's definition.

Here's the workaround for that bug:  I just wanted the job to run, so I changed Encryption back to None.  I saved the stage and created the job.  Then I went back to the job, Edited it, I changed Encryption from "none" to Software- and now the dropdown for "Encryption Key" worked!  It actually dropped down, and I was able to see my keys in the list and select the one I wanted.

For kicks, I created another single-stage backup-to-tape in the same manner- but this time, the dropdown for encryption keys worked.  Then I rebooted, created another single-stage backup-to-tape in the same manner- and the dropdown for encryption keys worked again.  Finally, I rebooted, added another encryption key using the "BE Start Button", created another single-stage b2t in the same manner- and the dropdown for encryption keys worked again.

My suspicion is that if an Admin pre-creates the backup keys before creating any backup job, the keys won't appear on the first tape job created.  So if the job won't show you your encryption keys and the dropdown won't work, try saving it without encryption, then go back and edit that job to see if it lets you use the dropdown for encryption keys.

Again this is a fresh install of SP1A, no updates yet, on server 2008 R2 x64.  Hope that helps!