Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2012 & Fedora

Created: 03 Oct 2012 | 3 comments

Hi there,

Have currently issue installing the RADIUS on fedora (15, 16 17) Linux Server.

I know it's NOT supported but I have many Prod server running on this platform and need to backup them..

The installation logs shows that the SymSnap driver installation failed

VxIF::Info:: Installing SymSnap Driver result: Verifying archive integrity... All good.
Uncompressing Symantec symbdsnap, build 2.0.1-41783..........................................................................................................
.......................................
This platform is not supported.  Exiting install.
VxIF::Error:: ERROR: Installing SymSnap Driver Failed.

Did someone find some workaround ?

Many thanks in advance for your answers

Comments 3 CommentsJump to latest comment

Lilavati's picture

Backup Exec does not support Fedora Operating system.

There is a new feature in Backup Exec 2012; “Advanced Open File option for Linux”, this feature requires  driver installation. This feature is not supported on all operating system of Linux but still you can backup the Linux system with legacy method, only open or locked files will not get backed up as it was not there in earlier versions of backup exec too.

Your logs say that this is not supported operating system but this message is for driver (Advanced Open File option feature), your RALUS installation may be successful.

Legacy backup method is still supported you can still backup the Linux machine with legacy method ( as you were doing it earlier)

Note :

You can see the RALUS installtion in /opt/ though the driver installtion is failed ( It is only exiting the driver installtion not the whole RALUS), you can start the beremote and verify the backup.

Thanks,

Lilavati

If this response answers your query, do mark it as a solution

FabA's picture

Thanks for your answer.

I was not sure the driver installation is mandatory or not for the agent to work.

In my case, the RALUS installation succeed and the Agent started. But after some seconds the beremote service simply stopped...

The /var/log/messages shows:

Oct  3 20:58:55 GVA12FED15Test kernel: [ 4733.901388] beremote[13505]: segfault at 100000008 ip 00007f4b3569256e sp 00007f4b319e4c50 error 4 in libbesocket.so[7f4b35670000+44000]
 

What you mean with legacy method ? I try to newly implement Backup Exec, over vendor before.

THX

jayaramk19831's picture

Fab A, 

Just wanted to clear a few doubts. 

1) Does beremote on the Linux machines crash only on Fedora 16 and 17 distributions? Please confirm the same. 

2) The beremote process abrupt crash is due to a bug in the kernel 3.x version. Please see https://bugzilla.kernel.org/show_bug.cgi?id=33992 to know more about this bug

3) As we do not support Fedora versions can you see if the kernel patch provided for the crash (mentioned in 2) solves the issue or not?

4) Also driver installation will not work on Fedora systems and that is not the actual cause of the problem.