Video Screencast Help

Backup Exec 2012 - Media remove autoresponse not possible

Created: 22 Mar 2012 | 15 comments
Tom Nielsen's picture

I´m trying to configure the 2012 version to backup multiple servers. What a nightmare.. (but thats a different story)

I guess the only way to backup multiple servers with various selections is to define one job pr. server. I must say - I think its a bad approach on how to backup multiple servers. And the overview is gone in the new version. (thinking about downgrading to 2010).

But my main question regards the possibilty to configure autoresponse for media remove. According to the manual this is not possible. Autoresponse can only be configured on Media insert and Media overwrite alerts.

But the last two days the jobs just says "running" and an active alert wants me to acknowledge "Please remove media".

As soon as I acknowledge the job ends. But there is no way to configure autoresponse.

What did they think ? - that I want to spend my time checking every morning to acknowledge ?

Come on Symantec - Let us be our own judges on the autoresponse on alerts...

Any one have a solution for this ?

Tom

 

 

 

 

 

Comments 15 CommentsJump to latest comment

Kiran Bandi's picture

I guess the only way to backup multiple servers with various selections is to define one job pr. server. I must say - I think its a bad approach on how to backup multiple servers. And the overview is gone in the new version. (thinking about downgrading to 2010).

You can use groups to backup multiple servers. 

Refer to 

http://www.symantec.com/docs/HOWTO73364

http://www.symantec.com/docs/HOWTO74306

Colin Weaver's picture

I haven't looked into this yet but I believe a Group is just an administrative container and that separate job definitions per server will still be created within the group. 

Tom Nielsen's picture

Kiran is partially right. You can create a backupjob by using groups, but only so far as the selections is identical (complete servers).

I found that described ind the administrators manual.

Tom

Colin Weaver's picture

OK I have now looked into this

 

If you create a Group and then create the job from the group during the creation of the job definition the selections are identical. When you click OK to save the definition it actually states the Jobs (plural) are being created. If you then Click the Arrow Button called Group <Group Name> (on right side below ribbon bar) to look within the Group itself and then look at the Jobs list you have 2 separate job definitions  that are scheduled to start at the same time.

And then if you edit each job definition you can then customize what is selected for backup.

As such you still don't end up with a job containing multiple servers.

Tom Nielsen's picture

Hi Colin

Thanks for the input. I have also come that far.

But my problem is about the schedule and how the media is handled.

Lets say I backup up two servers to tape which I configured as a group.

How does the two jobs (which are set to the same runtime) handle owerwrite/append/eject ?

Lets say the first server is backed up and the setting is overwrite - what about the next server ? - Will this overwrite again (and erase the backup of the first server) - should I edit the settings so that the first server backup is set to overwrite and the next to append ? - and what about the start times - do I have to make them indivudually as well to make sure I get the servers backed up in the right order ?

If I have to make all these indivual settings afterwards - what the point in using groups ?

pkh's picture

You CAN configure an auto-response for the media remove alert in BE 2012. Click on the BE button and then select alert categories. See screenshot below

Then select the media remove alert.  The auto-response is not greyed out.

Tom Nielsen's picture

Hello PKH

Actually if You look closer, the autoresponse I´m talking about is just beneath the filed you have marked in the red circle. I´ts called "Respond with" and is grayed out. Also in Your screendump.

 

If You navigate so the same place on the alert for Media Insert/Media overwrite - You can se what I mean.

 

Tom

pkh's picture

It has been sometime since I used a stand-alone tape drive.  When you respond with a clear, wouldn't it clear the alert and stop the job?  The portion that is greyed out is for configuring a cancel which probably is not valid in this case.  All the alert needs is an acknowledgement.  It does not matter whether the O.K. or the Cancel button is clicked.

For BE 2010, the "response with" is also greyed out.

Tom Nielsen's picture

I´m sure the "clear after x time" only clears the popup on the screen. But the alert is still active in the background.

I already tried this the first time the job waited for the respons. But the next day it was the same. I still had to open the active alert and click ok before the job ended.

But I found another solution - which is not so optimal as just setting the checkmark in the job.

But you can shedule a seperate eject job - which unfortunattely has some drawbacks.

For instance if I have multiple jobs configured (as described in other posts in this string, with multiple servers in separat jobs because of overwrite/append problem) - how can I be sure not to eject the tape between jobs ? (datasize will increase over time - and therefore also the backuptime.)

Can I be sure that the jobs will run in scheduled order no matter what ? (No - not If I get the automatic cancel af x time) configured in the wrong way and the second job somehow gets cancel before it has run.)

I still think these options is a step back compared to earlier versions. It might be a matter of habits that I need to change myself. I hope someone can convince me that the last applies...

 

 

romeo161's picture

 Hi, I had exactly the same problem and came across the below link from Symantec:

http://www.symantec.com/business/support/index?page=content&id=TECH160277

 

Problem

Respond with" field is greyed out when trying to set up automatic response for Media Insert/Remove or Library Insert alerts

Solution

To configure the automated Respond with for these alerts, follow the steps given below:

1. Browse to X:\Program files\Symantec\Backup Exec (X: being the driver letter where Backup Exec is installed)

2. Run BEUtility.exe

3. Add the media server from File | New | New Media Server

4. In BEUtility, select the All Media Servers, select the Media Server Name

5. From the left pane under Service Tasks click Edit configuration (or right click on media server name and select Edit Configuration)

6. Under Automated alert responses configure the respond with for the required alerts.

pkh's picture

As you can see when you run BEUtility, the auto-response for the media remove alert is by default set to respond O.K. which is the expected response.  This is same for both BE 2010 and BE 2012.

romeo161's picture

After changing the setting in my previous post, the greyed out portion now says "Yes" instead of "Cancel". So I can confirm that using pkh's instructions and the one in my previous post fixed my problem.

OP's picture

I'm having the identical problem and tried the mentioned solutions.

But:

The field "respond with" stays with "cancel" - even after editing the settings with beutility (according to TECh160277).

Restart of the services doesn't help.

Any idea`s?

Is there a trick to get the modified settings made in beutility accepted by backupexec itself ?

Olaf

OP's picture

Finally it worked after a reboot of the server ?!

Olaf