Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Backup Exec 2012 Service Pack 1 Released

Created: 31 May 2012 • Updated: 12 Jun 2012 | 66 comments

Symantec has announced the global availability of Backup Exec 2012 SP1.  This service pack update to the Backup Exec 2012 product delivers enhancement requests that were received from our community in regards to the significant user interface changes introduced with the Backup Exec 2012 release. Here is a TECHNOTE that contains a list of known issues and enhancements resolved with Backup Exec 2012 revision 1798 Service Pack 1.

Please read the Backup Exec 2012 Service Pack 1 Announcement Blog for more details.

Comments 66 CommentsJump to latest comment

chudless's picture

I was led to believe that you would be fixing the issue whereby the compression rates that are displayed all say 1:1 or 1.0:1 when in actual fact compression is taking place. It would be nice, saves clicking around and shows an instant rate of the compression.

Will it be fixed?

simonk27's picture

Updated to SP1, updated all agents. When I click backup now an error message appears(sorry, its german):

Der Server konnte den angeforderten Vorgang nicht abschließen. Unbekannter Grund: 1627652098. BEMSDK Failure Code: 1627652098:X8. Error: 1627652098:Database Exception 0x61040002, Microsoft OLE DB Provider for SQL Server, result:0x80040e14, Die Daten können nicht gespeichert werden, weil ein anderer Benutzer diese Informationen aktualisiert hat.

Any ideas? Rebooted the Backup Exec Server, restarted agent services. Same error.

Elias AbuGhazaleh's picture

Simonk27, there should be a crash dump from BEMSDK tha we will need to collect and look at for this crash.  The error message you are hitting is indicating that the requested operation could not be completed.

Do you receive the same error if you attempt to create a new backup job and run it? or does that only happen when you click backup now on an existing job?

simonk27's picture

Thank you for your quick reply.

Where can I find the crash dump?

When I start an existing job, nothing happens. When I create and start an new job or edit an existing job, the above error message appears.

Elias AbuGhazaleh's picture

Here is how you can gather the needed logs/crash dump.  Sorry for not including this information the first time:  http://www.symantec.com/business/support/index?page=content&id=TECH83408

simonk27's picture
Collected logs with vxgather, but cannot find a crash dump from BEMSDK.
 
Altough I found something in the debug monitor:
BESERVER: [03.06.12 21:28:26] [4348]     -1 SQLLog(3649):Database Exception Context:m_QueryTimeoutInSeconds=30 sql={CALL DBO.SAVETASKDEFINITION(?,?,?,?,?,?,?,?,?,?,?,?)} Error:-536837662: :: -2147217900:Die Daten können nicht gespeichert werden, weil ein anderer Benutzer diese Informationen aktualisiert hat.
 
 
     :: DB Error Set 0: native=0x61040002 source=Microsoft OLE DB Provider for SQL Server hr=0x80040e14 Die Daten können nicht gespeichert werden, weil ein anderer Benutzer diese Informationen aktualisiert hat.
BESERVER: [03.06.12 21:28:26] [4348]     -1 Error(16/18): 1627652098:Database Exception 0x61040002, source:Microsoft OLE DB Provider for SQL Server, result:0x80040e14, Die Daten können nicht gespeichert werden, weil ein anderer Benutzer diese Informationen aktualisiert hat.
 
placki's picture

Hi,

After applying SP1 I can't do my backups anymore - service "Backup Exec Server" crashes all the time :

Event ID: 1026 Source .NET Runtime

Application: beserver.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 0000000077AA4320

Event ID: 1000 Source Application Error

Faulting application name: beserver.exe, version: 14.0.1798.105, time stamp: 0x4fa3de95
Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e
Exception code: 0xc0000005
Fault offset: 0x0000000000054320
Faulting process id: 0x1c3c
Faulting application start time: 0x01cd42338f5d5f86
Faulting application path: C:\Program Files\Symantec\Backup Exec\beserver.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 5e55876a-ae27-11e1-8e7d-0013210788d7

Event ID 0 Source Backup Exec Management

Failed to configure ApplicationHA Console with the Backup Exec media server for Auto Recovery as a Backup Exec certificate could not be issued to the ApplicationHA Console.Check Backup Exec Root Certificates. ApplicationHA Console may not be properly configured or may be giving an improper CSR.

Any ideas ? Restarting services and rebooting server make na differences ;(

Markus_Hass's picture

Same Problem,

i just updated via LiveUpdate and now Backup Exec Server service stops working. You found a solution for this?

Regards,

Markus

InSixDays's picture

I had the same problem after the SP1 update.  I ended up doing a repair installation from the control panel and then Programs and Features.  Then after a requested reboot I did a liveupdate and the system said it was up to date.  That fixed the problem for me.

John Sims's picture

I have the same issue, (ntdll.dll crash).  I am attempting a repair and will post my findings.

clovett's picture

I installed the service pack and now the beserver.exe process keeps increasing memory usage and then will crash,

Log Name:      Application
Source:        Windows Error Reporting
Date:          6/3/2012 9:16:06 PM
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      FL-BACKUP-2008.Avatar.local
Description:
Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: beserver.exe
P2: 14.0.1798.105
P3: 4fa3de95
P4: StackHash_68a5
P5: 6.1.7601.17725
P6: 4ec4aa8e
P7: c0000374
P8: 00000000000c40f2
P9:
P10:

 
 

BEsymc's picture

@clovett :If this crash is seen after increasing memory, we will need to understand if this memory usage was indeed required or it is some issue with our memory management. Do you have a support case open from where we can request some additional logs to have a better understanding of the issue?

clovett's picture

I tried doing a repair of Backup Exec to see if that would fix the issue but that didn't help.  I then uninstalled sp1, did a reboot, reinstalled sp1 and rebooted.  This seemed to have fixed the major issue with the beserver.exe process.  Now 4 days later I check Backup Exec and beserver.exe is consuming memory and crashing again!  How could it work for 4 days and then with nothing changing on the server start crashing again? 

zak2011's picture

SP1 is a total disaster. I am having more errors than fixes. How come there are so many problems with SP1 now?

Elias AbuGhazaleh's picture

Zak2011, can you direct message me your contact information.  I'd like to get a better understanding of what issues you are running into and help you resolve those.

Arnault P.'s picture

Hello me too i have an another problem with the backup exec management service :

Platform/Version

 
 

Windows Server 2008 R2 Standard (x64-64bit)

 
 

Summary

 
 

After apply service pack 1 : The Backup Exec Management Service hung on starting event is logged whenever server is rebooted and take several minutes for open a session...

If i uninstalled it, the problem dissapears... I have found this article : http://www.symantec.com/business/support/index?page=content&id=TECH189830

When the problem is resolved ? Thanks for your help.

zak2011's picture

Sure. The errors i encountered were the following

1) Tried installing the SP1 using live update several times and it failed. Then i downloaded it manually and it got installed.

2) After that the Backup Job engine was crashing. It crashed twice in less than five minutes.

3) All the jobs that started to run appeared to be running and then failed twice.

Tried to uninstall SP1 by clicking the link provided by Symantec and does not work.

Elias AbuGhazaleh's picture

Thanks for the additional details Zak2011.  Do you recall what the Live Update errors were you ran into? (I realize that you are past that, but I'd like to troubleshoot it if possible.)  The other items you mentioned, do you have some time to get on a call/session with you today to look at these issues with you?  I read the 3 items yo have indidcated, and others have indicated a crash as well....we are still trying to determine what is going on.

I'd like to get you up and running of course, and I just wanted to mention the following as a status....
As we are tracking the adoption of the SP1 update across our install base not everyone is running into these issues, so we don't have a general issue.  Something is going on, and I'm reaching out to those that are running into an issue to help out.  I'd like to get you up and running...just need to know how to reach you via phone.

Markus_Hass's picture

I managed to uninstall SP1 with the 2008R2 "Add or remove Programs" tool. After that i have 2012 with 4 Hotfixes running again. However SP1 is no longer offered to me via Liveupdate.

Regards,

Markus

Elias AbuGhazaleh's picture

Markus_Hass, have you rebooted after the uninstall?  If yes and it still does not show up, please try to download SP1 from the here: http://www.symantec.com/business/support/index?page=content&id=TECH186717

Markus_Hass's picture

Yes, i rebootet... the uninstall requires that. I think i will wait before i install SP1 again.

zak2011's picture

Thanks for your help and  quick response Elias. Unfortunately I had to  uninstall SP1 due to issues i was encountering.  Perhaps I could install it back once SP1 is stable.

Elias AbuGhazaleh's picture

Zak (and anyone else encountering this error with SP1) - Please feel free to send me a DM with your email address, so that I can send you an email as soon as we have the fix for this issue some users are encountering.

zak2011's picture

I had to do a restore job from tape now. When i did a scan on the tape which consisted of monthly backups which has a retension of one year, it showed me as scracth media with no backup sets. After cataloging the tape again, the media set has gone to Backup and WindowsNT default media set and it shows the data. I guess this has happened after SP1 has been uninstalled.

Rogo's picture

I just moved from 2010R3 to 2012 last week. The results were less than spectacular. Now I have installed SP1 yesterday....  wow, what a disaster. Experiencing the same BE Engine service shutting down. Also my disk media will sporadically fall off line.

I uninstalled SP1 this morning and will monitor this thread for a fix. I'm less than happy with Symantecs performance in this.

Max123456789's picture

Backup Server services stops (after every job?). Any solutions?

zak2011's picture

Hi Max,

I have been encountering the same issues yesterday after SP1. Just remove it  from Program and Features in server 2008 and go to installed updates and remove it and do not use it for now until further notice from Symantec. Remmeber to reboot your server. I logged a case with Symantec few minutes ago and they have gathered some logs and will get back. Until then i am not installing SP1.

Max123456789's picture

Done another "install options and licenses on this server" and a reboot. Backup was OK last night.

Sorry. Problems are back. Backup Server Service crashes.

zak2011's picture

Just talked to Symantec Technical support and they have been asked not to recommend anyone from installing SP1. They said proabably the stable version of SP1 should be out by the end of the week.

Thanks!

chudless's picture

And what about those of us who have installed it - will the new release of SP1 mean we have to uninstall SP1 and install the 'good' one?

zak2011's picture

The information received now from Symantec technical support is not to encourage anyone to install the current SP1 until the issues are resolved. I faced many problems with SP1 and had to uninstall it inorder to get my backups up and running again. 

From what i have seen, almost everyone who installed SP1 including myself had problems. If you dont have any issues, perhaps you could keep it. Best thing would be to log a call and get their confirmation.

Brian Brophy's picture

Hello everyone,

There is a known issue with the current release of Backup Exec 2012 Service Pack 1 that can cause beserver.exe to crash on some installations. We are working on a fix for this and will release it as Service Pack 1a as soon as we are confident this resolves the issue.

Once Service Pack 1a is released you will be able to download it off of the Technote and from Live Update.  It will install over the current SP1 that you have in place, not requiring you to uninstall the first revision.

zak2011's picture

Hi Brian,

Thanks for the information. Since SP1 has caused lots of unforseen problems, why does Symantec still have it on the Live update. Also shouldn't there be  an official notification  to all Symantec customers that there has been issues with SP1 and   steps providing the necessary resolution or atleast an official info that SP1a will be out. I got this info only after contacting support several times.

simonk27's picture

I needed to reinstall my Windows server, because Symantec couldn't provide me with a solution. I opened a ticket monday morning europe time and no helping fix until now. This is taking too long, so I decided to reinstall my Windows machine - a lot of work, but a working solution.

placki's picture

I notice a few things - maybe they will be helpful for somebody:

- after installing SP1 via LiveUpdate I'm unable to uninstall it

- in other installation, which I know, after manual install (from exe file) there was possibility to rollback 

- I've got info from some Symantec employee that repairing BE2012 installation through the Add/Remove Programs helped in same cases but in my case it didnt work at all (repairing process crashes with some error message)

- sometimes right after server reboot when I open console and I dont touch anything I can see that some jobs started automatically are running fine and are finished. When I click something service crashes almost immediately

no-hoper's picture

I installed the SP1 today, since it has been installed i have not been able to access my Backup exec console as the services are not starting. I uninstalled the sp1 but i am still unable to do it. I have also done a repair on my backup exec installation but with no luck. Is there a work around for this services issue that i havn't seen yet? as i would really like to be able to run my backups tonight.

dlt1928's picture

Why hasn't Symantec removed the SP1 download??  Seems they 'tested' the SP1 like they 'tested' the 2012 release.  What a debacle!!!  Fortunately I did some research before I downloaded SP1.  wish I had done that BEFORE I upgraded to 2012.

Symantec you need to get it together.  Backups are a VITAL operation of any organization.  If your R&D and quality control can’t get it together you’ll force many of us to look at other solutions.  I, for one, DO NOT have time to be your guinea pig!

Steve Kratz's picture

So what do those of us with screwed up backups do to safeguard our servers in the meantime? Do we need to research a different product in the meantime and install that instead?

Elias AbuGhazaleh's picture

The issue identified in this thread about SP1 does not affect every user of SP1, while I understand it is affecting those that have posted here (and a few other posts on SymConnect).  Please check out this technote for the current work around: http://www.symantec.com/docs/TECH190313 (if you are hitting the serdll.dll error).
We have also had many users indicate that a repair operation from Add/Remove of Backup Exec and a reboot resolved the issue for them.

raelsprinkler's picture

I have the same issue. I just did a repair and still the Backup Exec Serivce keeps stopping. I am getting the following Event log (application):

Faulting application name: beserver.exe, version: 14.0.1798.105, time stamp: 0x4fa3de95

Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e

Exception code: 0xc0000374

Fault offset: 0x00000000000c40f2

Faulting process id: 0x17ec

Faulting application start time: 0x01cd442670f75861

Faulting application path: C:\Program Files\Symantec\Backup Exec\beserver.exe

Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

Report Id: 56496de1-b01a-11e1-b0f9-782bcb34662e

I am NOT able to run ANY Backups! This needs to be fixed ASAP!!!!!!!!!!!!!

no-hoper's picture

I managed to get my Symantec working again but not how i wanted to. I had to completly remove it from my server and re-install in order to get it working again like it was a fresh install. Due to this i was able to carry out my nightly backup's apart from one failed with:

" The job failed with the following error: For this operation, the Backup Exec Virtual File Filter (VFF) driver must be installed on the Backup Exec server.  The VFF driver is installed when you install any of the following Backup Exec agents or options:

Exchange Agent
Active Directory Recover Option
VMware Virtual Infrastructure Agent
Microsoft Virtual Server Agent "

which is one i haven't seen before, i was trying to backup a Domain Controller and the agent on it was the same as it has always been. Anyway i am sure i will figure it out. Just thought i would let people who where in the same position as me where the current work arounds/fixes are not working for them they will have to bite the bullet and start again and possibly do a restore of there backup server after.

aharte's picture

As subject says along with everyone else I had issues with service pack 1.   I applied service pack 1 and rebooted as instructed which led to a lovely reboot circle.  Had to travel to data centre to resolve via safemode and last known good configuration.  

BE 2012 reports service pack 1 is installed but is it?  Any idea's on how to confirm symantec?

Thanks

zak2011's picture

After SP1 was installed and removed, it seems to have removed some of the catalogs also. When I am trying to do a restore from a tape, i am not able to do that. This means i need to recatalog the tape again. When i do that it goes to the default media set.

PGagnon's picture

HI everyone, I'm having the same problem as you. This morning I've found this article: http://www.symantec.com/business/support/index?page=content&id=TECH190537&actp=RSS

Problem

After installing Backup Exec 2012 Service Pack 1 Backup Exec Server service crashes within few seconds of starting with error below in Event logs.

Solution

Workaround:

1. Go to command prompt and browse to "X:\Program Files\Symantec\Backup Exec" directory.

Note: replace X: with the drive letter where Backup Exec is installed.

2. Type bemig and hit enter key. Once the process is complete start the Backup Exec Server service.

In MY case it fixed my backup exec "beserver" service. So now I can access the software... 

FINALLY!!

Rogo's picture

Like many, I had to uninstall 2012 w/SP1 completely and reinstall 2012 without SP1. I can at least get a backup now.

2012 is a pitiful product. Some companies can mess around with their products and it's a major annoyance. But mess with our ability to generate reliable backups is absolutely not acceptable on any level.

Talking to AppAssure, if I can make a deal. I'm kissing you boys goodbye.

zak2011's picture

Contacted Symantec Technical Advanced team and they have confirmed that the service pack1 removes catalog information and the only way to restore from tapes is to recatalog everything. However they said this would be resolved once SP1a is out. They have recommended again not to install SP1.

Elias AbuGhazaleh's picture

zak2011, can you give me a case # so I can find out who you talked to about this issue.  This is not a valid statement.  We are working on resolving the crash that a few people are hitting, but the statement of SP1 removing catalog infomration is inaccurate.  Thus the reason I need to look at the case # that you called support on in order to track down that comment.  Feel free to email/direct message me that information please.

zak2011's picture

Hi Elias,
In my case some of the catalog information has been removed.This has happened after the installation and uninstallation of sp1. So when i spoke to the support team yesterday , there were many possible hints that some of the catalog information was missing since i was not able to do some restores from tapes since the errors came up saying unable to find the media. Also when i tried to restore files from different tapes which were recently inventoried in the catalague information of Backup Exec it showed up as scracth media having no backup sets. Once i recatalogued them, the information shows up in the tapes but the media set went to the default media set. Also the media server backup job is failing ever since the sp1 was installed and uninstalled. The following error was what i was getting

Backup- \\BACKUPSRVXX.company.local\C:
File Program Files\Symantec\Backup Exec\Catalogs\BACKUPSRVXX\{358CBEC3-3E47-424A-B596-E34E1BF563D6}_1.xml was not found, or could not be accessed.

.The case no. was 418-122-004.

So seeing all these events , it was concluded by the support team that SP1 had something to do with this.

Elias AbuGhazaleh's picture

Thanks for the response on this, I'll follow this up and check the case.

zak2011's picture

Hi Elias,

Have you got any response from this case. I am not even able to back up my media server properly. Is there any update about the service pack update!

Thanks!

Elias AbuGhazaleh's picture

I didn't receive an update back from our support management on this case yet, but I did pass along the information.  In regards to the update, it should be on Live Update mid-week.

Max123456789's picture

So. Removed BE2012 with SP1. Did not select the option to completely remove ALL files. Reboot and installed BE2012 again. Everything seems normal. All the jobs are there.

Only takes 15 minutes. Not a big deal.

Backup is running normal.

Wanted to wait for the SP1a but this takes too long unfortunately.

jpk's picture

Has anyone successfully installed this mess?  I'm not going near it after reading all of this.

David Palmerston's picture

jpk-

We tried updating to a downloaded copy of SP1 after having run BE2012 for 3 months and we got many, many new and different errors.

I finally bit the bullet last Friday night and did a COMPLETE BARE-METAL reinstall of our BE2012 server (and it caught SP1 via liveudpate during the process) and things have been a lot better (we actually have gotten 5-6 days of good backups!).

Things are NOT completely solved, but far, far better than adding in SP1 to a system that was already experiencing problems.

If you are getting okay results without SP1, I would wait a bit on SP1.

If you are NOT getting backups, I'd recommend the Bare Metal route as it actually doesn't take as long as trying to escalate a bunch of calls on what might be spurious errors.

YMMV

(Break over - now back to squashing a few more bugs...)

raelsprinkler's picture

That is simply CRAZY to do a bare-metal restore for a SP that Symantec put out that is causing all these issues!

jpk's picture

Thanks for the heads-up!

I have my own set of issues with the base install of 2012, but my backups are completing and appear to be restorable.  With that said, I'll let SP1 bake for a week or two until Symantec figures out how to fix the bugs that were supposed to fix bugs.  I can't fathom putting in the time to do a bare metal build of this *again*.  I'm kicking myself for not jumping to AppAssure or something else when i had the chance.  Unfortunately, I think BE has a limited lifespan within our organization.

Artisanhw's picture

Just upgraded from BE2010 to BE2012 on Windows 2008 R2 server with IBM TS3100 robotic library with two drives, an LTO4 and an LTO5.

Installation was a bit of a mystery as it asked to follow some videos. To be safe, I completely uninstalled 2010 and then installed 2012. Required three reboots to get everything working.

UI is completely new and requires a bit of time to get used to but surprise, surprise.. no BEMCMD. Symantec has also decided to follow the same logic as some others i.e. take something that is simple and works perfectly fine and has been for years and replace it with something that is anything but simple.

I used BEMCMD since version 10 because I do lots of disk-to-disk backups before I kick off the actual disk-to-tape backup. I have all my command scripts working for years and running a backup job from script was as simple as calling BEMCMD with couple of parameters. Now with 2012, I have to rewrite some of that logic in PowerShell to work with BEMCLI. I am not a happy camper.

Could'nt Symantec just add BEMCLI to the list of tools and inform users that BEMCMD will be obsolete by release 2014 e.g so that users could get used to the new tool instead of just replacing it cold turkey. Just a very dumb decision as far as I am concerned.

Number5Alive's picture

I am getting the ntdll.dll error as well and backups haven't been running since SP1. I was hoping SP1 would fix some random issues we were having and then BOOM. Really, really, frustrated with Symantec on this. 2012 was bad, but this is just unacceptable. Very seriously considering dropping them when my support contract is up (or sooner if this doesn't get fixed very very quickly).

The support technician I talked to said the Advanced Team is aware of the problem and are looking into some fix. If SP1a is indeed out by midweek like Elias said, that would be nice. I am losing sleep over no backups running.

raelsprinkler's picture

I have the same problem. They took a error log and said they will call me at 5 PM last night. I waited until 6:30 PM no call, now I have no backups since 6/8/2012 I have emailed them a few times, no reply. Going to call them now. This is really bad!

Elias AbuGhazaleh's picture

I wanted to send out a note to everyone on this thread that we are in the process of uploading SP1a to the Symantec Live Update Servers. I'm expecting this update to be available for download through Live Update around 7pm EST (6/12/2012).

raelsprinkler's picture

Symantec dropped the ball BIG TIME; I have a call open.. someone was suppose to get back to me.. NO phone call, NO email. Now I get this information via Symantec Connect...???

Will SP1a fixed this problem.. has it been tested OR will I have more problems? I need someone to call me my Case # is 418-164-646

Thank you.

Elias AbuGhazaleh's picture

Raelsprinkler,

I've passed along your note to our support managers to have someone give you a call.

Number5Alive's picture

What a relief! Thank you for the update. Keeping my update button ready for 7PM EST.

ndrogo's picture

I hope it works, we have been haveing the same issues

Swathi Turlapaty's picture

Backup Exec 2012 SP1a has been released today. Backup Exec 2012 Service Pack 1a will replace/supercede the previously released Backup Exec 2012 Service Pack 1.

Here is a TECHNOTE that contains a list of known issues and enhancements resolved with Backup Exec 2012 revision 1798 Service Pack 1a.

This thread is currently CLOSED. Please offer feedback and ask questions HERE!