Video Screencast Help

Backup Exec 2012 Services Crash for no apparent reason

Created: 03 Oct 2012 | 16 comments

Hi

We have server with BE 2012 Sp1 on 2008 R2 SP1.

It is configured to backup 3 servers. Two physical and one virutal (HyperV)

Almost every day the jobengine service and the management service stops for no apparent reason. I can start the service manually and run the job manually with no problem, but it won't start on its own.

This was originally an upgrade from BE 2010, so I thought maybe something had gone wrong with the upgrade. I unistalled BE and reinstalled it fresh, but the problem persists.

Here is the eventlog info:

 

Log Name:      System
Source:        Service Control Manager
Date:          02.10.2012 21:02:11
Event ID:      7009
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxx
Description:
A timeout was reached (30000 milliseconds) while waiting for the Backup Exec Server service to connect.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7009</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2012-10-02T19:02:11.890581800Z" />
    <EventRecordID>205058</EventRecordID>
    <Correlation />
    <Execution ProcessID="828" ThreadID="15888" />
    <Channel>System</Channel>
    <Computer>xxx</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">30000</Data>
    <Data Name="param2">Backup Exec Server</Data>
  </EventData>
</Event>
 
-----
 
Log Name:      System
Source:        Service Control Manager
Date:          02.10.2012 21:02:12
Event ID:      7000
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxx
Description:
The Backup Exec Server service failed to start due to the following error: 
The service did not respond to the start or control request in a timely fashion.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7000</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2012-10-02T19:02:12.327606800Z" />
    <EventRecordID>205059</EventRecordID>
    <Correlation />
    <Execution ProcessID="828" ThreadID="15888" />
    <Channel>System</Channel>
    <Computer>xxx</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Backup Exec Server</Data>
    <Data Name="param2">%%1053</Data>
  </EventData>
</Event>
 
----
 
Log Name:      System
Source:        Service Control Manager
Date:          02.10.2012 21:02:19
Event ID:      7001
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxx
Description:
The Backup Exec Job Engine service depends on the Backup Exec Server service which failed to start because of the following error: 
The service did not respond to the start or control request in a timely fashion.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7001</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2012-10-02T19:02:19.093993800Z" />
    <EventRecordID>205062</EventRecordID>
    <Correlation />
    <Execution ProcessID="828" ThreadID="15888" />
    <Channel>System</Channel>
    <Computer>xxx</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Backup Exec Job Engine</Data>
    <Data Name="param2">Backup Exec Server</Data>
    <Data Name="param3">%%1053</Data>
  </EventData>
</Event>
 
 
 
Anyone got any tips?
 
Cheers
 
Anders

Comments 16 CommentsJump to latest comment

AmolB's picture

If you have Anti-virus on the BE media server than exclude all BE serviecs from the AV scan.

AmolB's picture

BE Device and Media service  (pvlsvr)

BE Server service (beserver.exe)

BE Job Engine service (bengine.exe)

BE Rmote Agent services (beremote.exe)

BE Agent Browser service (benetns.exe)

 

Above is the sequence of services, BE job engine service is crashing coz it dependant on BE server 

service. From the above event id it seems that the issue is with the BE server service.

Anderso's picture

The thing is, the AV realtime scanner is turned off, and it's only scheduled for a scan every monday. The services crash regardless of this.

AmolB's picture

Do you see any .Net related errors in the Windows Event Viewer?

Within BE console check if you have installed SP1 or SP1a.

There was 1 known issue of BE server service crashing which is resolved in SP1a

Refer to http://www.symantec.com/docs/TECH190472

Anderso's picture

Sorry, no .NET errors.

BE says I have SP1 installed, but i have no option to install SP1a through Live Update.

Anderso's picture

Ok, seems that upgradeing to SP1a helped the job enginge service at least. Now it's just the manager service that crashes...

lmosla's picture

Is the Manager Service set to log on with the Backup Exec Service account?

Go ahead and go through this link to verify that all your service account still has the correct requirements. http://www.symantec.com/business/support/index?page=content&id=TECH36718

 

Let me know if this helps

Anderso's picture

The user wasn't a member of Backup operators.

Have entered the user in that group, so we'll see if that did it.

*crosses fingers*

lmosla's picture

Hi Anderso,

How are things working now?

Anderso's picture

Things are looking good so far :)

I still want to give it a few days before I consider the case solved though. It has gone a few days between crashes sometimes. Well see over the weekend.

Anderso's picture

The service still stops..... but I found out why

I am a bit embarrassed to say this but there was a batchjob made by the previous company which served this client. The bactchjob restartet some of the backupexec services at 2100 every night....

I should have caught on to this sooner. Sorry for troubling you guys.

 

Anders O

lmosla's picture

glad to hear things are figured out.

have a good one