Video Screencast Help

Backup Exec 2012 Sp2 - No contents shown when trying to restore a NDMP backup

Created: 30 Sep 2013 • Updated: 30 Sep 2013 | 3 comments

As stated in the title, I am trying to do a restore from a set of tapes backed up about two months ago.
While the job log says the backup has been completed succesfully with a size of about 4.400 GBs (~ 4 TB), the restore-dialogue won't come up with any contents within the given session.
In fact when checking the session on all the associated media (10x LTO3 tapes) Backup Exec tells me that this session has "0 Bytes" and that it "might not contain any data".
On the other hand the tapes are showing an average free space of about 10 GB only while the rest of the 400 GB capacity has been used for backups.
It looks like the data I'm looking for is in fact on the tapes but BE is unable to see it or let me choose it for restore.
I already tried to re-catalog all the tapes with different options ("use storage-based catalogs", etc.) with no luck.
I tried to retire all the affected tapes, delete them from BE and did a re-inventory and re-catalog afterwards with no luck either.
I removed the source-server from the console an re-added it afterwards -> same result.
I also tried to restore the whole 4TB-session to another destination but it refuses to do so also.
Even tried to rebuild the whole catalog by renaming the catalogs-folder and starting all over: still no luck.                                     

The server (Netapp FAS 2040 via NDMP) is showing up correctly and I am able to browse all the volumes, folders and files within the backup-selection lists.
In the restore window I can see both selected volumes but the files and folders below are missing (jep I already checked the date-option).
The tapes don't show any read- or write-errors (most of them have been used for the first time). The media server is up to date.
I'm running out of ideas how to proceed...

Any ideas, hints or recommendations how I could get back my data would be greatly appreciated.
Thanks in advance

Operating Systems:

Comments 3 CommentsJump to latest comment

Donald Eady's picture

Try to run a duplicate job from tape to disk and then attempt to restore from disk location and report wether or not the selections appear

I hope this posting was helpful


DefCon5's picture

Thanks for the hint, I'll give it a try. Might take some time but it seems to copy at least something (~23GB for now but still running)

DefCon5's picture

Well it took me quite a while and the result doesn't look very promising.
At the end of the duplicate-job the log says:

Duplicate Set Summary
Backed up 0 files in 3 directories.
Processed 4,767,124,029,440 bytes in  37 hours,  33 minutes, and  24 seconds.
Throughput rate: 2018 MB/min

That doesn't look too good. In addition after verification it states:

Verify Set Summary
V-79-8192-4881 - The count of Files and Directories processed is not available for this operation. The File and Directory count might be displayed as zero.
0 files were different.
Processed 2,730,876,928 bytes in  27 hours,  25 minutes, and  17 seconds.
Throughput rate: 1.58 MB/min

Although the verification is real slow, that's not a big problem for me since the destination drive is used only once in a while and not for all-day backups. I don't think that the mismatch between the duplication- and the verification-byte count really does matter. It seems the BE simply closed the connection after a while because it took to long to finish the job.
What puzzles me is that the file-count still says there were no files found in the set.
I already verified if the "File History"-setting is enabled in the job settings which is the case.
Any ideas how to proceed now? At least the byte-count (duplication job)  seems to be correct so I still hope to get my files back.
Thanks in advance