Video Screencast Help

Backup Exec 2012 - Unable to Add Barcode Rule - LTO5

Created: 16 Aug 2012 • Updated: 13 Sep 2012 | 17 comments
This issue has been solved. See solution.

I just recently upgraded to Backup Exec 2012 from 2010 and my LTO5 tape barcodes are not scanning.  I can set the Media Label and I am okay there, but it's not scanning the barcodes.  I tried using the BEMCLI and I am not having success.  When i listed the media types I don't see LTO5 in the list of results.  So I am having trouble adding LTO to the available media types.  Any help would be very much appreciated.  Please let me know what details you need to help.  Thanks for taking the time to look at this.

- Jesse

Comments 17 CommentsJump to latest comment

Colin Weaver's picture

Barcode rules are only used if you have a library that contains a mixxture of media types (LTO3, LTO4, LTO5 etc)

along with a mixture ofdrive types in the same library, in order to make sure that BE does not try and move and LTO-5 tape into an LTO-3 drive.

If your library only contains LTO-5 media and LTO-5 drives then you do not need to use or configure barcodes rules.

 

Now if you used to use Backup Eec 2010 and your LTO-5 barcodes were being correctly used and since the upgrade they are not, then I think you need to log a formal support case for us to investigate.

However before doing this please conform that at the same time as upgrading the Backup Exec version you did not also add some new barcodes/tapes into your library as if you did I would be suspicicous that you have the wrong barcode format and you will then need to contact the library (hardware) vendor to confirm this.

jrosenbaum's picture

Our Library has two LTO5 drives and uses LTO4 & LTO5 tapes.  We just recently got new Barcodes that start with W as opposed to A, which is what we were using before.

We didn't start using the LTO5 tapes with the new labels until after we upgraded.  Prior we used LTO5 tapes with old format labels and they were okay.

Larry Fine's picture

If your issue is that you cannot read the new labels, then bar code rules are obviously not going to work.

Can you see the bar code labels in BE?  if not, can you see them in your library interface (web or LCD)?

The first character shouldn't matter, or did you used to use bar code rules based upon the prefix?

If you find this is a solution for the thread, please mark it as such.

jrosenbaum's picture

I can see existing barcodes (i.e. A00001L4 or 000123L4).  Our new barcodes of W00001L5 are not being read.  I haven't tried the LCD or Web interface for the library yet.  I will check those and get back to you.

Larry Fine's picture

Bar code rules can be used with any library.  If the drives are all of the same generation, then bar code rules are only usefull if you have some other purpose in mind (such complicated stuff such as departmental rules, backup proirity strategies, etc).  But typically they are used when mixed generations of devices are present.

What BEMCLI commands were you using?

What do you get from this command:

Get-BETapeDriveDevice | select-object Name,@{n="WritableMedia"; e={$_ | get-bemediatype -writablemedia}},@{n="ReadbleMedia"; e={$_ | get-bemediatype -readablemedia}}| Out-Default

You should get something vaguely like this:

Drive Name                    WritableMedia                           ReadbleMedia
LTO2 01                        {LTO-100, LTO2}                         {LTO-100, LTO2}
LTO2 02                        {LTO-100, LTO2}                         {LTO-100, LTO2}
LTO4 01                        {LTO3, LTO4}                            {LTO2, LTO3, LTO4}
LTO4 02                        {LTO3, LTO4}                            {LTO2, LTO3, LTO4}
LTO5 01                        {LTO4, LTO5}                            {LTO3, LTO4, LTO5}
LTO5 02                        {LTO4, LTO5}                            {LTO3, LTO4, LTO5}

If you find this is a solution for the thread, please mark it as such.

jrosenbaum's picture

Here is what I get from BEMCLI:

 

BEMCLI> Get-BETapeDriveDevice | select-object Name,@{n="WritableMedia"; e={$_ |
get-bemediatype -writablemedia}},@{n="ReadbleMedia"; e={$_ | get-bemediatype -re
adablemedia}}| Out-Default
 
Name                       WritableMedia              ReadbleMedia
----                       -------------              ------------
MISSING 1                  {}                         {}
MISSING 2                  {}                         {}
Tape drive 0001            {LTO-10 (87m, 10.0GB), ... {LTO-10 (87m, 10.0GB),...
Tape drive 0002            {LTO-10 (87m, 10.0GB), ... {LTO-10 (87m, 10.0GB),...
 
 
BEMCLI>
                                                                       
We only have two drives in a 4 drive capable library.
Larry Fine's picture

try this (for IBM):

Get-BETapeDriveDevice | Where-Object{ $_.primaryinquirystring -like "*IBM     ULT????-??5*" }| Set-BETapeDriveDevice -WritableMediaType "LTO5","LTO4" -ReadableMediaType "LTO5","LTO4","LTO3"

or this (if you have HP)

Get-BETapeDriveDevice | Where-Object{ $_.primaryinquirystring -like "*HP      Ultrium 5-SCSI*" }| Set-BETapeDriveDevice -WritableMediaType "LTO5","LTO4" -ReadableMediaType "LTO5","LTO4","LTO3"

If you find this is a solution for the thread, please mark it as such.

pkh's picture

LTO3 should not be included since a LTO5 tape drive cannot write to a LTO3 tape.  Also, LTO5 is a valid media type only if you install a fresh copy of BE 2012.  If you upgrade from an older version of BE, there is no LTO5 media type.  You have to use an existing media type as to represent LTO5.

 

Larry Fine's picture

re: LTO3 should not be included since a LTO5 tape drive cannot write to a LTO3 tape.

An LTO5 drive can most certainly READ an LTO3 tape, which is what my command states.

If you find this is a solution for the thread, please mark it as such.

jrosenbaum's picture

Larry,

Thank you for your continued help here.  I ran that command and I get an error that states the MediaType LTO5 could not be found.  Maybe thats my ultimate problem.  Here is the full error.

 

-------------------------
 
BEMCLI> Get-BETapeDriveDevice | Where-Object{ $_.primaryinquirystring -like "*IB
M???? ULT????-??5*" }| Set-BETapeDriveDevice -WritableMediaType "LTO5","LTO4" -R
eadableMediaType "LTO5","LTO4","LTO3"
Set-BETapeDriveDevice : Cannot bind parameter 'WritableMediaType'. Cannot conve
rt value "LTO5" to type "BackupExec.Management.CLI.BEMediaType". Error: "Cannot
 find any MediaType objects with the name LTO5."
At line:1 char:136
+ Get-BETapeDriveDevice | Where-Object{ $_.primaryinquirystring -like "*IBM????
 ULT????-??5*" }| Set-BETapeDriveDevice -WritableMediaType <<<<  "LTO5","LTO4"
-ReadableMediaType "LTO5","LTO4","LTO3"
    + CategoryInfo          : InvalidArgument: (:) [Set-BETapeDriveDevice], Pa
   rameterBindingException
    + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,BackupExec.Manage
   ment.CLI.Commands.SetBETapeDriveDeviceCommand
 
BEMCLI>
                                                                       
pkh's picture

As I have stated earlier, if you have upgraded to BE 2012 from an earlier version of BE, then LTO5 would not be a valid media type.  You would have to use another media type as a subtstitute.  See my article below

https://www-secure.symantec.com/connect/articles/s...

Don't get hang up with barcode rules which is not applicable in your case.

pkh's picture

@jrosenbaum - To set barcode rules in BE 2012, see my article below

https://www-secure.symantec.com/connect/articles/s...

However, as Colin Weaver has previously advised, you do not need to set barcode rules because you are using only using LTO5 tape drives and it can write to both LTO4 and LTO5 tapes.

Make sure that your barcode labels comform to the tape library manufacturer's requirements.  If you are using a HP library, see my blog below

https://www-secure.symantec.com/connect/blogs/barc...

If your labels does not conform to the manufacturer's requirement, you can produce your own barcode labels.  See my article below

https://www-secure.symantec.com/connect/articles/u...

I see from your listing of tape drives that there are 2 missing tape drives.  You might want to go to the BE installation directory and use tapeinst.exe to delete all instances of tape drives and then re-install your current tape drives.

As an aside, since you have 2 tape drives in your library, make sure that you have an additional LEO licence installed.

jrosenbaum's picture

PKH,

Thanks for the reply.  I think you're second article is for BackupExec 2010 as there is no Option > BarCode Rules menu item in BE2012.

As for the missing tape drives, I will delete those instances as recommended.  Thank you.

- Jesse

pkh's picture

I don't know what second article that you are referring to.  I have written two articles on setting barcode rules, one for 2012 which I refer to above and an earlier one which is for setting barcode rules for BE 2010 or earlier.

Colin Weaver's picture

If you have LTO-5 tapes working correctly with barcodes that start with A and LTO-5 tapes that fail with the barcodes that start with W - then get confirmation that the W- barcodes are supported by the library hardware.

I saw something like this some time ago where to the naked eye the barcodes looked the same, however the customer in question had accidentally ordered barcodes that were incompatible with his library by accidentally entering one invalid number in the product code when ordering from his supplier.  Customer in question was adamant that he had the correct barcocdes only for it to eventually come to light that he did not.

SOLUTION
pkh's picture

I agree.  Also, the placement, size, the amount of white space around the labels, etc are important.  If you are not sure what is required, check with the tape library manufacturer.  Once you get the specs, you can produce your own using the method described in my article referenced above.

jrosenbaum's picture

All,

 

I have solved this mystery and I am happy to report that it is NOT a Symantec problem.  I contacted the person who ordered our labels and sure enough they didn't order labels with the Check Digit and my library had the check digit option turned on.  So I disabled the option and Backup Exec is reading the labels properly.  Thank you to everyone who participated in this thread.

 

- Jesse