Video Screencast Help

Backup Exec 2012 V-RAY VMware backup problem

Created: 17 Aug 2013 | 12 comments
MiTu's picture

Hi,

I have Backup Exec 2012 (V-RAY edition, with SP2 update) backup server and one VMware vSphere 5.1 (Essentials) server. VMware agents are installed to all Guest machines in VMware Server. I'm Backing up all the Guest machines directly from VMware Server (not using Agent backup). VMware agents are installed because of GRT backups.

Backup seems to work ok, no any errors etc. One thing what I don't understand is "System state" backup which isn't working?! Before I updated Backup Exec with SP2, I was taking backups of Guest machines by Backup Exec Agents (because lack of support for VMware vSphere 5.1) and System state backup was working ok. Now I can see from backup logs that "System state" backup has stopped after switching backup method?!

If I'm trying to GRT restore, I can example choose MSSQL database restore and see all the databases and GRT file restore is ok also. System state restore isn't possible?!

- MiTu

Operating Systems:

Comments 12 CommentsJump to latest comment

CraigV's picture

Hi,

Any AV blocking BE from accessing the registry? I've had this issue with McAfee before!

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

MiTu's picture

Hi,

No, thats not a problem because AV software isn't installed yet on servers.

I would like to know does anyone else have this same problem (if you you're taking backups directly from VMware server, not with Backup Exec agents. Please check the log files, do you see "system state" section there? )?

Sush...'s picture

Hello Mitu,

    Could you confirm that the Active Directory GRT option is enabled in the backup job properties. This option is under the Application GRT option under Virtual Machines tab.

 

Regards,

-Sush...

Hope this piece of Information Helps you... and if it does then mark this response as Solution....!!!

MiTu's picture

Hello Sush...

Yes, it's enabled (like as SQL GRT option which is workin ok)! Under of "Advanced Open file" page if have enabled "Use Snapshot Technology" and "Microsoft Volume Shadow Copy  Server (Windows 2003 or later) --> Snapshot provider "System  - Use Microsoft Software Shadows Copy Provider".

I don't really know what other option I can enable anymore to get this work?!

I said in my previous message that  "Please check the log files, do you see "system state" section there?" Actually I meant "Please check the Servers Backup sets, do you see "System state" section there". I just wanted to clarify this.

- Mitu

 

MiTu's picture

More information of this problem:

I noticed that Windows 2012 Domain Contoller Servers System State is backed up properly, but System State backup is missing for other Windows member Servers! I can see it from Servers Backup Sets.

Like I mentioned on my first message, System state backup was working ok (I can see it from Server Backup Sets) on all the servers before I switched backup method?

Does Symantec think it's not important to take System State backups from Windows Member Servers?!

- Mitu

 

Sush...'s picture

Hello MiTu,

   System State backup will be important. I would suggest that you open a support case with Symantec support so that this issue can be throughly troubleshooted.

 

Thanks,

-Sush...

Hope this piece of Information Helps you... and if it does then mark this response as Solution....!!!

MiTu's picture

Support case opened yesterday and after investigation today, problem not solved yet. Let's see what happens. I'll report more later....

Jayb's picture

Hi Mitu,

If i understand correctly , the backup using Vmware is fine but the restore does not show system state of member server alone after sp2?.

But the system state of Domain controller shows up fine , is that correct?

 

 

Thanks
Jay

Jayb's picture

If that above is the case , it is an expected behavior.

In case of Disaster you have to restore entire machine then you can restore the entire vm or

if you just want the file and app GRT , all of them can be restored as you will have the options.

If your Domain controller alone shows system state , it is normal as AD GRT is enabled.(enable GRT for Microsoft Active directory objects on Virtual machine)

Hope this answers.

Thanks
Jay

MiTu's picture
 
 

Hi Jayb,

 

"If i understand correctly , the backup using Vmware is fine but the restore does not show system state of member server alone after sp2?. But the system state of Domain controller shows up fine , is that correct?"

Yes, exactly!

I got finally answer from Symantec --> System State data restore isn't possible to Windows Member Server (VMware Guest machine). You have to restore whole machine. To Domain Controller you can restore System State because of AD GRT

 

They know this issue and hope they have some solution for this in future? I think this is big lack of feature.

 

 
lmosla's picture

Hello MiTu,

what is the support case # ?  I'd like to get more information and see if I can help get this resolved.

thanks