Video Screencast Help

Backup Exec 2012 Windows Agent push install fails with error 1603

Created: 11 Dec 2013 • Updated: 12 Dec 2013 | 6 comments
This issue has been solved. See solution.

In order to troubleshoot another problem I'm trying to re-push the Windows agent from my Backup Exec 2012 server to a Windows Server 2008 R2 running Microsoft Exchange. Everything looks fine until I reach the remote installation pane. Installation starts, percentage runs up from 0 to 100% several times, several strings looking like file names and registry keys display in the status column to quickly to follow or note, then status changes to "installation is being undone", the percentage column changes to a single percent sign without a number in front, and the finally the status is:

"Installation fehlgeschlagen mit Fehlercode 1603. Klicken Sie mit der rechten Maustaste auf den Computer, um Protokolle für weitere Informationen anzuzeigen."

Translation: "Installation failed with error code 1603. Click on the computer with the right mouse button to display logs for further information."

The right click offers two options, "display installation log" and "display log for push installation". The former displays the log from the original installation on the target machine half a year ago, ending with

04-02-2013,15:58:00 : SUCCESS: Installation has completed successfully.

The latter opens the file C:\ProgramData\Symantec\Backup Exec\PushLogs\exchange_Push.log on the BE server which contains an enormous number of error messages, none of them pointing to an obvious (to me) reason for the failure. The first couple of errors appear to be just the result of making sure there are no remnants of previous installations, trying to delete temporary files and registry keys, complaining loudly that they aren't there. Then installation seems to begin in ernest, with a lot of lines "Copying file .." followed by:

01:(12.11.13 10:59:17)->Starting Install:  
01:(12.11.13 10:59:17)->Creating process:  
01:(12.11.13 10:59:17)->CreateProcess: nPID:10736, Return:0
01:(12.11.13 10:59:17)->Checking process status: 10736
01:(12.11.13 10:59:17)->ERROR retrieving registry string: 2147483650, SOFTWARE\Symantec\SymcInstall, Action
01:(12.11.13 10:59:17)->ERROR: Win32: 2
01:(12.11.13 10:59:17)->ERROR Error reading remote registry HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\SymcInstall\Action
01:(12.11.13 10:59:17)->ERROR: Win32: 2
01:(12.11.13 10:59:17)->ERROR: Exception: System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
   bei Symantec.IFrameSDK.NetPush.WMIMethods.GetRegistryDWORD(ManagementScope& oScope, UInt32 nHive, String strKey, String strValue, UInt32& nVal)
01:(12.11.13 10:59:17)->ERROR Error reading remote registry HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\SymcInstall\Total Percent Done
01:(12.11.13 10:59:17)->ERROR: Win32: 1603

The last eight messages (from "Checking process status" through "ERROR: Win32: 1603") repeat many times, until finally:

01:(12.11.13 11:01:00)->Checking process status: 10736
01:(12.11.13 11:01:00)->Cleaning up push install...
01:(12.11.13 11:01:01)->ERROR Error deleting file: \\exchange\BEW-49eeb0b0555049f0b69a0f2cf56fe773\VXPUSHRA\RAWSX64\Install with error: Access to path "\\exchange\BEW-49eeb0b0555049f0b69a0f2cf56fe773\VXPUSHRA\RAWSX64\Install\VxLogServer.exe" was denied.
01:(12.11.13 11:01:01)->ERROR: Win32: -1
01:(12.11.13 11:01:01)->ERROR Error deleting file: \\exchange\BEW-49eeb0b0555049f0b69a0f2cf56fe773\VXPUSHRA\RAWSX64 with error: The directory is not empty.
01:(12.11.13 11:01:01)->ERROR: Win32: -1
01:(12.11.13 11:01:01)->ERROR Error deleting file: \\exchange\BEW-49eeb0b0555049f0b69a0f2cf56fe773\VXPUSHRA with error: The directory is not empty.
01:(12.11.13 11:01:01)->ERROR: Win32: -1
01:(12.11.13 11:01:01)->ERROR Error deleting file: \\exchange\BEW-49eeb0b0555049f0b69a0f2cf56fe773 with error: The process cannot access the file "\\exchange\BEW-49eeb0b0555049f0b69a0f2cf56fe773" because it is in use by another process.
01:(12.11.13 11:01:01)->ERROR: Win32: -1
01:(12.11.13 11:01:01)->Removing map to remote install directory...
01:(12.11.13 11:01:01)->Removing map: *
01:(12.11.13 11:01:01)->Removed map: *
01:(12.11.13 11:01:01)->Deleting share: C:\BEW-49eeb0b0555049f0b69a0f2cf56fe773
01:(12.11.13 11:01:01)->Deleting entire folder: C:\BEW-49eeb0b0555049f0b69a0f2cf56fe773

A lot of other messages follow, until the file ends with

01:(12.11.13 11:09:28)->Deleting folder: C:\BEW-1bee1a8b03aa44f2a95a471a27fcff8e
01:(12.11.13 11:09:28)->Successful DeleteEntireFolder on 1 attempt
01:(12.11.13 11:09:28)->Deleting registry key: 2147483650, SOFTWARE\Symantec\SymcPushInstall
01:(12.11.13 11:09:28)->ERROR deleting registry key: 2147483650, SOFTWARE\Symantec\SymcPushInstall
01:(12.11.13 11:09:28)->ERROR: Win32: 2
01:(12.11.13 11:09:28)->Push install cleaned.

I verified that the target server's C:\ directory does not contain any files or directories starting with BEW- and that the registry key HKLM\SOFTWARE\Symantec exists but does not contain a subkey SymcPushInstall.

How can I proceed to locate the cause of this failure?

Thanks,
Tilman

Operating Systems:

Comments 6 CommentsJump to latest comment

w-d's picture

The default location of installation logs are here: C:\ProgramData\Symantec\Backup Exec\Logs

pkh's picture

If you forget something, do edit your previous answer and add it in.  Don't use multiple posts.

Artegic's picture

I uninstalled the agent locally and tried to push it again from the BE server, with the same result.

Then I tried to install the agent locally as described in TECH179142. This failed with the message:

---------------------------
Installationsfehler
---------------------------
FATAL ERROR: Während der Installation der Assembly "policy.9.0.Microsoft.VC90.MFCLOC,version="9.0.30729.6161",publicKeyToken="1fc8b3b9a1e18e3b", processorArchitecture="x86",type="win32-policy"" ist ein Fehler aufgetreten.
Weitere Informationen finden Sie unter Hilfe und Support.
---------------------------
OK  
---------------------------

Translation:

---------------------------
Installation Error
---------------------------
FATAL ERROR: During the installation of the assembly "policy.9.0.Microsoft.VC90.MFCLOC,version="9.0.30729.6161",publicKeyToken="1fc8b3b9a1e18e3b", processorArchitecture="x86",type="win32-policy"" an error has occurred.
You'll find further information in Help and Support.
---------------------------
OK  
---------------------------

(The last sentence is a lie. There's nothing on this in Help and Support.)

After clicking OK, the installer announces "action is being undone" followed by "the installation failed" and, on the next pane, the bizarre statement: "The wizard has been interrupted before Agent for Windows could be installed completely. The system hasn't been modified. Run the installation program again if you want to install the program. Click on 'Finish' to terminate the wizard or on the link 'Support web site' to display a list of possible causes for the erroneous installation." Needless to say, I didn't interrupt anything, running the installer again runs into exactly the same problem, and there's no link 'Support web site' anywhere to be seen.

I'm attaching the RAWSINST2012.HTM file (2.6 MB) packed into a ZIP file since the form won't let me upload an HTM file.

Thanks,
Tilman

AttachmentSize
log.zip 198.11 KB
pkh's picture

Check that the remote registry service is running on the remote server.

Artegic's picture

The remote registry service was running. I was able to connect to the Exchange server registry from the Backup Exec server with regedit just fine.

In our despair, with the Backup Exec agent gone from the Exchange server and no way to reinstall it, we decided that the wrath of our users was the lesser evil compared to going without backups, and did an unplanned reboot of both servers (Exchange and Backup Exec.) After that, remote installation went smoothly. I didn't re-test local installation because one unplanned downtime is enough.

Summary: Problem solved by reboot.

SOLUTION