Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Backup Exec 2014 agent install / c:\windows\installer

Created: 18 Jul 2014 • Updated: 24 Jul 2014 | 4 comments
This issue has been solved. See solution.

Using Backup Exec 2012 agents. Upgraded main server to 2014 version with latest hotfixes. Copied from "\Program Files\Symantec\Backup Exec\Agents" -directory all contents to network share. Copied that contents to server A1 to the local directory C:\Install.

Local install at server A1 fails. Started "RAWSX64\Setup.exe". Everything goes smoothly, until it fails and this shows at log:

07-18-2014,10:28:18 : Action 10:28:18: InstallFiles. Copying new files

 + 07-18-2014,10:28:18 : FATAL ERROR: Error 1316.A network error occurred while
attempting to read from the file C:\Windows\Installer\Symantec Backup Exec
Remote Agent for Windows Systems.msi

07-18-2014,10:49:07 : Action ended 10:49:07: InstallExecute. Return value 3.

For testing purposes, I copied "Symantec Backup Exec Remote Agent for Windows Systems.msi" file to c:\Windows\installer -directory. What happens now?

 + 07-18-2014,11:34:45 : FATAL ERROR: Error 1311.Source file not found:
C:\Windows\Installer\Data1.cab. Verify that the file exists and that you can
access it.

 + 07-18-2014,11:49:30 : User: Are you sure you want to cancel?

07-18-2014,11:49:30 : Threw Exception: The value of argument 'buttons' (260) is
invalid for Enum type 'MessageBoxButtons'. Parameter name: buttons

07-18-2014,11:49:30 : Action ended 11:49:30: InstallExecute. Return value 3.

So, it is missing another file. I don't think user should have to copy all files manually to C:\windows\installer -directory. There is something wrong here. Not sure how to proceed, and need to upgrade all clients. Push-install from server didn't work.

Tried to uninstall old agent from Control Panel. It worked successfully.

Install 2014 agent locally again. Now it worked!

Do I have to uninstall all clients manually and duplicate this procedure?

Operating Systems:

Comments 4 CommentsJump to latest comment

lmosla's picture

hi,

You should be able to just push the remote agent from the media server to update the remote agents  see:  http://www.symantec.com/docs/TECH179142

deeroad's picture

I uninstalled old agent and rebooted server, then remote install worked with one server. But another, similar server failed. It's log:

07-21-2014,12:24:27 : DIFXAPP: INFO: Copied file: 'C:\Program
Files\Symantec\Backup Exec\RAWS\VirtFile\VirtFile.sys' ->
'C:\Windows\system32\DRVSTORE\VirtFile_B222B73FA8342982FBC30D152B02EA04C0A63BEC\VirtFile.sys'.

07-21-2014,12:24:27 : DIFXAPP: INFO: Installing INF file
"C:\Windows\system32\DRVSTORE\VirtFile_B222B73FA8342982FBC30D152B02EA04C0A63BEC\VirtFile.inf"t
of Type 5.

07-21-2014,12:24:27 : DIFXAPP: INFO: installing class filter
'C:\Windows\system32\DRVSTORE\VirtFile_B222B73FA8342982FBC30D152B02EA04C0A63BEC\VirtFile.inf'

07-21-2014,12:24:27 : DIFXAPP: ERROR: The driver installation failed. Attempting
to undo system changes ... (Error code 0x65B: Function failed during execution.)

07-21-2014,12:24:27 : DIFXAPP: INFO: Driver store reference information does not
exist for service 'VirtFile'. So, no undo for this service.

07-21-2014,12:24:27 : DIFXAPP: INFO: Unable to revert to a previous driver store
for service 'VirtFile'.

07-21-2014,12:24:27 : DIFXAPP: INFO: Will attempt to uninstall the driver.

07-21-2014,12:24:27 : DIFXAPP: ERROR: Error unable to open service 'VirtFile' to
delete it because of error 0x424

07-21-2014,12:24:27 : DIFXAPP: INFO: Successfully removed
'{24B4B1C2-B6AD-4690-8455-DB29A706DCE1}' from reference list of driver store
entry ''

07-21-2014,12:24:27 : DIFXAPP: INFO: Driver Store entry '' removed.

07-21-2014,12:24:27 : DIFXAPP: INFO: RETURN: DriverPackageInstallW (0x65B)

07-21-2014,12:24:27 : DIFXAPP: ERROR: encountered while installing driver
package 'C:\Program Files\Symantec\Backup Exec\RAWS\VirtFile\VirtFile.inf'

07-21-2014,12:24:27 : DIFXAPP: ERROR: InstallDriverPackages failed with error
0x65B

07-21-2014,12:24:27 : DIFXAPP: RETURN: InstallDriverPackages() 1627 (0x65B)

07-21-2014,12:24:27 : CustomAction MsiInstallDrivers returned actual error code
1603 (note this may not be 100% accurate if translation happened inside sandbox)

07-21-2014,12:24:27 : Action ended 12:24:27: InstallExecute. Return value 3.

07-21-2014,12:24:27 : Action 12:24:27: Rollback. Rolling back action:

07-21-2014,12:24:27 : MsiInstallDrivers

07-21-2014,12:24:27 : MsiRollbackInstall

I found out link http://www.symantec.com/business/support/index?page=content&id=TECH135837 but it's no help, because there is nothing in those registry keys, they were already empty.

deeroad's picture

Devised a hack solution which seems to work. Log in to buggy server and do this:

netdom resetpwd /server:domaincontrollerhostname /userD:* /passwordD:*

and then reboot.

Use this script from Backup Exec server:

C:\scripts>type final.cmd
rem Give one parameter for remote server name
rem example: "final.cmd vm1"

c:\psexec.exe \\%1 netsh advfirewall set domainprofile settings remotemanagement enable

c:\psexec.exe \\%1 -s net stop "Backup Exec Error Recording Service"

c:\psexec.exe \\%1 -s net stop "Backup Exec Remote Agent for Windows"

wmic /node:"%1" product where name="Symantec Backup Exec Remote Agent for Windows" call uninstall

shutdown /m \\%1 /r

deeroad's picture

Uninstalling using wmic was not enough and it did leave programs + registry broken. I had this kind of situation:

Backup Exec 2014 agent did not install and finished with rollback

Backup Exec 2012 agent did not install : it detected earlier agent (probably 2010)

Solution was to use Microsoft Fixit and select manual, install-problems and choose Symantec Backup Exec from detected programs. It fixed something? and then, finally, 2014 agent could install.

http://support.microsoft.com/mats/Program_Install_and_Uninstall/

SOLUTION